dns/bind9-devel: update to latest commit
This commit is contained in:
parent
fccfb7d497
commit
0a3c220a10
@ -49,13 +49,13 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
|
||||
# XXX: remove tar:bz2
|
||||
USES= autoreconf compiler:c11 cpe libedit libtool pkgconfig ssl tar:bz2
|
||||
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
|
||||
ISCVERSION= 9.17.18a0.2021.09.20
|
||||
ISCVERSION= 9.17.18a0.2021.09.24
|
||||
# XXX: Remove gitlab
|
||||
USE_GITLAB= yes
|
||||
GL_SITE= https://gitlab.isc.org
|
||||
GL_ACCOUNT= isc-projects
|
||||
GL_PROJECT= bind9
|
||||
GL_COMMIT= be99fc92b63ef2463cadb2f90162982ed3ed289d
|
||||
GL_COMMIT= eeec53eb5da5c0968e099f01c6236127f9813a97
|
||||
|
||||
CPE_VENDOR= isc
|
||||
CPE_VERSION= ${ISCVERSION:C/-.*//}
|
||||
@ -92,21 +92,17 @@ CONFLICTS= bind911 bind912 bind913 bind914 bind916
|
||||
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
|
||||
OPTIONS_DEFAULT= DLZ_FILESYSTEM GSSAPI_NONE IDN JSON LMDB MANPAGES \
|
||||
OPTIONS_DEFAULT= GSSAPI_NONE IDN JSON LMDB MANPAGES \
|
||||
TCP_FASTOPEN DNSTAP
|
||||
OPTIONS_DEFINE= DNSTAP DOCS FIXED_RRSET GEOIP IDN JSON LARGE_FILE LMDB \
|
||||
MANPAGES OVERRIDECACHE PORTREVISION QUERYTRACE \
|
||||
START_LATE TCP_FASTOPEN
|
||||
|
||||
OPTIONS_GROUP= DLZ
|
||||
OPTIONS_GROUP_DLZ= DLZ_BDB DLZ_FILESYSTEM DLZ_LDAP DLZ_MYSQL \
|
||||
DLZ_POSTGRESQL DLZ_STUB
|
||||
|
||||
OPTIONS_SINGLE= GSSAPI
|
||||
OPTIONS_SINGLE_GSSAPI= GSSAPI_BASE GSSAPI_HEIMDAL GSSAPI_MIT GSSAPI_NONE
|
||||
|
||||
.if defined(BIND_TOOLS_SLAVE)
|
||||
OPTIONS_EXCLUDE= ${OPTIONS_GROUP_DLZ} DNSTAP DOCS GEOIP LMDB \
|
||||
OPTIONS_EXCLUDE= DNSTAP DOCS GEOIP LMDB \
|
||||
OVERRIDECACHE PORTREVISION QUERYTRACE START_LATE \
|
||||
TCP_FASTOPEN
|
||||
.endif # BIND_TOOLS_SLAVE
|
||||
@ -114,13 +110,6 @@ OPTIONS_EXCLUDE= ${OPTIONS_GROUP_DLZ} DNSTAP DOCS GEOIP LMDB \
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
CRYPTO_DESC= Choose which crypto engine to use
|
||||
DLZ_BDB_DESC= DLZ BDB driver
|
||||
DLZ_DESC= Dynamically Loadable Zones
|
||||
DLZ_FILESYSTEM_DESC= DLZ filesystem driver
|
||||
DLZ_LDAP_DESC= DLZ LDAP driver
|
||||
DLZ_MYSQL_DESC= DLZ MySQL driver (no threading)
|
||||
DLZ_POSTGRESQL_DESC= DLZ Postgres driver
|
||||
DLZ_STUB_DESC= DLZ stub driver
|
||||
DNSTAP_DESC= Provides fast passive logging of DNS messages
|
||||
FIXED_RRSET_DESC= Enable fixed rrset ordering
|
||||
GSSAPI_BASE_DESC= Using Heimdal in base
|
||||
@ -135,22 +124,6 @@ QUERYTRACE_DESC= Enable the very verbose query tracelogging
|
||||
START_LATE_DESC= Start BIND late in the boot process (see help)
|
||||
TCP_FASTOPEN_DESC= RFC 7413 support
|
||||
|
||||
DLZ_BDB_CONFIGURE_ON= --with-dlz-bdb=yes
|
||||
DLZ_BDB_USES= bdb
|
||||
|
||||
DLZ_FILESYSTEM_CONFIGURE_ON= --with-dlz-filesystem=yes
|
||||
|
||||
DLZ_LDAP_CONFIGURE_ON= --with-dlz-ldap=yes
|
||||
DLZ_LDAP_USE= OPENLDAP=yes
|
||||
|
||||
DLZ_MYSQL_CONFIGURE_ON= --with-dlz-mysql=yes
|
||||
DLZ_MYSQL_USES= mysql
|
||||
|
||||
DLZ_POSTGRESQL_CONFIGURE_ON= --with-dlz-postgres=yes
|
||||
DLZ_POSTGRESQL_USES= pgsql
|
||||
|
||||
DLZ_STUB_CONFIGURE_ON= --with-dlz-stub=yes
|
||||
|
||||
DNSTAP_CONFIGURE_ENABLE= dnstap
|
||||
DNSTAP_LIB_DEPENDS= libfstrm.so:devel/fstrm \
|
||||
libprotobuf-c.so:devel/protobuf-c
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1632153636
|
||||
SHA256 (isc-projects-bind9-be99fc92b63ef2463cadb2f90162982ed3ed289d_GL0.tar.gz) = 5bdcd0999fb97f70c8622b90270665cccba9467d943984ce06845545ef5c605f
|
||||
SIZE (isc-projects-bind9-be99fc92b63ef2463cadb2f90162982ed3ed289d_GL0.tar.gz) = 6192681
|
||||
TIMESTAMP = 1632746052
|
||||
SHA256 (isc-projects-bind9-eeec53eb5da5c0968e099f01c6236127f9813a97_GL0.tar.gz) = 771af250c5eed45337cc418827c7fad50ff6fbd09e31f40c126ceb96fd202bae
|
||||
SIZE (isc-projects-bind9-eeec53eb5da5c0968e099f01c6236127f9813a97_GL0.tar.gz) = 6123928
|
||||
|
@ -1,6 +1,6 @@
|
||||
Only select the "tools" part of bind for building.
|
||||
|
||||
--- Makefile.am.orig 2021-09-17 07:10:48 UTC
|
||||
--- Makefile.am.orig 2021-09-24 03:34:18 UTC
|
||||
+++ Makefile.am
|
||||
@@ -8,8 +8,6 @@ CLEANFILES = bind.keys.h
|
||||
bind.keys.h: bind.keys Makefile
|
||||
@ -11,14 +11,12 @@ Only select the "tools" part of bind for building.
|
||||
.PHONY: doc
|
||||
|
||||
EXTRA_DIST = \
|
||||
--- bin/Makefile.am.orig 2021-09-17 07:10:48 UTC
|
||||
--- bin/Makefile.am.orig 2021-09-24 03:34:18 UTC
|
||||
+++ bin/Makefile.am
|
||||
@@ -1 +1 @@
|
||||
-SUBDIRS = named rndc dig delv dnssec tools nsupdate check confgen tests plugins
|
||||
+SUBDIRS = dig delv dnssec tools nsupdate
|
||||
-SUBDIRS = named rndc dig delv dnssec tools nsupdate check confgen tests plugins
|
||||
+SUBDIRS = dig delv dnssec tools nsupdate
|
||||
--- bin/tools/Makefile.am.orig 2021-09-17 07:10:48 UTC
|
||||
--- bin/tools/Makefile.am.orig 2021-09-24 03:34:18 UTC
|
||||
+++ bin/tools/Makefile.am
|
||||
@@ -11,7 +11,6 @@ LDADD += \
|
||||
bin_PROGRAMS = \
|
||||
|
Loading…
Reference in New Issue
Block a user