- Update to 3.0.20071212

- Pass maintainership to submitter
- Enable 64-bit support (experimental per stated by the project web page)

PR:		ports/122337
Submitted by:	Wen heping <wenheping at gmail.com>
This commit is contained in:
Rong-En Fan 2008-04-06 06:35:14 +00:00
parent a423262c1a
commit 09ffa2e370
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=210630
5 changed files with 46 additions and 49 deletions

View File

@ -6,20 +6,24 @@
#
PORTNAME= simlib
PORTVERSION= 2.18.20061212
PORTVERSION= 3.0.20071212
CATEGORIES= science
MASTER_SITES= http://www.fit.vutbr.cz/~peringer/SIMLIB/source/
DISTNAME= SIMLIB-${PORTVERSION:S/.200/-200/}
DISTNAME= ${PORTNAME}3-${PORTVERSION:E}
MAINTAINER= ports@FreeBSD.org
MAINTAINER= wenheping@gmail.com
COMMENT= SIMulation LIBrary for C++ programming language
NO_WRKSUBDIR= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
MAKEFILE= Makefile.FreeBSD
WRKSRC= ${WRKDIR}/${PORTNAME}-3
# not 64bit ready
ONLY_FOR_ARCHS= i386
CXXFLAGS+= -fPIC
post-patch:
@${REINPLACE_CMD} -e 's|make|gmake|g' ${WRKSRC}/Makefile
@${MV} ${WRKSRC}/src/Makefile.FreeBSD-i386 ${WRKSRC}/src/Makefile
@${MV} ${WRKSRC}/examples/Makefile.FreeBSD-i386 ${WRKSRC}/examples/Makefile
@${MV} ${WRKSRC}/tests/Makefile.FreeBSD-i386 ${WRKSRC}/tests/Makefile
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
MD5 (SIMLIB-2.18-20061212.tar.gz) = cbd9680a4b57854f6200419e1e2dafb6
SHA256 (SIMLIB-2.18-20061212.tar.gz) = 99ea069cf7dde1304ae682275242d21166238cd4353fb3a51892b05de27f4711
SIZE (SIMLIB-2.18-20061212.tar.gz) = 360454
MD5 (simlib3-20071212.tar.gz) = 7d3b6123234b756b228a2e379982cd2e
SHA256 (simlib3-20071212.tar.gz) = 41784cf5ec79c91256625dc802befa5e70788e04f5bf2394c334d8c7837d69b2
SIZE (simlib3-20071212.tar.gz) = 1245014

View File

@ -1,39 +0,0 @@
--- Makefile.FreeBSD.orig Thu Dec 9 13:39:45 2004
+++ Makefile.FreeBSD Tue Jan 16 11:50:27 2007
@@ -52,18 +52,19 @@
LIBNAME=simlib
# name of the compiler for C and C++ language
-CC=gcc
-CXX=g++
+CC?=gcc
+CXX?=g++
#CXX=g++-3.4
# C++ compiler flags -- for development
-CXXFLAGS=-g -fPIC -O2 # with debug info
+CXXFLAGS?=-g -fPIC -O2 # with debug info
#CXXFLAGS=-pg -O2 -Wall # with profile support
#CXXFLAGS=-O2 -Wall -Weffc++ # PRODUCTION CODE
#CXXFLAGS=-O2 -Wall # PRODUCTION CODE
# installing program
-INSTALL=install -m0644
+INSTALL_DATA?=install -c -m 444
+INSTALL_PROGRAM?=install -c -s -m 555
# directory where the files will be installed in
PREFIX=/usr/local
@@ -237,9 +238,9 @@
#TODO: add version and symlink
install: all
echo "You should have permissions to install in " $(PREFIX)/
- $(INSTALL) $(SIMLIB_HEADERS) $(PREFIX)/include
- $(INSTALL) $(LIBNAME).a $(PREFIX)/lib/lib$(LIBNAME).a
- $(INSTALL) $(LIBNAME).so $(PREFIX)/lib/lib$(LIBNAME).so
+ $(INSTALL_DATA) $(SIMLIB_HEADERS) $(PREFIX)/include
+ $(INSTALL_PROGRAM) $(LIBNAME).a $(PREFIX)/lib/lib$(LIBNAME).a
+ $(INSTALL_PROGRAM) $(LIBNAME).so $(PREFIX)/lib/lib$(LIBNAME).so
#############################################################################
###############################

View File

@ -0,0 +1,17 @@
--- src/Makefile.FreeBSD-i386.orig 2008-04-06 14:24:46.000000000 +0800
+++ src/Makefile.FreeBSD-i386 2008-04-06 14:25:19.000000000 +0800
@@ -4,11 +4,11 @@
#
# name of the compiler for C and C++ language
-CC=gcc
-CXX=g++
+CC?=gcc
+CXX?=g++
# C++ compiler flags
-CXXFLAGS = -Wall -std=c++98 -fPIC
+CXXFLAGS ?= -Wall -std=c++98 -fPIC
CXXFLAGS += -O2 # with optimization
CXXFLAGS += -g # with debug info
#CXXFLAGS += -pg # with profile support

View File

@ -0,0 +1,15 @@
--- src/Makefile.generic.orig 2008-04-06 14:25:38.000000000 +0800
+++ src/Makefile.generic 2008-04-06 14:26:50.000000000 +0800
@@ -225,9 +225,9 @@
#TODO: add version and symlink
install: all
install -d $(PREFIX)/include $(PREFIX)/lib
- install -m0644 $(SIMLIB_HEADERS) $(PREFIX)/include
- install -m0644 $(LIBNAME).a $(PREFIX)/lib/lib$(LIBNAME).a
- install -m0644 $(LIBNAME).so $(PREFIX)/lib/lib$(LIBNAME).so
+ $(BSD_INSTALL_DATA) $(SIMLIB_HEADERS) $(PREFIX)/include
+ $(BSD_INSTALL_PROGRAM) $(LIBNAME).a $(PREFIX)/lib/lib$(LIBNAME).a
+ $(BSD_INSTALL_PROGRAM) $(LIBNAME).so $(PREFIX)/lib/lib$(LIBNAME).so
@if ! grep '^'$(PREFIX)/lib'$$' /etc/ld.so.conf >/dev/null; then \
echo "Add $(PREFIX)/lib to /etc/ld.so.conf "; \
fi