This commit is contained in:
Vanilla I. Shu 2014-06-10 02:37:54 +00:00
parent affe10028a
commit 09f37da63d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=357240
2 changed files with 17 additions and 1 deletions

View File

@ -19,7 +19,6 @@ PLIST_FILES= lib/libpdbtools.so \
bin/csv2pdb \
bin/pdb2csv
NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e "s|-Wno-deprecated|& -fPIC -DPIC|" \
${WRKSRC}/libflatfile/Makefile.in ${WRKSRC}/libpalm/Makefile.in \

View File

@ -0,0 +1,17 @@
--- flatfile/Makefile.in.orig 2014-06-10 10:35:56.370537068 +0800
+++ flatfile/Makefile.in 2014-06-10 10:36:30.106537760 +0800
@@ -95,10 +95,10 @@ distrib: $(ALL)
strip $(ALL)
install: all
- $(INSTALL) -d $(bindir)
- $(INSTALL) -d $(libdir)
- $(INSTALL) -s $(TARGETS) $(libdir)
- $(INSTALL) -s $(PROGRAMS:%=%$(EXEEXT)) $(bindir)
+ $(INSTALL) -d $(DESTDIR)$(bindir)
+ $(INSTALL) -d $(DESTDIR)$(libdir)
+ $(INSTALL) -s $(TARGETS) $(DESTDIR)$(libdir)
+ $(INSTALL) -s $(PROGRAMS:%=%$(EXEEXT)) $(DESTDIR)$(bindir)
.SUFFIXES:
.SUFFIXES: .c .cpp .lo .o .obj