Quoting the submitter:
---snip--- - Revert the partially enabled building and usage of the libgmp version shipping with ssh introduced with the upgrade to 1.2.33. For -current depend on math/libgmp-freebsd and use the libgmp in the base system for -stable like this port did before. This fixes compilation on -current and turns of the annoying errors when the configure of the ssh-enclosed libgmp tests the optimisations using the wrong assembler- syntax on 4-stable. The later causes configure to hang on 3-stable. - Don't define 'REALLY_WANT_SSH=1' in the Makefile else the FORBIDDEN for FreeBSD systems shipping with OpenSSH in the base-distribution and not defining 'REALLY_WANT_SSH' is useless. This was also broken with the last commit. Tested on 5.0-current, 4-stable and 3-stable. ---snip--- Submitted by: marius@alchemy.franken.de
This commit is contained in:
parent
3266ee3cdb
commit
09e4bf1048
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=68808
@ -1,4 +1,3 @@
|
||||
REALLY_WANT_SSH=1
|
||||
# New ports collection makefile for: ssh
|
||||
# Date created: 30 Jul 1995
|
||||
# Whom: torstenb@FreeBSD.org
|
||||
@ -11,7 +10,7 @@ REALLY_WANT_SSH=1
|
||||
|
||||
PORTNAME= ssh
|
||||
PORTVERSION= 1.2.33
|
||||
PORTREVISION= 0
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= security ipv6
|
||||
MASTER_SITES= ftp://ftp.tokyonet.ad.jp/pub/security/ssh/ \
|
||||
ftp://ftp.tokyonet.ad.jp/pub/security/ssh/old/ \
|
||||
@ -67,7 +66,6 @@ CONFIGURE_ARGS+= --without-idea
|
||||
|
||||
.if ${OSVERSION} > 500023
|
||||
LIB_DEPENDS+= gmp.3:${PORTSDIR}/math/libgmp-freebsd
|
||||
#LIB_DEPENDS+= gmp.4:${PORTSDIR}/math/libgmp3
|
||||
MAKE_ENV+= GMPINCDIR="${LOCALBASE}/include" \
|
||||
GMPLIBDIR="${LOCALBASE}/lib"
|
||||
.endif
|
||||
|
@ -1,31 +1,41 @@
|
||||
--- Makefile.in.orig Thu Jan 17 05:35:34 2002
|
||||
+++ Makefile.in Sat Jun 29 20:37:40 2002
|
||||
@@ -307,11 +307,11 @@
|
||||
--- Makefile.in.orig Thu Jan 17 14:35:34 2002
|
||||
+++ Makefile.in Mon Oct 21 23:43:07 2002
|
||||
@@ -307,11 +307,13 @@
|
||||
|
||||
SHELL = /bin/sh
|
||||
|
||||
-GMPDIR = gmp-2.0.2-ssh-2
|
||||
+GMPDIR = $(PREFIX)
|
||||
GMPLIBS = @ssh_gmp_ldadd_options@
|
||||
-GMPLIBS = @ssh_gmp_ldadd_options@
|
||||
-GMPDEP = $(GMPDIR)/gmp.h $(GMPDIR)/libgmp.a
|
||||
+GMPDEP =
|
||||
+GMPDIR =
|
||||
+GMPINCDIR ?= /usr/include
|
||||
+GMPLIBDIR ?= /usr/lib
|
||||
+GMPLIBS = -L$(GMPLIBDIR) -lgmp
|
||||
+GMPDEP = $(GMPINCDIR)/gmp.h $(GMPLIBDIR)/libgmp.a
|
||||
|
||||
-ZLIBDIR = zlib-1.0.4
|
||||
+ZLIBDIR = /usr/lib
|
||||
ZLIBDEP = $(ZLIBDIR)/libz.a
|
||||
ZLIBLIBS = @ssh_zlib_ldadd_options@
|
||||
|
||||
@@ -418,7 +418,7 @@
|
||||
@@ -418,7 +420,7 @@
|
||||
$(CC) -o rfc-pg rfc-pg.o
|
||||
|
||||
.c.o:
|
||||
- $(CC) -c -I. $(KERBEROS_INCS) -I$(srcdir)/$(GMPDIR) -I$(srcdir)/$(ZLIBDIR) $(DEFS) -DHOST_KEY_FILE=\"$(HOST_KEY_FILE)\" -DHOST_CONFIG_FILE=\"$(HOST_CONFIG_FILE)\" -DSERVER_CONFIG_FILE=\"$(SERVER_CONFIG_FILE)\" -DSSH_PROGRAM=\"$(SSH_PROGRAM)\" -DETCDIR=\"$(etcdir)\" -DPIDDIR=\"$(piddir)\" -DSSH_BINDIR=\"$(bindir)\" -DTIS_MAP_FILE=\"$(TIS_MAP_FILE)\" $(CFLAGS) $(X_CFLAGS) $<
|
||||
+ $(CC) -c -I. $(KERBEROS_INCS) -I$(srcdir)/$(GMPDIR) $(DEFS) -DHOST_KEY_FILE=\"$(HOST_KEY_FILE)\" -DHOST_CONFIG_FILE=\"$(HOST_CONFIG_FILE)\" -DSERVER_CONFIG_FILE=\"$(SERVER_CONFIG_FILE)\" -DSSH_PROGRAM=\"$(SSH_PROGRAM)\" -DETCDIR=\"$(etcdir)\" -DPIDDIR=\"$(piddir)\" -DSSH_BINDIR=\"$(bindir)\" -DTIS_MAP_FILE=\"$(TIS_MAP_FILE)\" $(CFLAGS) $(X_CFLAGS) $<
|
||||
+ $(CC) -c -I. $(KERBEROS_INCS) -I$(GMPINCDIR) $(DEFS) -DHOST_KEY_FILE=\"$(HOST_KEY_FILE)\" -DHOST_CONFIG_FILE=\"$(HOST_CONFIG_FILE)\" -DSERVER_CONFIG_FILE=\"$(SERVER_CONFIG_FILE)\" -DSSH_PROGRAM=\"$(SSH_PROGRAM)\" -DETCDIR=\"$(etcdir)\" -DPIDDIR=\"$(piddir)\" -DSSH_BINDIR=\"$(bindir)\" -DTIS_MAP_FILE=\"$(TIS_MAP_FILE)\" $(CFLAGS) $(X_CFLAGS) $<
|
||||
|
||||
sshd: $(SSHD_OBJS) $(GMPDEP) $(RSAREFDEP) $(ZLIBDEP)
|
||||
-rm -f sshd
|
||||
@@ -466,7 +466,7 @@
|
||||
$(GMPDIR)/libgmp.a:
|
||||
@@ -461,12 +463,12 @@
|
||||
sed "s#&PERL&#$(PERL)#" <$(srcdir)/make-ssh-known-hosts.pl >make-ssh-known-hosts
|
||||
chmod +x make-ssh-known-hosts
|
||||
|
||||
-GMP_COPY_SOURCES = mpz_gcd.c mpz_powm.c mpz_pow_ui.c mpz_add.c mpz_sub.c \
|
||||
+XXX_DONT_GMP_COPY_SOURCES = mpz_gcd.c mpz_powm.c mpz_pow_ui.c mpz_add.c mpz_sub.c \
|
||||
mpz_mul.c mpz_cmp.c mpz_sqrtrem.c
|
||||
-$(GMPDIR)/libgmp.a:
|
||||
+XXX_DONT_$(GMPDIR)/libgmp.a:
|
||||
cd $(GMPDIR); $(MAKE)
|
||||
|
||||
-$(ZLIBDEP):
|
||||
@ -33,7 +43,7 @@
|
||||
-if test '!' -d $(ZLIBDIR); then \
|
||||
mkdir $(ZLIBDIR); \
|
||||
cp $(srcdir)/$(ZLIBDIR)/Makefile $(ZLIBDIR); \
|
||||
@@ -530,7 +530,7 @@
|
||||
@@ -530,7 +532,7 @@
|
||||
# (otherwise it can only log in as the user it runs as, and must be
|
||||
# bound to a non-privileged port). Also, password authentication may
|
||||
# not be available if non-root and using shadow passwords.
|
||||
@ -42,7 +52,7 @@
|
||||
-rm -f $(install_prefix)$(bindir)/ssh1.old
|
||||
-chmod 755 $(install_prefix)$(bindir)/ssh1
|
||||
-chmod 755 $(install_prefix)$(bindir)/ssh
|
||||
@@ -756,7 +756,7 @@
|
||||
@@ -756,7 +758,7 @@
|
||||
(echo "s/\.$$old_version\"/.$$new_version\"/g"; echo w; echo q) | ed $(srcdir)/version.h >/dev/null
|
||||
|
||||
depend:
|
||||
|
@ -358,7 +358,7 @@
|
||||
AC_MSG_RESULT($PIDDIR)
|
||||
|
||||
-AC_CONFIG_SUBDIRS(gmp-2.0.2-ssh-2)
|
||||
+AC_CONFIG_SUBDIRS(gmp-2.0.2-ssh-2)
|
||||
+#AC_CONFIG_SUBDIRS(gmp-2.0.2-ssh-2)
|
||||
|
||||
AC_ARG_PROGRAM
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user