Update to 2011.07.09

PR:	ports/158951
Submitted by:	John Hixson
Sponsored by:	iXsystems
This commit is contained in:
Josh Paetzel 2011-07-18 14:20:11 +00:00
parent 46f6c92a05
commit 09c84a461f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=277902
7 changed files with 56 additions and 40 deletions

View File

@ -6,9 +6,9 @@
#
PORTNAME= pianobar
PORTVERSION= 2011.04.27
PORTVERSION= 2011.07.09
CATEGORIES= audio
MASTER_SITES= http://6xq.net/media/00/16/
MASTER_SITES= http://6xq.net/static/projects/${PORTNAME}/
MAINTAINER= john@pcbsd.org
COMMENT= Command line Pandora player
@ -17,6 +17,8 @@ LIB_DEPENDS= ao:${PORTSDIR}/audio/libao \
faad:${PORTSDIR}/audio/faad \
mad:${PORTSDIR}/audio/libmad
LICENSE= MIT
MAN1= pianobar.1
MAN_COMPRESSED= no
@ -25,4 +27,6 @@ PLIST_FILES= bin/pianobar
USE_BZIP2= yes
USE_GMAKE= yes
CFLAGS=
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
SHA256 (pianobar-2011.04.27.tar.bz2) = e4b1354974af36d32dc34b3329bd09f3e0437127539024cf7add61facbb621dc
SIZE (pianobar-2011.04.27.tar.bz2) = 61317
SHA256 (pianobar-2011.07.09.tar.bz2) = e8ecc60637b57a807e3db35242e968fa8ce60b0db8a3268acd52a16c027e89b4
SIZE (pianobar-2011.07.09.tar.bz2) = 64497

View File

@ -1,16 +1,35 @@
--- Makefile.orig 2011-04-27 14:11:06.000000000 -0500
+++ Makefile 2011-04-30 09:03:16.000000000 -0500
@@ -4,11 +4,10 @@
--- Makefile.orig 2011-07-09 03:40:54.000000000 -0500
+++ Makefile 2011-07-18 09:00:04.740569788 -0500
@@ -4,12 +4,12 @@
BINDIR:=${PREFIX}/bin
LIBDIR:=${PREFIX}/lib
INCDIR:=${PREFIX}/include
-MANDIR:=${PREFIX}/share/man
+MANDIR:=${PREFIX}/man
DYNLINK:=0
-CFLAGS:=-O2 -DNDEBUG
+CFLAGS:=-Wall -std=c99 -O2 -DNDEBUG -pedantic -I/usr/local/include -L/usr/local/lib -lao
LDFLAGS:=
-CC:=c99
PIANOBAR_DIR=src
PIANOBAR_SRC=\
# Respect environment variables set by user; does not work with :=
ifeq (${CFLAGS},)
- CFLAGS=-O2 -DNDEBUG
+ CFLAGS=-O2 -DNDEBUG -I/usr/local/include
endif
ifeq (${CC},cc)
CC=c99
@@ -74,7 +74,7 @@
LIBFAAD_LDFLAGS=
else
LIBFAAD_CFLAGS=-DENABLE_FAAD
- LIBFAAD_LDFLAGS=-lfaad
+ LIBFAAD_LDFLAGS=-L/usr/local/lib -lfaad
endif
ifeq (${DISABLE_MAD}, 1)
@@ -82,7 +82,7 @@
LIBMAD_LDFLAGS=
else
LIBMAD_CFLAGS=-DENABLE_MAD
- LIBMAD_LDFLAGS=-lmad
+ LIBMAD_LDFLAGS=-L/usr/local/lib -lmad
endif
# build pianobar

View File

@ -1,12 +1,10 @@
--- src/main.c.orig 2011-01-24 04:00:25.000000000 -0800
+++ src/main.c 2011-04-07 14:28:49.000000000 -0700
@@ -21,9 +21,6 @@
--- src/main.c.orig 2011-07-09 01:40:54.000000000 -0700
+++ src/main.c 2011-07-14 12:01:40.000000000 -0700
@@ -21,7 +21,6 @@
THE SOFTWARE.
*/
-#define _POSIX_C_SOURCE 1 /* fileno() */
-#define _BSD_SOURCE /* strdup() */
-
#define _BSD_SOURCE /* strdup() */
/* system includes */
#include <stdlib.h>
#include <string.h>

View File

@ -1,11 +1,10 @@
--- src/terminal.c.orig 2011-01-24 04:00:25.000000000 -0800
+++ src/terminal.c 2011-04-07 14:29:03.000000000 -0700
@@ -21,9 +21,6 @@
--- src/terminal.c.orig 2011-07-09 01:40:54.000000000 -0700
+++ src/terminal.c 2011-07-14 12:07:01.000000000 -0700
@@ -21,7 +21,6 @@
THE SOFTWARE.
*/
-#define _POSIX_C_SOURCE 1 /* fileno() */
-#define _BSD_SOURCE /* setlinebuf() */
-
#define _BSD_SOURCE /* setlinebuf() */
#include <termios.h>
#include <stdio.h>

View File

@ -1,12 +1,10 @@
--- src/ui.c.orig 2011-01-24 04:00:25.000000000 -0800
+++ src/ui.c 2011-04-07 14:29:19.000000000 -0700
@@ -23,9 +23,6 @@
--- src/ui.c.orig 2011-07-09 01:40:54.000000000 -0700
+++ src/ui.c 2011-07-14 12:02:04.000000000 -0700
@@ -23,7 +23,6 @@
/* everything that interacts with the user */
-#define _POSIX_C_SOURCE 1 /* fileno() */
-#define _BSD_SOURCE /* strdup() */
-
#define _BSD_SOURCE /* strdup() */
#include <stdio.h>
#include <stdarg.h>
#include <unistd.h>

View File

@ -1,12 +1,10 @@
--- src/libwaitress/waitress.c.orig 2011-01-24 04:00:25.000000000 -0800
+++ src/libwaitress/waitress.c 2011-04-07 14:29:37.000000000 -0700
@@ -21,9 +21,6 @@
--- src/libwaitress/waitress.c.orig 2011-07-09 01:40:54.000000000 -0700
+++ src/libwaitress/waitress.c 2011-07-14 12:02:14.000000000 -0700
@@ -21,7 +21,6 @@
THE SOFTWARE.
*/
-#define _POSIX_C_SOURCE 1 /* required by getaddrinfo() */
-#define _BSD_SOURCE /* snprintf() */
-
#define _BSD_SOURCE /* snprintf() */
#include <sys/types.h>
#include <sys/socket.h>
#include <netdb.h>