- Fix build with clang

PR:		175022
Submitted by:	Ports Fury
This commit is contained in:
Martin Wilke 2013-02-07 14:36:55 +00:00
parent 76b00bd071
commit 09b95bf774
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=311851
4 changed files with 35 additions and 3 deletions

View File

@ -3,26 +3,34 @@
PORTNAME= linsmith
PORTVERSION= 0.99.24
PORTREVISION= 1
CATEGORIES= science hamradio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Smith charting program
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
LICENSE= GPLv2 # (or later)
USE_GNOME= libgnomeui libxml2
USE_ICONV= yes
USE_GETTEXT= yes
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
USE_GCC= any
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
post-patch:
@${CP} ${FILESDIR}/carg.c ${WRKSRC}/src
@${REINPLACE_CMD} -e \
'/^Icon/s|=.*|=linsmith_icon|' ${WRKSRC}/linsmith.desktop
post-install:
@${MKDIR} ${DESKTOPDIR}
(cd ${WRKSRC} \
&& ${INSTALL_DATA} linsmith.desktop ${DESKTOPDIR})
(cd ${WRKSRC} \
&& ${INSTALL_DATA} linsmith_icon.xpm ${PREFIX}/share/pixmaps)
.include <bsd.port.mk>

View File

@ -0,0 +1,10 @@
--- src/element.c.orig 2011-06-23 01:10:42.000000000 +0900
+++ src/element.c 2012-10-21 04:47:51.000000000 +0900
@@ -306,6 +306,7 @@
}
+void
clear_element_lnlist(chart_lnlist *lnlst)
{
GList *l;

View File

@ -0,0 +1,11 @@
--- src/remote.c.orig 2007-11-12 12:09:03.000000000 +0900
+++ src/remote.c 2012-10-21 04:50:16.000000000 +0900
@@ -36,7 +36,7 @@
remove_fifos(gpointer data)
{
// if not even enabled manually, just go away
- if (pref.rem_mode != REMOTE_SOCK) return;
+ if (pref.rem_mode != REMOTE_SOCK) return 0;
printf("Removing the remote pipes\n");
close(pref.inpipe);

View File

@ -1,4 +1,5 @@
bin/linsmith
share/applications/linsmith.desktop
%%DATADIR%%/6-1.circ
%%DATADIR%%/6-4.circ
%%DATADIR%%/6-4.load
@ -20,7 +21,9 @@ share/locale/hu/LC_MESSAGES/linsmith.mo
share/locale/it/LC_MESSAGES/linsmith.mo
share/locale/sv/LC_MESSAGES/linsmith.mo
share/locale/zh/LC_MESSAGES/linsmith.mo
share/pixmaps/linsmith_icon.xpm
share/pixmaps/linsmith/smith4.png
share/pixmaps/linsmith/smithent.png
@dirrm share/pixmaps/linsmith
@dirrm %%DATADIR%%
@dirrmtry share/applications