- Fix build on 5-current

PR:		46436
Submitted by:	Ports Fury
This commit is contained in:
Ying-Chieh Liao 2002-12-22 18:05:35 +00:00
parent 36aea8a3af
commit 09b251be4f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=71799
7 changed files with 66 additions and 12 deletions

View File

@ -13,15 +13,20 @@ MASTER_SITES= http://www.ece.ucdavis.edu/~kenelson/gtk-glarea/dist/
MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
LIB_DEPENDS= gtkmm.2:${PORTSDIR}/x11-toolkits/gtk-- \
gtkgl.5:${PORTSDIR}/x11-toolkits/gtkglarea
USE_MESA= yes
USE_GNOMENG= yes
USE_GNOME= gtk12
USE_MESA= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}"
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-lib-GL
INSTALLS_SHLIB= yes
CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib -lGL -lGLU -lglut \
${PTHREAD_LIBS}
.include <bsd.port.mk>

View File

@ -1,10 +0,0 @@
--- examples/extra/events.cc.orig Wed Aug 28 14:04:59 2002
+++ examples/extra/events.cc Wed Aug 28 14:05:23 2002
@@ -28,6 +28,7 @@
#include <GL/gl.h>
#include <GL/glu.h>
+using namespace std;
void gl() {
static int displaylist=-1;

View File

@ -0,0 +1,19 @@
--- examples/extra/events.cc.orig Thu Jan 27 09:15:24 2000
+++ examples/extra/events.cc Fri Dec 20 09:45:21 2002
@@ -18,7 +18,7 @@
*********************************************************************/
#include <string>
-#include <iostream.h>
+#include <iostream>
#include <GL/glx.h>
#include <glib.h>
#include <gdk/gdk.h>
@@ -28,6 +28,7 @@
#include <GL/gl.h>
#include <GL/glu.h>
+using namespace std;
void gl() {
static int displaylist=-1;

View File

@ -0,0 +1,20 @@
--- examples/pickmm/pick.cc.orig Thu Jan 27 09:15:24 2000
+++ examples/pickmm/pick.cc Fri Dec 20 09:42:57 2002
@@ -16,7 +16,7 @@
Software Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
*********************************************************************/
-#include <iostream.h>
+#include <iostream>
#include <GL/gl.h>
#include <GL/glu.h>
@@ -28,6 +28,8 @@
#include <gtk--.h>
#include <gtkgl--/glarea.h>
+
+using namespace std;
// WARNING: Verbosity level set to maximum, prepare to get an ear full

View File

@ -0,0 +1,20 @@
--- examples/planetmm/planet.cc.orig Thu Jan 27 09:15:25 2000
+++ examples/planetmm/planet.cc Fri Dec 20 09:43:57 2002
@@ -16,7 +16,7 @@
Software Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
*********************************************************************/
-#include <iostream.h>
+#include <iostream>
#include <GL/glx.h>
#include <glib.h>
#include <gdk/gdk.h>
@@ -27,6 +27,8 @@
#include <GL/gl.h>
#include <math.h>
#include "globeGL.hh"
+
+using namespace std;
// WARNING: Verbosity level set to maximum, prepare to get an ear full