wmcalc is a simple dockable calculator
This commit is contained in:
parent
8d3d318a69
commit
097b78a84f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=27099
24
math/wmcalc/Makefile
Normal file
24
math/wmcalc/Makefile
Normal file
@ -0,0 +1,24 @@
|
||||
# New ports collection makefile for: wmcalc
|
||||
# Version required: 0.1
|
||||
# Date created: 28 March 2000
|
||||
# Whom: Chris D. Faulhaber <jedgar@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
DISTNAME= wmcalc-0.1
|
||||
CATEGORIES= math windowmaker
|
||||
MASTER_SITES= http://members.access1.net/ehflora/wmcalc/
|
||||
|
||||
MAINTAINER= jedgar@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
|
||||
|
||||
ALL_TARGET= wmcalc
|
||||
USE_X_PREFIX= yes
|
||||
WRKSRC= ${WRKDIR}/wmcalc
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/wmcalc ${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
1
math/wmcalc/distinfo
Normal file
1
math/wmcalc/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (wmcalc-0.1.tar.gz) = a4f5e639e115b2c20c8ee604cc0ce449
|
23
math/wmcalc/files/patch-aa
Normal file
23
math/wmcalc/files/patch-aa
Normal file
@ -0,0 +1,23 @@
|
||||
--- Makefile.orig Sat Nov 27 01:40:16 1999
|
||||
+++ Makefile Tue Mar 28 07:35:20 2000
|
||||
@@ -1,15 +1,15 @@
|
||||
-INCLUDES =-I/usr/X11R6/include/X11 -I/usr/local/include -I/usr/include/X11R6/X11
|
||||
-LIBINC =-L/usr/X11R6/lib -L/usr/include/lib
|
||||
-LIBS = -lX11 -lXpm -lXext
|
||||
+INCLUDES=-I${PREFIX}/include
|
||||
+LIBINC=-L${PREFIX}/lib
|
||||
+LIBS = -lX11 -lXpm -lXext -lm
|
||||
|
||||
TARGET = wmcalc
|
||||
OBJECTS = wmcalc.o readln.o wmcalcswitch.o wmcalcfunc.o
|
||||
|
||||
.c.o:
|
||||
- gcc -O2 -c -Wall ${INCLUDES} ${FLAGS} $< -o $*.o
|
||||
+ gcc ${CFLAGS} -c -Wall ${INCLUDES} ${FLAGS} $< -o $*.o
|
||||
|
||||
${TARGET}: ${OBJECTS}
|
||||
- gcc -O2 -o ${TARGET} ${OBJECTS} ${LIBINC} ${LIBS}
|
||||
+ gcc ${CFLAGS} -o ${TARGET} ${OBJECTS} ${LIBINC} ${LIBS}
|
||||
|
||||
clean::
|
||||
for i in ${OBJECTS}; do if [ -e $$i ] ; then rm $$i; fi; done
|
19
math/wmcalc/files/patch-ab
Normal file
19
math/wmcalc/files/patch-ab
Normal file
@ -0,0 +1,19 @@
|
||||
--- wmcalc.c.orig Mon Dec 20 00:17:29 1999
|
||||
+++ wmcalc.c Tue Mar 28 07:34:28 2000
|
||||
@@ -10,11 +10,11 @@
|
||||
* development of wmbutton. I'm listing them here partially as thanks for
|
||||
* helping out, catching bugs in the code, etc.
|
||||
***********************************************************************/
|
||||
-#include <Xlib.h>
|
||||
-#include <Xutil.h>
|
||||
-#include <xpm.h>
|
||||
-#include <extensions/shape.h>
|
||||
-#include <keysym.h>
|
||||
+#include <X11/Xlib.h>
|
||||
+#include <X11/Xutil.h>
|
||||
+#include <X11/xpm.h>
|
||||
+#include <X11/extensions/shape.h>
|
||||
+#include <X11/keysym.h>
|
||||
#include <stdio.h>
|
||||
#include <math.h>
|
||||
#include <stdlib.h>
|
1
math/wmcalc/pkg-comment
Normal file
1
math/wmcalc/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
Simple dockable calculator
|
6
math/wmcalc/pkg-descr
Normal file
6
math/wmcalc/pkg-descr
Normal file
@ -0,0 +1,6 @@
|
||||
Simple dockable calculator
|
||||
|
||||
WWW: http://members.access1.net/ehflora/
|
||||
|
||||
- Chris D. Faulhaber
|
||||
<jedgar@FreeBSD.org>
|
1
math/wmcalc/pkg-plist
Normal file
1
math/wmcalc/pkg-plist
Normal file
@ -0,0 +1 @@
|
||||
bin/wmcalc
|
Loading…
Reference in New Issue
Block a user