Initial import of clo++-0.3.0

clo++ is a command line parser generator for C++
This commit is contained in:
Kevin Lo 2001-01-30 10:21:27 +00:00
parent 87b755e051
commit 09401b51ae
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=37785
8 changed files with 62 additions and 0 deletions

View File

@ -11,6 +11,7 @@
SUBDIR += cdif
SUBDIR += cdiff
SUBDIR += chpp
SUBDIR += clo++
SUBDIR += cocoon
SUBDIR += code2html
SUBDIR += cole

23
textproc/clo++/Makefile Normal file
View File

@ -0,0 +1,23 @@
# New ports collection makefile for: clo++
# Date created: 30 January 2001
# Whom: Kevin Lo <kevlo@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= clo++
PORTVERSION= 0.3.0
CATEGORIES= textproc
MASTER_SITES= http://pmade.org/~pjones/software/clo++/download/
MAINTAINER= kevlo@FreeBSD.org
LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
GNU_CONFIGURE= yes
post-install:
@${MKDIR} ${PREFIX}/share/doc/clo++
${INSTALL_DATA} ${WRKSRC}/doc/handbook.html ${PREFIX}/share/doc/clo++
.include <bsd.port.mk>

1
textproc/clo++/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (clo++-0.3.0.tar.gz) = 06609b8fff514a50cb539ab14e9a97c9

View File

@ -0,0 +1,13 @@
--- configure.orig Tue Jan 30 17:09:05 2001
+++ configure Tue Jan 30 17:12:33 2001
@@ -1237,8 +1237,8 @@
*** variable to the full path to the xml-config program
*** that got installed with libxml2"
-# Extract the first word of "xml-config", so it can be a program name with args.
-set dummy xml-config; ac_word=$2
+# Extract the first word of "xml2-config", so it can be a program name with args.
+set dummy xml2-config; ac_word=$2
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
echo "configure:1244: checking for $ac_word" >&5
if eval "test \"`echo '$''{'ac_cv_path_XML_CONFIG'+set}'`\" = set"; then

View File

@ -0,0 +1,11 @@
--- src/XML.hh.orig Tue Jan 30 17:15:36 2001
+++ src/XML.hh Tue Jan 30 17:15:49 2001
@@ -40,7 +40,7 @@
// Standard Includes
#include <iostream>
#include <string>
-#include <libxml/parser.h>
+#include <libxml2/parser.h>
// Local Includes
#include "Option.hh"

View File

@ -0,0 +1 @@
Command line parser generator

9
textproc/clo++/pkg-descr Normal file
View File

@ -0,0 +1,9 @@
Clo++ is a command line option parser generator for C++.
It generates a C++ header file with a class that can parse your
command line and supports just about anything that you want to do
with your command line. It also generates usage information and
can handle subcommands that take their own options. clo++ is itself
written in C++ and uses a command line option parser that it
generated.
WWW: http://pmade.org/~pjones/software/clo++

3
textproc/clo++/pkg-plist Normal file
View File

@ -0,0 +1,3 @@
bin/clo++
share/doc/clo++/handbook.html
@dirrm share/doc/clo++