Don't allow GCC to optimize away -lm test, and thus unbreak.

Reported by:	kris
Approved by:	portmgr (krion), fjoe (mentor, implicit)
This commit is contained in:
Alexey Dokuchaev 2004-10-07 18:48:29 +00:00
parent ff63c67768
commit 0925066a54
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=118579
2 changed files with 13 additions and 9 deletions

View File

@ -42,12 +42,6 @@ MAKE_ENV= CPU=FreeBSD MAPLE_LIB=${MAPLE_LIB}
AC_FAKE_FILES= aclocal.m4 config.h.in stamp-h stamp-h.in
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 502126
BROKEN= "Does not compile on FreeBSD >= 5.x"
.endif
post-configure:
cd ${WRKSRC}; ${TOUCH} ${AC_FAKE_FILES}
${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${TOUCH}
@ -74,4 +68,4 @@ post-install:
${INSTALL_MAN} ${WRKSRC}/doc/html/pix/*.gif ${DOCSDIR}/html/pix
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -11,7 +11,17 @@
*) MACHTYPE=$target_os
AC_DEFINE_UNQUOTED(MACHTYPE, "$MACHTYPE")
;;
@@ -471,7 +471,8 @@
@@ -459,7 +463,8 @@
# mbp Mon May 8 18:47:33 2000
AC_MSG_CHECKING([whether we need to link -lm to get math functions])
AC_TRY_LINK([ #include <math.h> ],
- [ double s = sin(1.5); ],
+ [ double s = sin(1.5);
+ return ((int)s); ],
[ MATHLIB=""
AC_MSG_RESULT([no]) ],
[ MATHLIB=-lm
@@ -471,7 +476,8 @@
AC_MSG_CHECKING([whether we need to link -lsocket to get socket()])
@ -21,7 +31,7 @@
[ int s = socket(AF_UNIX, SOCK_STREAM, 0); ],
[ SOCKETLIBS=""
AC_MSG_RESULT([no]) ],
@@ -491,10 +492,10 @@
@@ -491,10 +497,10 @@
AC_CHECK_HEADERS(fpu_control.h i386/fpu_control.h netinet/in.h)