Tools to help hacking Allwinner A10 (aka sun4i) based devices and possibly
it's successors, that's why the 'x' in the package name. WWW: https://github.com/linux-sunxi/sunxi-tools PR: 213250 Submitted by: manu
This commit is contained in:
parent
0825b181a7
commit
08c13bcac5
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=446592
@ -168,6 +168,7 @@
|
||||
SUBDIR += spandsp
|
||||
SUBDIR += splat
|
||||
SUBDIR += sredird
|
||||
SUBDIR += sunxi-tools
|
||||
SUBDIR += svxlink
|
||||
SUBDIR += syncterm
|
||||
SUBDIR += tcpser
|
||||
|
19
comms/sunxi-tools/Makefile
Normal file
19
comms/sunxi-tools/Makefile
Normal file
@ -0,0 +1,19 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= sunxi-tools
|
||||
PORTVERSION= 1.4.2
|
||||
DISTVERSIONPREFIX= v
|
||||
CATEGORIES= comms
|
||||
|
||||
MAINTAINER= manu@freebsd.org
|
||||
COMMENT= Tools to help hacking Allwinner devices
|
||||
|
||||
LICENSE= GPLv2+
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE.md
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= linux-sunxi
|
||||
|
||||
USES= gmake pkgconfig
|
||||
|
||||
.include <bsd.port.mk>
|
3
comms/sunxi-tools/distinfo
Normal file
3
comms/sunxi-tools/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1499609673
|
||||
SHA256 (linux-sunxi-sunxi-tools-v1.4.2_GH0.tar.gz) = 81f48014a520cb83cac4e17f5ae627a637c4d6a422b60c693c5a705c92e43822
|
||||
SIZE (linux-sunxi-sunxi-tools-v1.4.2_GH0.tar.gz) = 84090
|
29
comms/sunxi-tools/files/patch-Makefile
Normal file
29
comms/sunxi-tools/files/patch-Makefile
Normal file
@ -0,0 +1,29 @@
|
||||
--- Makefile.orig 2016-11-29 13:07:51 UTC
|
||||
+++ Makefile
|
||||
@@ -17,7 +17,7 @@
|
||||
# along with this program. If not, see <http://www.gnu.org/licenses/>.
|
||||
|
||||
CC ?= gcc
|
||||
-DEFAULT_CFLAGS := -std=c99
|
||||
+DEFAULT_CFLAGS += -std=c99
|
||||
DEFAULT_CFLAGS += -Wall -Wextra -Wno-unused-result
|
||||
|
||||
DEFAULT_CFLAGS += -D_POSIX_C_SOURCE=200112L
|
||||
@@ -63,7 +63,7 @@ BINDIR ?= $(PREFIX)/bin
|
||||
tools: $(TOOLS) $(FEXC_LINKS)
|
||||
target-tools: $(TARGET_TOOLS)
|
||||
|
||||
-all: tools target-tools
|
||||
+all: tools
|
||||
|
||||
misc: $(MISC_TOOLS)
|
||||
|
||||
@@ -75,7 +75,7 @@ install-all: install-tools install-target-tools
|
||||
install-tools: $(TOOLS)
|
||||
install -d $(DESTDIR)$(BINDIR)
|
||||
@set -ex ; for t in $^ ; do \
|
||||
- install -m0755 $$t $(DESTDIR)$(BINDIR)/$$t ; \
|
||||
+ $(BSD_INSTALL_PROGRAM) $$t $(DESTDIR)$(BINDIR)/$$t ; \
|
||||
done
|
||||
@set -ex ; for l in $(FEXC_LINKS) ; do \
|
||||
ln -nfs sunxi-fexc $(DESTDIR)$(BINDIR)/$$l ; \
|
4
comms/sunxi-tools/pkg-descr
Normal file
4
comms/sunxi-tools/pkg-descr
Normal file
@ -0,0 +1,4 @@
|
||||
Tools to help hacking Allwinner A10 (aka sun4i) based devices and possibly
|
||||
it's successors, that's why the 'x' in the package name.
|
||||
|
||||
WWW: https://github.com/linux-sunxi/sunxi-tools
|
7
comms/sunxi-tools/pkg-plist
Normal file
7
comms/sunxi-tools/pkg-plist
Normal file
@ -0,0 +1,7 @@
|
||||
bin/bin2fex
|
||||
bin/fex2bin
|
||||
bin/sunxi-bootinfo
|
||||
bin/sunxi-fel
|
||||
bin/sunxi-fexc
|
||||
bin/sunxi-nand-part
|
||||
bin/sunxi-pio
|
Loading…
Reference in New Issue
Block a user