lang/scm: fix build on powerpc64*

(#<primitive-procedure call-with-current-continuation> #<CLOSURE <anon> "r4rstest.scm": (exit) (for-each (lambda (x) (if (negative? x) (exit x))) (quote (54 0 37 -3 245 19))) #t>)  ==> 
;ERROR: "r4rstest.scm": segment violation 11
; in expression: (#@apply #@fun #@args)
; in scope:
;   (expect fun . args)  procedure test
; defined by load: "r4rstest.scm"

;STACK TRACE
1; (#@let ((res (#@if (#@procedure? #@0+1) (#@apply #@0+1 #@0-2)  ...
2; (#@test -3 #@call-with-current-continuation (#@lambda (exit) ( ...
3; (#@define ((filesuf #@file) (hss (#@has-suffix? #@file (#@sche ...
4; ((#@thunk) (#@set! #@complete #t))
5; ((#@do-thunk (#@lambda () (#@cond (#@*syntax-rules* (require ( ...
6; ((#@case #@option #(#<unspecified> #f #\? #\: #\n #\u #\m #\s  ...
7; ((#@cond ((#@not #@*argv*) (#@set! #@*argv* (#@program-argumen ...

; program args: ("./scm" "-rmacro" "-fsyntest1.scm" "-fsyntest2.scm" "-fr4rstest.scm" "-e(test-sc4)(test-cont)(test-delay)" "-fsyntest1" "-e" "(or (null? errs) (quit 1))")

Builds fine with GCC.

While here, remove ia64 support.
This commit is contained in:
Piotr Kubaj 2021-10-17 11:54:34 +00:00
parent 875b901fb0
commit 088f48d0af
2 changed files with 6 additions and 14 deletions

View File

@ -54,6 +54,12 @@ SCM_MODULES= byte.so bytenumb.so crs.so differ.so edline.so gsubr.so \
socket.so unix.so
SCM_MODULES_X11=x.so
.include <bsd.port.options.mk>
.if ${ARCH:Mpowerpc64*}
USES+= compiler:gcc-c++11-lib
.endif
.include <bsd.port.pre.mk>
.if ${OSVERSION} > 1300000
@ -65,11 +71,6 @@ SCM_MODULES+= ${SCM_MODULES_X11}
SCM_DATA+= ${SCM_DATA_X11}
.endif
.if ${ARCH} == "ia64"
EXTRA_PATCHES+= ${FILESDIR}/ia64-patch
ARCHOBJS= continue-ia64.S
.endif
LIBEDIT_SUB1= ${CPPFLAGS}" "${LDFLAGS:M-L*}
LIBEDIT_SUB2= ${LDFLAGS:M-L*}

View File

@ -1,9 +0,0 @@
--- Makefile 2013-03-10 03:29:54.000000000 +0000
+++ Makefile 2015-01-23 21:59:51.747074000 +0000
@@ -104,5 +104,5 @@
ofiles = scm.o time.o repl.o scl.o sys.o eval.o subr.o unif.o rope.o \
continue.o findexec.o script.o debug.o
-# continue-ia64.o
+ofiles+= continue-ia64.o
ifiles = Init$(VERSION).scm Transcen.scm Link.scm Macro.scm Macexp.scm \
Tscript.scm compile.scm Iedline.scm Idiffer.scm