Update to 0.2.0.

This commit is contained in:
MANTANI Nobutaka 2003-12-11 10:02:59 +00:00
parent d97fe6f483
commit 0872d5dcc1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=95590
14 changed files with 54 additions and 82 deletions

View File

@ -6,14 +6,15 @@
#
PORTNAME= uim
PORTVERSION= 0.1.7
PORTVERSION= 0.2.0
CATEGORIES= japanese x11
MASTER_SITES= http://freedesktop.org/Software/uim/
MAINTAINER= nobutaka@FreeBSD.org
COMMENT= Input method library
LIB_DEPENDS= anthy.0:${PORTSDIR}/japanese/anthy
LIB_DEPENDS= anthy.0:${PORTSDIR}/japanese/anthy \
iconv.3:${PORTSDIR}/converters/libiconv
USE_X_PREFIX= yes
INSTALLS_SHLIB= yes

View File

@ -1 +1 @@
MD5 (uim-0.1.7.tar.gz) = fb9bfb998a47fc1d4366eb3ce6d13c87
MD5 (uim-0.2.0.tar.gz) = 72d5ae116e983cff0535933faadc0f82

View File

@ -0,0 +1,11 @@
--- Makefile.in.orig Wed Dec 10 23:28:20 2003
+++ Makefile.in Wed Dec 10 23:29:10 2003
@@ -198,7 +198,7 @@
@GTK2_TRUE@gtk_entry_CFLAGS = @GTK2_CFLAGS@
uim_agent_SOURCES = agent.c
-uim_agent_LDADD = uim/libuim.la
+uim_agent_LDADD = uim/libuim.la -liconv
ACLOCAL_AMFLAGS = -I m4
subdir = .

View File

@ -1,23 +0,0 @@
--- helper/helper-applet.c.orig Tue Oct 14 00:07:31 2003
+++ helper/helper-applet.c Tue Oct 14 00:24:43 2003
@@ -134,6 +134,7 @@
gchar **tmp2 = NULL;
gchar *charset = NULL;
GString *path = g_string_new("");
+ GtkItemFactoryEntry entry;
tmp2 = g_strsplit(tmp[1], "=", 0);
@@ -176,7 +177,11 @@
gtk_widget_show(button);
} else if(strcmp("leaf", tmp2[0]) == 0) {
g_string_printf(path, "/%s", tmp2[2]);
- GtkItemFactoryEntry entry = {path->str, NULL, G_CALLBACK(activate_event), 0, ""};
+ entry.path = path->str;
+ entry.accelerator = NULL;
+ entry.callback = G_CALLBACK(activate_event);
+ entry.callback_action = 0;
+ entry.item_type = "";
gtk_item_factory_create_item ( mode_item_fact, &entry, tmp2[4], 1);
}

View File

@ -1,15 +0,0 @@
--- helper/helper-candwin-gtk.c.orig Sun Nov 9 02:26:21 2003
+++ helper/helper-candwin-gtk.c Sun Nov 9 02:27:22 2003
@@ -160,10 +160,11 @@
{
int index;
char idx[20];
+ GtkTreePath* path;
sscanf(str[1],"%d",&index);
cwin.candidate_index = index;
- GtkTreePath* path = gtk_tree_path_new_from_indices(index, -1);
+ path = gtk_tree_path_new_from_indices(index, -1);
gtk_tree_view_set_cursor(GTK_TREE_VIEW(m_view),
path, NULL, FALSE);
gtk_tree_view_scroll_to_cell(GTK_TREE_VIEW(m_view),

View File

@ -0,0 +1,11 @@
--- xim/Makefile.in.orig Wed Dec 10 23:36:10 2003
+++ xim/Makefile.in Wed Dec 10 23:37:25 2003
@@ -182,7 +182,7 @@
bin_PROGRAMS = uim-xim
uim_xim_LDFLAGS = -L/usr/lib -L/usr/X11R6/lib
-uim_xim_LDADD = -lXext -lX11 ../uim/libuim.la
+uim_xim_LDADD = -lXext -lX11 ../uim/libuim.la -liconv
uim_xim_SOURCES = \
main.cpp convdisp.cpp \

View File

@ -12,6 +12,7 @@ lib/libuim.a
lib/libuim.la
lib/libuim.so
lib/libuim.so.0
lib/pkgconfig/uim.pc
%%GNOME%%libexec/uim-helper-applet
%%PORTDOCS%%%%DOCSDIR_JA%%/README.ja
%%PORTDOCS%%%%DOCSDIR%%/README

View File

@ -6,14 +6,15 @@
#
PORTNAME= uim
PORTVERSION= 0.1.7
PORTVERSION= 0.2.0
CATEGORIES= japanese x11
MASTER_SITES= http://freedesktop.org/Software/uim/
MAINTAINER= nobutaka@FreeBSD.org
COMMENT= Input method library
LIB_DEPENDS= anthy.0:${PORTSDIR}/japanese/anthy
LIB_DEPENDS= anthy.0:${PORTSDIR}/japanese/anthy \
iconv.3:${PORTSDIR}/converters/libiconv
USE_X_PREFIX= yes
INSTALLS_SHLIB= yes

View File

@ -1 +1 @@
MD5 (uim-0.1.7.tar.gz) = fb9bfb998a47fc1d4366eb3ce6d13c87
MD5 (uim-0.2.0.tar.gz) = 72d5ae116e983cff0535933faadc0f82

View File

@ -0,0 +1,11 @@
--- Makefile.in.orig Wed Dec 10 23:28:20 2003
+++ Makefile.in Wed Dec 10 23:29:10 2003
@@ -198,7 +198,7 @@
@GTK2_TRUE@gtk_entry_CFLAGS = @GTK2_CFLAGS@
uim_agent_SOURCES = agent.c
-uim_agent_LDADD = uim/libuim.la
+uim_agent_LDADD = uim/libuim.la -liconv
ACLOCAL_AMFLAGS = -I m4
subdir = .

View File

@ -1,23 +0,0 @@
--- helper/helper-applet.c.orig Tue Oct 14 00:07:31 2003
+++ helper/helper-applet.c Tue Oct 14 00:24:43 2003
@@ -134,6 +134,7 @@
gchar **tmp2 = NULL;
gchar *charset = NULL;
GString *path = g_string_new("");
+ GtkItemFactoryEntry entry;
tmp2 = g_strsplit(tmp[1], "=", 0);
@@ -176,7 +177,11 @@
gtk_widget_show(button);
} else if(strcmp("leaf", tmp2[0]) == 0) {
g_string_printf(path, "/%s", tmp2[2]);
- GtkItemFactoryEntry entry = {path->str, NULL, G_CALLBACK(activate_event), 0, ""};
+ entry.path = path->str;
+ entry.accelerator = NULL;
+ entry.callback = G_CALLBACK(activate_event);
+ entry.callback_action = 0;
+ entry.item_type = "";
gtk_item_factory_create_item ( mode_item_fact, &entry, tmp2[4], 1);
}

View File

@ -1,15 +0,0 @@
--- helper/helper-candwin-gtk.c.orig Sun Nov 9 02:26:21 2003
+++ helper/helper-candwin-gtk.c Sun Nov 9 02:27:22 2003
@@ -160,10 +160,11 @@
{
int index;
char idx[20];
+ GtkTreePath* path;
sscanf(str[1],"%d",&index);
cwin.candidate_index = index;
- GtkTreePath* path = gtk_tree_path_new_from_indices(index, -1);
+ path = gtk_tree_path_new_from_indices(index, -1);
gtk_tree_view_set_cursor(GTK_TREE_VIEW(m_view),
path, NULL, FALSE);
gtk_tree_view_scroll_to_cell(GTK_TREE_VIEW(m_view),

View File

@ -0,0 +1,11 @@
--- xim/Makefile.in.orig Wed Dec 10 23:36:10 2003
+++ xim/Makefile.in Wed Dec 10 23:37:25 2003
@@ -182,7 +182,7 @@
bin_PROGRAMS = uim-xim
uim_xim_LDFLAGS = -L/usr/lib -L/usr/X11R6/lib
-uim_xim_LDADD = -lXext -lX11 ../uim/libuim.la
+uim_xim_LDADD = -lXext -lX11 ../uim/libuim.la -liconv
uim_xim_SOURCES = \
main.cpp convdisp.cpp \

View File

@ -12,6 +12,7 @@ lib/libuim.a
lib/libuim.la
lib/libuim.so
lib/libuim.so.0
lib/pkgconfig/uim.pc
%%GNOME%%libexec/uim-helper-applet
%%PORTDOCS%%%%DOCSDIR_JA%%/README.ja
%%PORTDOCS%%%%DOCSDIR%%/README