MFH: r555761

textproc/bsdgrep: fix the build on recent -CURRENT

A seatbelt was added to throw a warning if a "SUBDIR." variable appeared
non-empty, since that indicates something was trying to expand a MK_
variable most likely and either opts.mk wasn't included or the name of the
variable used is wrong.

In this particular case, we're repackaging a part from base. I had stripped
the src.opts.mk include but hadn't thought to replace it with bsd.opts.mk
for userlandy stuff.

This also goes as far as fixing the test build, but doesn't yet hook up the
tests. On FreeBSD <13 these need a kyua/atf test dep, but I'd like to do a
sweep and see if there are any other ports (e.g. from NetBSD base or FreeBSD
base) that also have a dependency to weigh in on if this should just be a
one-off osversion check or a kyua/atf USES.

Approved by:	ports-secteam (implicit, build fix)
This commit is contained in:
Kyle Evans 2020-11-22 22:04:31 +00:00
parent 4a36b077b2
commit 08682d4012
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/branches/2020Q4/; revision=556075
3 changed files with 63 additions and 3 deletions

View File

@ -19,7 +19,8 @@ USES= uidfix
MAKE_ENV+= BINDIR="${PREFIX}/bin" \
MANDIR="${MANPREFIX}/man/man" \
CATDIR="${MANPREFIX}/man/man" \
NLSDIR="${PREFIX}/share/nls"
NLSDIR="${PREFIX}/share/nls" \
WITHOUT_TESTS=yes
CFLAGS+= -std=gnu99
OPTIONS_DEFINE= GNU_COMPAT NLS
@ -38,6 +39,6 @@ pre-install-NLS-on:
${MKDIR} ${STAGEDIR}${PREFIX}/share/nls/gl_ES.ISO8859-1
post-install:
${LN} -sf ${PREFIX}/bin/grep ${STAGEDIR}${PREFIX}/bin/bsdgrep
${RLN} ${STAGEDIR}${PREFIX}/bin/grep ${STAGEDIR}${PREFIX}/bin/bsdgrep
.include <bsd.port.mk>

View File

@ -1,10 +1,11 @@
--- Makefile.orig 2017-10-19 20:07:52 UTC
+++ Makefile
@@ -2,31 +2,13 @@
@@ -2,31 +2,14 @@
# $FreeBSD: head/usr.bin/grep/Makefile 322515 2017-08-14 19:21:37Z ngie $
# $OpenBSD: Makefile,v 1.6 2003/06/25 15:00:04 millert Exp $
-.include <src.opts.mk>
+.include <bsd.opts.mk>
-
-.if ${MK_BSD_GREP} == "yes"
PROG= grep

View File

@ -0,0 +1,58 @@
--- tests/Makefile.orig 2020-11-20 14:03:37 UTC
+++ tests/Makefile
@@ -3,55 +3,5 @@
PACKAGE= tests
ATF_TESTS_SH+= grep_freebsd_test
-NETBSD_ATF_TESTS_SH= grep_test
-
-${PACKAGE}FILES+= d_basic.out
-${PACKAGE}FILES+= d_begin_end_a.out
-${PACKAGE}FILES+= d_begin_end_b.out
-${PACKAGE}FILES+= d_binary.out
-${PACKAGE}FILES+= d_color_a.in
-${PACKAGE}FILES+= d_color_a.out
-${PACKAGE}FILES+= d_color_b.in
-${PACKAGE}FILES+= d_color_b.out
-${PACKAGE}FILES+= d_color_c.out
-${PACKAGE}FILES+= d_context2_a.out
-${PACKAGE}FILES+= d_context2_b.out
-${PACKAGE}FILES+= d_context2_c.out
-${PACKAGE}FILES+= d_context_a.in
-${PACKAGE}FILES+= d_context_a.out
-${PACKAGE}FILES+= d_context_b.in
-${PACKAGE}FILES+= d_context_e.in
-${PACKAGE}FILES+= d_context_b.out
-${PACKAGE}FILES+= d_context_c.out
-${PACKAGE}FILES+= d_context_d.out
-${PACKAGE}FILES+= d_context_e.out
-${PACKAGE}FILES+= d_context_f.out
-${PACKAGE}FILES+= d_context_g.out
-${PACKAGE}FILES+= d_egrep.out
-${PACKAGE}FILES+= d_escmap.in
-${PACKAGE}FILES+= d_f_file_empty.in
-${PACKAGE}FILES+= d_file_exp.in
-${PACKAGE}FILES+= d_file_exp.out
-${PACKAGE}FILES+= d_ignore_case.out
-${PACKAGE}FILES+= d_input
-${PACKAGE}FILES+= d_invert.in
-${PACKAGE}FILES+= d_invert.out
-${PACKAGE}FILES+= d_oflag_zerolen_a.in
-${PACKAGE}FILES+= d_oflag_zerolen_a.out
-${PACKAGE}FILES+= d_oflag_zerolen_b.in
-${PACKAGE}FILES+= d_oflag_zerolen_b.out
-${PACKAGE}FILES+= d_oflag_zerolen_c.in
-${PACKAGE}FILES+= d_oflag_zerolen_c.out
-${PACKAGE}FILES+= d_oflag_zerolen_d.in
-${PACKAGE}FILES+= d_oflag_zerolen_e.in
-${PACKAGE}FILES+= d_oflag_zerolen_e.out
-${PACKAGE}FILES+= d_recurse.out
-${PACKAGE}FILES+= d_recurse_symlink.err
-${PACKAGE}FILES+= d_recurse_symlink.out
-${PACKAGE}FILES+= d_whole_line.out
-${PACKAGE}FILES+= d_word_regexps.out
-${PACKAGE}FILES+= d_zgrep.out
-
-.include <netbsd-tests.test.mk>
.include <bsd.test.mk>