sysutils/rubygem-hiera-eyaml: create port

hiera-eyaml is a backend for Hiera that provides per-value encryption of
sensitive data within yaml files to be used by Puppet. The Hiera eyaml
backend uses yaml formatted files with the .eyaml extension.  The encrypted
strings are prefixed with the encryption method, wrapped with ENC[] and
placed in an eyaml file. You can mix your plain values in as well or
separate them into different files.

WWW: https://github.com/TomPoulton/hiera-eyaml

PR:		206280
Submitted by:	Paul <freebsd@rig.rain.com> (with slight modifications due to time)
This commit is contained in:
Steve Wills 2017-07-08 00:24:05 +00:00
parent 4a47890057
commit 083a856580
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=445289
5 changed files with 45 additions and 0 deletions

View File

@ -993,6 +993,7 @@
SUBDIR += rubygem-hammer_cli_foreman_salt
SUBDIR += rubygem-hammer_cli_foreman_ssh
SUBDIR += rubygem-hiera
SUBDIR += rubygem-hiera-eyaml
SUBDIR += rubygem-hiera-file
SUBDIR += rubygem-hiera1
SUBDIR += rubygem-hieracles

View File

@ -0,0 +1,22 @@
# $FreeBSD$
PORTNAME= hiera-eyaml
PORTVERSION= 2.1.0
CATEGORIES= sysutils rubygems
MASTER_SITES= RG
MAINTAINER= freebsd@rig.rain.com
COMMENT= Backend for Hiera that provides encryption/decryption for properties
LICENSE= MIT
RUN_DEPENDS= rubygem-trollop>=2.0:devel/rubygem-trollop \
rubygem-highline>=1.7:devel/rubygem-highline
PLIST_FILES= bin/eyaml
NO_ARCH= yes
USE_RUBY= yes
USES= gem
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
TIMESTAMP = 1499471105
SHA256 (rubygem/hiera-eyaml-2.1.0.gem) = 469148a15902c837221324aae53f712a600aa93e3d37a987934cd584b6bb45c0
SIZE (rubygem/hiera-eyaml-2.1.0.gem) = 29184

View File

@ -0,0 +1,11 @@
--- hiera-eyaml.gemspec.orig 2017-07-08 00:14:31 UTC
+++ hiera-eyaml.gemspec
@@ -22,7 +22,7 @@ Gem::Specification.new do |s|
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
s.add_runtime_dependency(%q<trollop>.freeze, ["~> 2.0"])
- s.add_runtime_dependency(%q<highline>.freeze, ["~> 1.6.19"])
+ s.add_runtime_dependency(%q<highline>.freeze, ["~> 1.6"])
else
s.add_dependency(%q<trollop>.freeze, ["~> 2.0"])
s.add_dependency(%q<highline>.freeze, ["~> 1.6.19"])

View File

@ -0,0 +1,8 @@
hiera-eyaml is a backend for Hiera that provides per-value encryption of
sensitive data within yaml files to be used by Puppet. The Hiera eyaml
backend uses yaml formatted files with the .eyaml extension. The encrypted
strings are prefixed with the encryption method, wrapped with ENC[] and
placed in an eyaml file. You can mix your plain values in as well or
separate them into different files.
WWW: https://github.com/TomPoulton/hiera-eyaml