Upgrade to 1.0.4.

PR:		ports/24931
Submitted by:	KATO Tsuguru <tkato@prontomail.ne.jp>
This commit is contained in:
Vanilla I. Shu 2001-03-22 09:15:07 +00:00
parent 2f976830b2
commit 0815c29a4a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=40195
7 changed files with 36 additions and 236 deletions

View File

@ -1,14 +0,0 @@
--- backend/artec.c.orig Sun Mar 5 22:40:43 2000
+++ backend/artec.c Wed Apr 19 06:00:00 2000
@@ -3238,7 +3238,11 @@
if (DBG_LEVEL == 101)
{
debug_fd = open ("artec.data.raw",
+#ifdef __FreeBSD__
+ O_WRONLY | O_CREAT | O_TRUNC, 0666);
+#else
O_WRONLY | O_CREAT | O_TRUNC | O_SYNC, 0666);
+#endif
if (debug_fd > -1)
DBG (101, "opened artec.data.raw output file\n");
}

View File

@ -1,11 +0,0 @@
--- backend/Makefile.in.orig Sun Mar 5 22:40:35 2000
+++ backend/Makefile.in Wed Apr 19 06:00:00 2000
@@ -113,7 +113,7 @@
nn=`echo $$n | sed 's,^libsane-dll,libsane,'`; \
(cd ..; $(LN_S) sane/$$n $$nn); \
done || exit 1
- $(INSTALL_PROGRAM) libsane.la $(libdir)/libsane.la
+ $(LIBTOOL) $(MINST) $(INSTALL_PROGRAM) libsane.la $(libdir)/libsane.la
@list="$(CONFIGS)"; for cfg in $$list; do \
if test ! -r $(srcdir)/$${cfg}; then continue; fi; \
if test -f $(configdir)/$${cfg}; then \

View File

@ -1,19 +0,0 @@
--- tools/Makefile.in.orig Sun Mar 5 22:45:19 2000
+++ tools/Makefile.in Wed Apr 19 06:00:00 2000
@@ -25,6 +25,7 @@
MKDIR = $(top_srcdir)/mkinstalldirs
INSTALL = @INSTALL@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
+INSTALL_SCRIPT = @INSTALL_SCRIPT@
INSTALL_DATA = @INSTALL_DATA@
RANLIB = @RANLIB@
@@ -65,7 +66,7 @@
all: $(DESTINATIONS)
install: sane-config
- $(INSTALL_PROGRAM) sane-config $(bindir)/sane-config
+ $(INSTALL_SCRIPT) sane-config $(bindir)/sane-config
sane-config: sane-config.in $(top_builddir)/config.status
cd $(top_builddir) \

View File

@ -1,180 +0,0 @@
--- sanei/sanei_scsi.c.orig Sat Aug 12 23:54:15 2000
+++ sanei/sanei_scsi.c Fri Sep 8 22:38:49 2000
@@ -2424,6 +2424,169 @@
cam_freeccb(ccb);
return SANE_STATUS_GOOD;
}
+
+#define WE_HAVE_FIND_DEVICES
+
+int
+cam_compare_inquiry(int fd, path_id_t path_id,
+ target_id_t target_id, lun_id_t target_lun,
+ const char *vendor, const char *product, const char *type)
+{
+ struct ccb_dev_match cdm;
+ struct device_match_pattern *pattern;
+ struct scsi_inquiry_data *inq;
+ int retval = 0;
+
+ /* build ccb for device match */
+ bzero(&cdm, sizeof(cdm));
+ cdm.ccb_h.func_code = XPT_DEV_MATCH;
+
+ /* result buffer */
+ cdm.match_buf_len = sizeof(struct dev_match_result);
+ cdm.matches = (struct dev_match_result *)malloc(cdm.match_buf_len);
+ cdm.num_matches = 0;
+
+ /* pattern buffer */
+ cdm.num_patterns = 1;
+ cdm.pattern_buf_len = sizeof(struct dev_match_pattern);
+ cdm.patterns = (struct dev_match_pattern *)malloc(cdm.pattern_buf_len);
+
+ /* assemble conditions */
+ cdm.patterns[0].type = DEV_MATCH_DEVICE;
+ pattern = &cdm.patterns[0].pattern.device_pattern;
+ pattern->flags = DEV_MATCH_PATH | DEV_MATCH_TARGET | DEV_MATCH_LUN;
+ pattern->path_id = path_id;
+ pattern->target_id = target_id;
+ pattern->target_lun = target_lun;
+
+ if (ioctl(fd, CAMIOCOMMAND, &cdm) == -1) {
+ DBG (1, "error sending CAMIOCOMMAND ioctl");
+ retval = -1;
+ goto ret;
+ }
+
+ if ((cdm.ccb_h.status != CAM_REQ_CMP)
+ || ((cdm.status != CAM_DEV_MATCH_LAST)
+ && (cdm.status != CAM_DEV_MATCH_MORE))) {
+ DBG (1, "got CAM error %#x, CDM error %d\n",
+ cdm.ccb_h.status, cdm.status);
+ retval = -1;
+ goto ret;
+ }
+
+ if (cdm.num_matches == 0) {
+ DBG (1, "not found\n");
+ retval = -1;
+ goto ret;
+ }
+
+ if (cdm.matches[0].type != DEV_MATCH_DEVICE) {
+ DBG (1, "no device match\n");
+ retval = -1;
+ goto ret;
+ }
+
+ inq = &cdm.matches[0].result.device_result.inq_data;
+ if ((vendor && cam_strmatch(inq->vendor, vendor, SID_VENDOR_SIZE)) ||
+ (product && cam_strmatch(inq->product, product, SID_PRODUCT_SIZE)))
+ retval = 1;
+
+ ret:
+ free(cdm.patterns);
+ free(cdm.matches);
+ return(retval);
+}
+
+void
+sanei_scsi_find_devices (const char *findvendor, const char *findmodel,
+ const char *findtype,
+ int findbus, int findchannel, int findid, int findlun,
+ SANE_Status (*attach) (const char *dev))
+{
+ int fd;
+ struct ccb_dev_match cdm;
+ struct periph_match_pattern *pattern;
+ struct periph_match_result *result;
+ int i;
+ char devname[16];
+
+ DBG_INIT();
+
+ if ((fd = open(XPT_DEVICE, O_RDWR)) == -1) {
+ DBG (1, "could not open %s\n", XPT_DEVICE);
+ return;
+ }
+
+ /* build ccb for device match */
+ bzero(&cdm, sizeof(cdm));
+ cdm.ccb_h.func_code = XPT_DEV_MATCH;
+
+ /* result buffer */
+ cdm.match_buf_len = sizeof(struct dev_match_result) * 100;
+ cdm.matches = (struct dev_match_result *)malloc(cdm.match_buf_len);
+ cdm.num_matches = 0;
+
+ /* pattern buffer */
+ cdm.num_patterns = 1;
+ cdm.pattern_buf_len = sizeof(struct dev_match_pattern);
+ cdm.patterns = (struct dev_match_pattern *)malloc(cdm.pattern_buf_len);
+
+ /* assemble conditions ... findchannel is ignored */
+ cdm.patterns[0].type = DEV_MATCH_PERIPH;
+ pattern = &cdm.patterns[0].pattern.periph_pattern;
+ pattern->flags = PERIPH_MATCH_NAME;
+ strcpy(pattern->periph_name, "pass");
+ if (findbus != -1) {
+ pattern->path_id = findbus;
+ pattern->flags |= PERIPH_MATCH_PATH;
+ }
+ if (findid != -1) {
+ pattern->target_id = findid;
+ pattern->flags |= PERIPH_MATCH_TARGET;
+ }
+ if (findlun != -1) {
+ pattern->target_lun = findlun;
+ pattern->flags |= PERIPH_MATCH_LUN;
+ }
+
+ /* result loop */
+ do {
+ if (ioctl(fd, CAMIOCOMMAND, &cdm) == -1) {
+ DBG (1, "error sending CAMIOCOMMAND ioctl");
+ break;
+ }
+
+ if ((cdm.ccb_h.status != CAM_REQ_CMP)
+ || ((cdm.status != CAM_DEV_MATCH_LAST)
+ && (cdm.status != CAM_DEV_MATCH_MORE))) {
+ DBG (1, "got CAM error %#x, CDM error %d\n",
+ cdm.ccb_h.status, cdm.status);
+ break;
+ }
+
+ for (i = 0; i < cdm.num_matches; i++) {
+ if (cdm.matches[i].type != DEV_MATCH_PERIPH)
+ continue;
+ result = &cdm.matches[i].result.periph_result;
+ DBG (4, "%s%d on scbus%d %d:%d\n",
+ result->periph_name, result->unit_number,
+ result->path_id, result->target_id, result->target_lun);
+ if (cam_compare_inquiry(fd, result->path_id,
+ result->target_id, result->target_lun,
+ findvendor, findmodel, findtype) == 0) {
+ sprintf(devname, "/dev/%s%d", result->periph_name, result->unit_number);
+ (*attach) (devname);
+ }
+ }
+ } while ((cdm.ccb_h.status == CAM_REQ_CMP)
+ && (cdm.status == CAM_DEV_MATCH_MORE));
+
+ free(cdm.patterns);
+ free(cdm.matches);
+ close(fd);
+ return;
+}
+
#endif
@@ -3722,6 +3885,7 @@
int findbus, int findchannel, int findid, int findlun,
SANE_Status (*attach) (const char *dev))
{
+ DBG_INIT();
DBG (1, "sanei_scsi_find_devices: not implemented for this platform\n");
}

View File

@ -1,12 +0,0 @@
--- frontend/xscanimage.c.orig Sun Oct 15 08:12:12 2000
+++ frontend/xscanimage.c Sun Oct 15 08:12:39 2000
@@ -57,6 +57,8 @@
#ifdef HAVE_LIBGIMP_GIMP_H
+#define GIMP_ENABLE_COMPAT_CRUFT
+
#include <libgimp/gimp.h>
static void query (void);

View File

@ -0,0 +1,10 @@
--- configure.orig Wed Mar 21 17:56:40 2001
+++ configure Wed Mar 21 17:56:57 2001
@@ -3218,6 +3218,7 @@
s%@GTK_CFLAGS@%$GTK_CFLAGS%g
s%@GTK_LIBS@%$GTK_LIBS%g
s%@INCLUDES@%$INCLUDES%g
+s%@GUIPROGS@%$GUIPROGS%g
s%@BINPROGS@%$BINPROGS%g
s%@GIMP_LIBS@%$GIMP_LIBS%g
s%@V_MAJOR@%$V_MAJOR%g

View File

@ -0,0 +1,26 @@
--- src/Makefile.in.orig Fri Dec 1 03:58:38 2000
+++ src/Makefile.in Wed Mar 21 17:52:10 2001
@@ -39,7 +39,7 @@
GTK_CFLAGS = @GTK_CFLAGS@
GIMP_LIBS = @GIMP_LIBS@
-BINPROGS = @BINPROGS@
+BINPROGS = @GUIPROGS@
COMPILE = $(CC) -c $(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS) $(GTK_CFLAGS)
LINK = $(CC) $(LDFLAGS) -o $@
@@ -59,12 +59,12 @@
all: $(PROGRAMS)
install: $(PROGRAMS)
- $(MKDIR) $(bindir) $(datadir)
+ $(MKDIR) $(bindir) $(sanedatadir)
@for program in $(BINPROGS); do \
$(INSTALL_PROGRAM) $${program} \
$(bindir)/$${program}; \
done
- $(INSTALL_DATA) $(srcdir)/sane-style.rc $(datadir)/sane-style.rc
+ $(INSTALL_DATA) $(srcdir)/sane-style.rc $(sanedatadir)/sane-style.rc
xscanimage: $(XSCAN_OBJS) $(LIBSANEI) $(LIBLIB)
$(LINK) $(XSCAN_OBJS) $(LIBSANEI) \