Import of gxanim 0.45, a Gtk front-end to xanim.
PR: 13707 Submitted by: Rod Taylor <rod@idiotswitch.org>
This commit is contained in:
parent
58239cba7f
commit
07ffec94b1
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=21835
26
graphics/gxanim/Makefile
Normal file
26
graphics/gxanim/Makefile
Normal file
@ -0,0 +1,26 @@
|
||||
# New ports collection makefile for: xanim
|
||||
# Version required: 0.45
|
||||
# Date created: Sat Nov 5 11:43:03 PST 1994
|
||||
# Whom: Rod Taylor
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
DISTNAME= gxanim-0.45
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://www.iag.net/~aleris/
|
||||
|
||||
MAINTAINER= rod@idiotswitch.org
|
||||
|
||||
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
|
||||
RUN_DEPENDS= xanim:${PORTSDIR}/graphics/xanim
|
||||
|
||||
GTK_CONFIG= ${X11BASE}/bin/gtk12-config
|
||||
|
||||
USE_XLIB= yes
|
||||
|
||||
USE_BZIP2= yes
|
||||
WRKSRC= ${WRKDIR}/gxanim
|
||||
MAKE_ENV= GTK_CONFIG="${GTK_CONFIG}"
|
||||
|
||||
.include <bsd.port.mk>
|
1
graphics/gxanim/distinfo
Normal file
1
graphics/gxanim/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (gxanim-0.45.tar.bz2) = 43a6c20583c69ece93efb2a2eabe87c9
|
22
graphics/gxanim/files/patch-aa
Normal file
22
graphics/gxanim/files/patch-aa
Normal file
@ -0,0 +1,22 @@
|
||||
--- Makefile.orig Tue Aug 31 14:57:46 1999
|
||||
+++ Makefile Mon Sep 20 11:32:09 1999
|
||||
@@ -1,8 +1,8 @@
|
||||
-CC = gcc
|
||||
-CFLAGS = -O2 `gtk-config --cflags`
|
||||
-INSTALLDIR = /usr/local/bin
|
||||
+# CC = gcc
|
||||
+CFLAGS += `${GTK_CONFIG} --cflags`
|
||||
+INSTALLDIR = ${PREFIX}/bin
|
||||
|
||||
-LIBS = `gtk-config --libs`
|
||||
+LIBS = `${GTK_CONFIG} --libs`
|
||||
OBJS = runxanim.o gxanim.o memory.o filesel.o util.o valxanim.o control.o windows.o config.o prefs.o
|
||||
|
||||
FINAL = gxanim
|
||||
@@ -29,5 +29,5 @@
|
||||
rm -f ${FINAL}
|
||||
|
||||
install :
|
||||
- mv ${FINAL} ${INSTALLDIR}
|
||||
+ ${BSD_INSTALL_PROGRAM} ${FINAL} ${INSTALLDIR}
|
||||
|
1
graphics/gxanim/pkg-comment
Normal file
1
graphics/gxanim/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
A graphical front end to Xanim.
|
6
graphics/gxanim/pkg-descr
Normal file
6
graphics/gxanim/pkg-descr
Normal file
@ -0,0 +1,6 @@
|
||||
GXAnim is a graphical interface to XAnim written with the GTK+ toolkit for UNIX
|
||||
platforms. You can quickly find a movie file, play it, and do the usual
|
||||
VCR-like stuff (rewind, fast forward, pause, stop set volume, etc.), as
|
||||
well as set general play preferences.
|
||||
|
||||
WWW: http://www.iag.net/~aleris/gxanim.html
|
1
graphics/gxanim/pkg-plist
Normal file
1
graphics/gxanim/pkg-plist
Normal file
@ -0,0 +1 @@
|
||||
bin/gxanim
|
26
multimedia/gxanim/Makefile
Normal file
26
multimedia/gxanim/Makefile
Normal file
@ -0,0 +1,26 @@
|
||||
# New ports collection makefile for: xanim
|
||||
# Version required: 0.45
|
||||
# Date created: Sat Nov 5 11:43:03 PST 1994
|
||||
# Whom: Rod Taylor
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
DISTNAME= gxanim-0.45
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://www.iag.net/~aleris/
|
||||
|
||||
MAINTAINER= rod@idiotswitch.org
|
||||
|
||||
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
|
||||
RUN_DEPENDS= xanim:${PORTSDIR}/graphics/xanim
|
||||
|
||||
GTK_CONFIG= ${X11BASE}/bin/gtk12-config
|
||||
|
||||
USE_XLIB= yes
|
||||
|
||||
USE_BZIP2= yes
|
||||
WRKSRC= ${WRKDIR}/gxanim
|
||||
MAKE_ENV= GTK_CONFIG="${GTK_CONFIG}"
|
||||
|
||||
.include <bsd.port.mk>
|
1
multimedia/gxanim/distinfo
Normal file
1
multimedia/gxanim/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (gxanim-0.45.tar.bz2) = 43a6c20583c69ece93efb2a2eabe87c9
|
22
multimedia/gxanim/files/patch-aa
Normal file
22
multimedia/gxanim/files/patch-aa
Normal file
@ -0,0 +1,22 @@
|
||||
--- Makefile.orig Tue Aug 31 14:57:46 1999
|
||||
+++ Makefile Mon Sep 20 11:32:09 1999
|
||||
@@ -1,8 +1,8 @@
|
||||
-CC = gcc
|
||||
-CFLAGS = -O2 `gtk-config --cflags`
|
||||
-INSTALLDIR = /usr/local/bin
|
||||
+# CC = gcc
|
||||
+CFLAGS += `${GTK_CONFIG} --cflags`
|
||||
+INSTALLDIR = ${PREFIX}/bin
|
||||
|
||||
-LIBS = `gtk-config --libs`
|
||||
+LIBS = `${GTK_CONFIG} --libs`
|
||||
OBJS = runxanim.o gxanim.o memory.o filesel.o util.o valxanim.o control.o windows.o config.o prefs.o
|
||||
|
||||
FINAL = gxanim
|
||||
@@ -29,5 +29,5 @@
|
||||
rm -f ${FINAL}
|
||||
|
||||
install :
|
||||
- mv ${FINAL} ${INSTALLDIR}
|
||||
+ ${BSD_INSTALL_PROGRAM} ${FINAL} ${INSTALLDIR}
|
||||
|
1
multimedia/gxanim/pkg-comment
Normal file
1
multimedia/gxanim/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
A graphical front end to Xanim.
|
6
multimedia/gxanim/pkg-descr
Normal file
6
multimedia/gxanim/pkg-descr
Normal file
@ -0,0 +1,6 @@
|
||||
GXAnim is a graphical interface to XAnim written with the GTK+ toolkit for UNIX
|
||||
platforms. You can quickly find a movie file, play it, and do the usual
|
||||
VCR-like stuff (rewind, fast forward, pause, stop set volume, etc.), as
|
||||
well as set general play preferences.
|
||||
|
||||
WWW: http://www.iag.net/~aleris/gxanim.html
|
1
multimedia/gxanim/pkg-plist
Normal file
1
multimedia/gxanim/pkg-plist
Normal file
@ -0,0 +1 @@
|
||||
bin/gxanim
|
Loading…
Reference in New Issue
Block a user