devel/sdbus-cpp: update to 1.1.0
Changes: https://github.com/Kistler-Group/sdbus-cpp/releases/tag/v1.1.0 Reported by: GitHub (watch releases)
This commit is contained in:
parent
645a63cd63
commit
07cee16dc7
@ -1,6 +1,6 @@
|
||||
PORTNAME= sdbus-cpp
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 1.0.0
|
||||
DISTVERSION= 1.1.0
|
||||
CATEGORIES= devel
|
||||
|
||||
MAINTAINER= jbeich@FreeBSD.org
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1635145357
|
||||
SHA256 (Kistler-Group-sdbus-cpp-v1.0.0_GH0.tar.gz) = 3db82112c0d8a171a4115d761e3a592b62091fa7600988736652595178ae4e94
|
||||
SIZE (Kistler-Group-sdbus-cpp-v1.0.0_GH0.tar.gz) = 202061
|
||||
TIMESTAMP = 1640175451
|
||||
SHA256 (Kistler-Group-sdbus-cpp-v1.1.0_GH0.tar.gz) = 35e939fdd9c796522702c9c8762dd59b5c47f3440c01ba9feb9921c042780b55
|
||||
SIZE (Kistler-Group-sdbus-cpp-v1.1.0_GH0.tar.gz) = 201532
|
||||
|
@ -1,8 +1,8 @@
|
||||
libsystemd is Linux-only, so replace with basu
|
||||
|
||||
--- CMakeLists.txt.orig 2021-10-25 07:02:37 UTC
|
||||
--- CMakeLists.txt.orig 2021-12-22 12:17:31 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -16,15 +16,14 @@ option(BUILD_LIBSYSTEMD "Build libsystemd static libra
|
||||
@@ -16,7 +16,7 @@ option(BUILD_LIBSYSTEMD "Build libsystemd static libra
|
||||
|
||||
if(NOT BUILD_LIBSYSTEMD)
|
||||
find_package(PkgConfig REQUIRED)
|
||||
@ -10,8 +10,9 @@ libsystemd is Linux-only, so replace with basu
|
||||
+ pkg_check_modules(Systemd IMPORTED_TARGET GLOBAL basu)
|
||||
if(NOT TARGET PkgConfig::Systemd)
|
||||
message(FATAL_ERROR "libsystemd of version at least 236 is required, but was not found "
|
||||
"(you may turn BUILD_LIBSYSTEMD on for sdbus-c++ to try downloading "
|
||||
"and building libsystemd in as part of sdbus-c++ during configuration)")
|
||||
"(if you have systemd in your OS, you may want to install package containing pkgconfig "
|
||||
@@ -25,8 +25,7 @@ if(NOT BUILD_LIBSYSTEMD)
|
||||
"and incorporate libsystemd as embedded library within sdbus-c++)")
|
||||
endif()
|
||||
add_library(Systemd::Libsystemd ALIAS PkgConfig::Systemd)
|
||||
- string(REGEX MATCHALL "([0-9]+)" SYSTEMD_VERSION_LIST "${Systemd_VERSION}")
|
||||
@ -186,19 +187,6 @@ libsystemd is Linux-only, so replace with basu
|
||||
#include <stdbool.h>
|
||||
|
||||
#ifdef __cplusplus
|
||||
--- tests/integrationtests/AdaptorAndProxy_test.cpp.orig 2021-10-25 07:02:37 UTC
|
||||
+++ tests/integrationtests/AdaptorAndProxy_test.cpp
|
||||
@@ -510,8 +510,8 @@ TEST_F(SdbusTestObject, AnswersMachineUuidViaPeerInter
|
||||
// a non-systemd Linux), org.freedesktop.DBus.Peer.GetMachineId() will not work. To solve
|
||||
// this, you can create /etc/machine-id yourself as symlink to /var/lib/dbus/machine-id,
|
||||
// and then org.freedesktop.DBus.Peer.GetMachineId() will start to work.
|
||||
- if (::access("/etc/machine-id", F_OK) == -1)
|
||||
- GTEST_SKIP() << "/etc/machine-id file does not exist, GetMachineId() will not work";
|
||||
+ if (::access("/var/lib/dbus/machine-id", F_OK) == -1)
|
||||
+ GTEST_SKIP() << "/var/lib/dbus/machine-id file does not exist, GetMachineId() will not work";
|
||||
|
||||
ASSERT_NO_THROW(m_proxy->GetMachineId());
|
||||
}
|
||||
--- tests/integrationtests/DBusStandardInterfacesTests.cpp.orig 2021-10-25 07:02:37 UTC
|
||||
+++ tests/integrationtests/DBusStandardInterfacesTests.cpp
|
||||
@@ -65,8 +65,8 @@ TEST_F(SdbusTestObject, AnswersMachineUuidViaPeerInter
|
||||
|
@ -24,6 +24,6 @@ lib/cmake/sdbus-c++/sdbus-c++-targets-%%CMAKE_BUILD_TYPE%%.cmake
|
||||
lib/cmake/sdbus-c++/sdbus-c++-targets.cmake
|
||||
lib/libsdbus-c++.so
|
||||
lib/libsdbus-c++.so.1
|
||||
lib/libsdbus-c++.so.1.0.0
|
||||
lib/libsdbus-c++.so.1.1.0
|
||||
libdata/pkgconfig/sdbus-c++-tools.pc
|
||||
libdata/pkgconfig/sdbus-c++.pc
|
||||
|
Loading…
Reference in New Issue
Block a user