Update port to 1.99.12
PR: 20264 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
This commit is contained in:
parent
2a7f4af49b
commit
0721c061a1
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=31225
@ -6,21 +6,21 @@
|
||||
#
|
||||
|
||||
PORTNAME= oleo
|
||||
PORTVERSION= 1.99.5
|
||||
PORTVERSION= 1.99.12
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= ${MASTER_SITE_GNU}
|
||||
MASTER_SITE_SUBDIR= oleo
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
||||
BUILD_DEPENDS= gettext:${PORTSDIR}/devel/gettext
|
||||
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
|
||||
|
||||
USE_XLIB= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_AUTOCONF= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
|
||||
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
|
||||
CONFIGURE_ARGS= --with-x --without-motif \
|
||||
--without-Xbae --without-XmHTML \
|
||||
--without-xlt --without-SciPlot
|
||||
--without-xbae --without-xlt \
|
||||
--without-xmhtml --without-SciPlot
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (oleo-1.99.5.tar.gz) = 80cad7cb19e12a5f75b80a7c72849748
|
||||
MD5 (oleo-1.99.12.tar.gz) = 57ac0e2eab661685ef5f6fa6bfe5b1c5
|
||||
|
@ -1,8 +1,16 @@
|
||||
--- Makefile.in.orig Sat Jul 10 16:46:45 1999
|
||||
+++ Makefile.in Sat Sep 18 04:16:54 1999
|
||||
@@ -123,7 +123,7 @@
|
||||
EXTRA_DIST = oleobug.in FAQ oleo.spec.in oleo.spec ftp.gnudist ftp.alpha ftp.dist
|
||||
--- Makefile.in.orig Sat Jul 22 18:51:35 2000
|
||||
+++ Makefile.in Fri Jul 28 04:28:46 2000
|
||||
@@ -124,14 +124,14 @@
|
||||
|
||||
D = `date +%G%m%d.%H%M%S`
|
||||
|
||||
-SUBDIRS = doc lib intl src m4 po Xresources examples afm
|
||||
+SUBDIRS = doc lib intl src m4 po Xresources examples
|
||||
|
||||
# Remove this file here (it is created via configure), not from within intl.
|
||||
DISTCLEANFILES = intl/libintl.h
|
||||
|
||||
EXTRA_DIST = oleobug.in FAQ oleo.spec.in oleo.spec
|
||||
|
||||
-docdir = $(prefix)/Oleo
|
||||
+docdir = $(datadir)/doc/Oleo
|
||||
|
60
math/oleo/files/patch-ag
Normal file
60
math/oleo/files/patch-ag
Normal file
@ -0,0 +1,60 @@
|
||||
--- aclocal.m4.orig Thu Feb 10 05:22:27 2000
|
||||
+++ aclocal.m4 Fri Jul 28 19:30:42 2000
|
||||
@@ -1733,7 +1733,7 @@
|
||||
# but which still want to provide support for the GNU gettext functionality.
|
||||
# Please note that the actual code is *not* freely available.
|
||||
|
||||
-# serial 3
|
||||
+# serial 5
|
||||
|
||||
AC_DEFUN(AM_WITH_NLS,
|
||||
[AC_MSG_CHECKING([whether NLS is requested])
|
||||
@@ -1775,9 +1775,10 @@
|
||||
AC_CHECK_LIB(intl, bindtextdomain,
|
||||
[AC_CACHE_CHECK([for gettext in libintl],
|
||||
gt_cv_func_gettext_libintl,
|
||||
- [AC_TRY_LINK([], [return (int) gettext ("")],
|
||||
- gt_cv_func_gettext_libintl=yes,
|
||||
- gt_cv_func_gettext_libintl=no)])])
|
||||
+ [AC_CHECK_LIB(intl, gettext,
|
||||
+ gt_cv_func_gettext_libintl=yes,
|
||||
+ gt_cv_func_gettext_libintl=no)],
|
||||
+ gt_cv_func_gettext_libintl=no)])
|
||||
fi
|
||||
|
||||
if test "$gt_cv_func_gettext_libc" = "yes" \
|
||||
@@ -1799,6 +1800,9 @@
|
||||
INSTOBJEXT=.mo
|
||||
fi
|
||||
fi
|
||||
+ if test "$gt_cv_func_gettext_libintl" = "yes"; then
|
||||
+ INTLLIBS='-lintl'
|
||||
+ fi
|
||||
])
|
||||
|
||||
if test "$CATOBJEXT" = "NONE"; then
|
||||
@@ -1883,6 +1887,12 @@
|
||||
nls_cv_header_intl=intl/libintl.h
|
||||
nls_cv_header_libgt=intl/libgettext.h
|
||||
fi
|
||||
+ AC_LINK_FILES($nls_cv_header_libgt, $nls_cv_header_intl)
|
||||
+ AC_OUTPUT_COMMANDS(
|
||||
+ [case "$CONFIG_FILES" in *po/Makefile.in*)
|
||||
+ sed -e "/POTFILES =/r po/POTFILES" po/Makefile.in > po/Makefile
|
||||
+ esac])
|
||||
+
|
||||
|
||||
# If this is used in GNU gettext we have to set USE_NLS to `yes'
|
||||
# because some of the sources are only built for this goal.
|
||||
@@ -1927,9 +1937,9 @@
|
||||
AC_REQUIRE([AC_FUNC_MMAP])dnl
|
||||
|
||||
AC_CHECK_HEADERS([argz.h limits.h locale.h nl_types.h malloc.h string.h \
|
||||
-unistd.h values.h sys/param.h])
|
||||
+unistd.h sys/param.h])
|
||||
AC_CHECK_FUNCS([getcwd munmap putenv setenv setlocale strchr strcasecmp \
|
||||
-__argz_count __argz_stringify __argz_next])
|
||||
+strdup __argz_count __argz_stringify __argz_next])
|
||||
|
||||
if test "${ac_cv_func_stpcpy+set}" != "set"; then
|
||||
AC_CHECK_FUNCS(stpcpy)
|
15
math/oleo/files/patch-ah
Normal file
15
math/oleo/files/patch-ah
Normal file
@ -0,0 +1,15 @@
|
||||
--- configure.in.orig Tue Jul 25 21:56:32 2000
|
||||
+++ configure.in Fri Jul 28 02:51:24 2000
|
||||
@@ -324,12 +324,6 @@
|
||||
AM_GNU_GETTEXT
|
||||
|
||||
dnl
|
||||
-dnl This used to cause all kinds of problems in an earlier revision
|
||||
-dnl of oleo. (Mostly because of using earlier auto* tools.)
|
||||
-dnl
|
||||
-AC_LINK_FILES($nls_cv_header_libgt, $nls_cv_header_intl)
|
||||
-
|
||||
-dnl
|
||||
dnl Pass information about where we install to the source, to be
|
||||
dnl able to read AFM files. Note this doesn't work if you
|
||||
dnl install via "make install DESTDIR=/xxx"
|
11
math/oleo/files/patch-ai
Normal file
11
math/oleo/files/patch-ai
Normal file
@ -0,0 +1,11 @@
|
||||
--- doc/Makefile.in.orig Sat Jul 22 18:51:35 2000
|
||||
+++ doc/Makefile.in Fri Jul 28 03:02:45 2000
|
||||
@@ -87,7 +87,7 @@
|
||||
LIBOBJS = @LIBOBJS@
|
||||
LN_S = @LN_S@
|
||||
MAINT = @MAINT@
|
||||
-MAKEINFO = @MAKEINFO@
|
||||
+MAKEINFO = @MAKEINFO@ --no-split
|
||||
MKINSTALLDIRS = @MKINSTALLDIRS@
|
||||
MOTIF_CFLAGS = @MOTIF_CFLAGS@
|
||||
MOTIF_LIBS = @MOTIF_LIBS@
|
11
math/oleo/files/patch-aj
Normal file
11
math/oleo/files/patch-aj
Normal file
@ -0,0 +1,11 @@
|
||||
--- po/Makefile.in.in.orig Fri Aug 28 06:15:29 1998
|
||||
+++ po/Makefile.in.in Fri Jul 28 04:30:24 2000
|
||||
@@ -119,7 +119,7 @@
|
||||
for cat in $$catalogs; do \
|
||||
cat=`basename $$cat`; \
|
||||
case "$$cat" in \
|
||||
- *.gmo) destdir=$(gnulocaledir);; \
|
||||
+ *.mo) destdir=$(gnulocaledir);; \
|
||||
*) destdir=$(localedir);; \
|
||||
esac; \
|
||||
lang=`echo $$cat | sed 's/\$(CATOBJEXT)$$//'`; \
|
@ -4,14 +4,12 @@ share/locale/fr/LC_MESSAGES/oleo.mo
|
||||
share/locale/nl/LC_MESSAGES/oleo.mo
|
||||
share/oleo/fr/Oleo
|
||||
share/oleo/nl/Oleo
|
||||
share/oleo/oleo.html
|
||||
share/oleo/Oleo
|
||||
share/doc/Oleo/AUTHORS
|
||||
share/doc/Oleo/FAQ
|
||||
@unexec install-info --delete %D/info/oleo.info %D/info/dir
|
||||
info/oleo.info
|
||||
info/oleo.info-1
|
||||
info/oleo.info-2
|
||||
info/oleo.info-3
|
||||
@exec install-info %D/info/oleo.info %D/info/dir
|
||||
@dirrm share/doc/Oleo
|
||||
@dirrm share/oleo/nl
|
||||
|
Loading…
Reference in New Issue
Block a user