x11/kitty: Update to 0.26.4

ChangeLog: https://sw.kovidgoyal.net/kitty/changelog/#detailed-list-of-changes

 * Allow centering the background_image
 * X11: Fix a regression in the previous release that caused pasting from GTK
   based applications to have extra newlines
 * Tab bar: Improve empty space management when some tabs have short titles,
   allocate the saved space to the active tab
 * Fix background_tint not applying to window margins and padding
 * Wayland: Fix background image scaling using tiled mode on high DPI screens
 * Wayland: Fix an abort when changing background colors with
   wayland_titlebar_color set to background
 * Update to Unicode 15.0
 * GNOME Wayland: Fix a memory leak in gnome-shell when using client side
   decorations
 * Wayland: Mark windows in which a bell occurs as urgent on compositors that
   support the xdg-activation protocol
 * Allow passing null bytes through the system clipboard
 * ssh kitten: Fix KITTY_PUBLIC_KEY not being encoded properly when transmitting
 * Sessions: Allow controlling which OS Window is active via the
   focus_os_window directive
 * Wayland: Fix for bug in NVIDIA drivers that prevents transparency working
 * Wayland: Fix for a bug that could cause kitty to become non-responsive when
   using multiple OS windows in a single instance on some compositors
 * Wayland: Fix for a bug preventing kitty from starting on Hyprland when using
   a non-unit scale
 * Wayland: Generate a XDG_ACTIVATION_TOKEN when opening URLs or running
   programs in the background via the launch action
 * Fix a regression that caused kitty not to restore SIGPIPE after python nukes
   it when launching children. Affects bash which does not sanitize its signal
   mask.
 * Fix a use-after-free when handling fake mouse clicks and the action causes
windows to be removed/re-allocated

PR:		267209
Reported by:	alexis.praga@proton.me (maintainer)
This commit is contained in:
Alexis Praga 2022-10-20 07:47:29 +02:00 committed by Fernando Apesteguía
parent 6266198345
commit 0720e8460e
4 changed files with 37 additions and 6 deletions

View File

@ -1,5 +1,5 @@
PORTNAME= kitty
DISTVERSION= 0.26.2
DISTVERSION= 0.26.4
CATEGORIES= x11 wayland
MASTER_SITES= https://github.com/kovidgoyal/${PORTNAME}/releases/download/v${DISTVERSION}/
@ -14,7 +14,6 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}furo>0:textproc/py-furo@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sphinx-copybutton>0:textproc/py-sphinx-copybutton@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sphinx-inline-tabs>0:textproc/py-sphinx-inline-tabs@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sphinxext-opengraph>0:textproc/py-sphinxext-opengraph@${PY_FLAVOR} \
openssl>0:security/openssl \
sphinx-build:textproc/py-sphinx@${PY_FLAVOR} \
wayland-protocols>=0:graphics/wayland-protocols
LIB_DEPENDS= libdbus-1.so:devel/dbus \

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1663399175
SHA256 (kitty-0.26.2.tar.xz) = 586ff599c5a3f31831b2a32dd9faafacb6c3581f2561f8ddcab0ba815bc7dab4
SIZE (kitty-0.26.2.tar.xz) = 4716932
TIMESTAMP = 1666199757
SHA256 (kitty-0.26.4.tar.xz) = c09591ac7c908e6a0549f75cc061c6318f46261f9f5d3f3775120063c3a43bb7
SIZE (kitty-0.26.4.tar.xz) = 4749148

View File

@ -0,0 +1,31 @@
--- setup.py.orig 2022-10-19 17:45:56 UTC
+++ setup.py
@@ -130,25 +130,9 @@ def libcrypto_flags() -> Tuple[List[str], List[str]]:
# Apple use their special snowflake TLS libraries and additionally
# have an ancient broken system OpenSSL, so we need to check for one
# installed by all the various macOS package managers.
- extra_pc_dir = ''
-
- try:
- cflags = pkg_config('libcrypto', '--cflags-only-I', fatal=False)
- except subprocess.CalledProcessError:
- if is_macos:
- import ssl
- v = ssl.OPENSSL_VERSION_INFO
- pats = f'{v[0]}.{v[1]}', f'{v[0]}'
- for pat in pats:
- q = f'opt/openssl@{pat}/lib/pkgconfig'
- openssl_dirs = glob.glob(f'/opt/homebrew/{q}') + glob.glob(f'/usr/local/{q}')
- if openssl_dirs:
- break
- if not openssl_dirs:
- raise SystemExit(f'Failed to find OpenSSL version {v[0]}.{v[1]} on your system')
- extra_pc_dir = os.pathsep.join(openssl_dirs)
- cflags = pkg_config('libcrypto', '--cflags-only-I', extra_pc_dir=extra_pc_dir)
- return cflags, pkg_config('libcrypto', '--libs', extra_pc_dir=extra_pc_dir)
+ cflags = [f"-I{sys.prefix}/include"]
+ libs = [f"-L{sys.prefix}/lib", "-lcrypto"]
+ return cflags, libs
def at_least_version(package: str, major: int, minor: int = 0) -> None:

View File

@ -36,7 +36,6 @@ lib/kitty/kittens/mouse_demo/__init__.py
lib/kitty/kittens/mouse_demo/main.py
lib/kitty/kittens/panel/__init__.py
lib/kitty/kittens/panel/main.py
lib/kitty/kitty/prewarm.py
lib/kitty/kittens/query_terminal/__init__.py
lib/kitty/kittens/query_terminal/main.py
lib/kitty/kittens/remote_file/__init__.py
@ -102,6 +101,7 @@ lib/kitty/kitty/choose_entry.py
lib/kitty/kitty/cli.py
lib/kitty/kitty/cli_stub.py
lib/kitty/kitty/client.py
lib/kitty/kitty/clipboard.py
lib/kitty/kitty/complete.py
lib/kitty/kitty/conf/__init__.py
lib/kitty/kitty/conf/generate.py
@ -148,6 +148,7 @@ lib/kitty/kitty/options/parse.py
lib/kitty/kitty/options/types.py
lib/kitty/kitty/options/utils.py
lib/kitty/kitty/os_window_size.py
lib/kitty/kitty/prewarm.py
lib/kitty/kitty/rc/__init__.py
lib/kitty/kitty/rc/base.py
lib/kitty/kitty/rc/close_tab.py