Log the contents of unwanted tcp and udp connections.

PR:		11973
Submitted by:	Warren Toomey
This commit is contained in:
Michael Haro 1999-06-01 20:29:14 +00:00
parent 8148933a31
commit 06f90cb3cb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=19166
7 changed files with 61 additions and 0 deletions

View File

@ -0,0 +1,21 @@
# New ports collection makefile for: pktsuckers
# Version required: 1.2
# Date created: 31 May 1999
# Whom: Warren Toomey <wkt@cs.adfa.edu.au>
#
# $Id$
#
DISTNAME= pktsuckers1_2
PKGNAME= pktsuckers-1.2
CATEGORIES= security net
MASTER_SITES= ftp://minnie.cs.adfa.edu.au/pub/NetSecurity/
MAINTAINER= wkt@cs.adfa.edu.au
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tcpsuck ${PREFIX}/libexec
${INSTALL_PROGRAM} ${WRKSRC}/udpsuck ${PREFIX}/libexec
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (pktsuckers1_2.tar.gz) = 5b6878f7d8b81020ab2f61d4af41eac1

View File

@ -0,0 +1,26 @@
--- Makefile.orig Mon May 31 20:32:49 1999
+++ Makefile Tue Jun 1 13:17:49 1999
@@ -3,8 +3,8 @@
# $Date: 1999/06/01 03:32:48 $
#
-DESTDIR= /usr/local/libexec
-CFLAGS= -Wall
+DESTDIR= ${PREFIX}/libexec
+CFLAGS?= -Wall
LDFLAGS= -static
all: tcpsuck udpsuck
@@ -16,10 +16,10 @@
@echo ''
tcpsuck: tcpsuck.o dump_pkt.o
- cc -o tcpsuck $(LDFLAGS) tcpsuck.o dump_pkt.o
+ ${CC} ${CFLAGS} -o tcpsuck $(LDFLAGS) tcpsuck.o dump_pkt.o
udpsuck: udpsuck.o dump_pkt.o
- cc -o udpsuck $(LDFLAGS) udpsuck.o dump_pkt.o
+ ${CC} ${CFLAGS} -o udpsuck $(LDFLAGS) udpsuck.o dump_pkt.o
clean:
rm -f *.o *.BAK *.core tcpsuck udpsuck

View File

@ -0,0 +1 @@
Log contents of unwanted UDP packets and TCP connections

View File

@ -0,0 +1,7 @@
The two programs tcpsuck and udpsuck run out of the Inetd daemon on
unused ports. They log the contents of packets or connections to these
ports. This allows you to read the contents of the network strobe
attacks on your machine. It also slows the strobes down, as they think
you're actually running a service on several ports when you aren't.
Warren Toomey, wkt@cs.adfa.edu.au

View File

@ -0,0 +1,3 @@
You need to edit your inetd.conf to enable the suckers

View File

@ -0,0 +1,2 @@
libexec/tcpsuck
libexec/udpsuck