New port faad version 1.1: A LC, MAIN and LTP profile, MPEG2 and

MPEG-4 AAC decoder

PR:		46884
Submitted by:	Sean McGovern <sean@sfarc.net>
This commit is contained in:
Mario Sergio Fujikawa Ferreira 2003-01-18 19:21:13 +00:00
parent e622b31995
commit 06f6765b64
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=73421
10 changed files with 134 additions and 0 deletions

View File

@ -50,6 +50,7 @@
SUBDIR += ecawave
SUBDIR += esound
SUBDIR += extace
SUBDIR += faad
SUBDIR += fcplay
SUBDIR += festdoc
SUBDIR += festival

53
audio/faad/Makefile Normal file
View File

@ -0,0 +1,53 @@
# New ports collection makefile for: faad
# Date created: 8 January 2003
# Whom: Sean McGovern <sean@sfarc.net>
#
# $FreeBSD$
#
PORTNAME= faad2
PORTVERSION= 1.1
CATEGORIES= audio
MASTER_SITES= http://faac.sourceforge.net/files/
MAINTAINER= sean@sfarc.net
LIB_DEPENDS= sndfile.1:${PORTSDIR}/audio/libsndfile \
gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_AUTOMAKE_VER= 15
AUTOMAKE_ARGS= --add-missing
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
USE_REINPLACE= yes
CONFIGURE_ARGS= --program-transform-name=''
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
INSTALLS_SHLIB= yes
post-patch:
# make sure everything is prepared prior to configure stage
# pre-configure will not work since *AUTO* tools happen in-between
@cd ${WRKSRC}; ${ACLOCAL} -I ${ACLOCAL_DIR} -I .; libtoolize \
--automake
# CFLAGS safeness
@${FIND} ${WRKSRC} -type f -name Makefile.am | \
${XARGS} -n 5 -x \
${REINPLACE_CMD} -e \
's|-O2|${CFLAGS}|'
post-configure:
# sync the multiple libtool copies
@${CP} ${WRKSRC}/${LIBTOOL} ${WRKSRC}/common/mp4v2/
.include <bsd.port.pre.mk>
CONFIGURE_ARGS+= --build=${CONFIGURE_TARGET}
.include <bsd.port.post.mk>

1
audio/faad/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (faad2-1.1.tar.gz) = 5a20a6268484dea0e080df47f64b9075

View File

@ -0,0 +1,16 @@
--- common/mp4v2/configure.in.orig Wed Jan 8 19:45:23 2003
+++ common/mp4v2/configure.in Wed Jan 8 19:45:57 2003
@@ -1,11 +1,12 @@
AC_INIT()
+AC_CANONICAL_TARGET
AM_INIT_AUTOMAKE(mpeg4ip,0.9.2.8,dummy)
AC_PROG_CC
AC_PROG_CXX
AC_PROG_INSTALL
-AM_PROG_LIBTOOL
+AC_PROG_LIBTOOL
AM_CONFIG_HEADER(config.h)

View File

@ -0,0 +1,26 @@
--- configure.in.orig Fri Aug 9 03:23:28 2002
+++ configure.in Wed Jan 8 19:20:59 2003
@@ -1,8 +1,9 @@
-AC_INIT()
+AC_INIT
+AC_CANONICAL_TARGET
AM_INIT_AUTOMAKE(faad,2.0)
AC_PROG_CC
-AM_PROG_LIBTOOL
+AC_PROG_LIBTOOL
AC_SUBST(LIBTOOL_DEPS)
dnl Checks for programs.
@@ -29,8 +30,9 @@
])
fi
-AC_OUTPUT_COMMANDS(,[cd common/mp4v2; aclocal -I .; autoheader; libtoolize --automake; automake --add-missing; autoconf; cd -])
+AC_CONFIG_COMMANDS([default-1],[[]],[[cd common/mp4v2; aclocal -I . -I /usr/local/share/aclocal; autoheader; libtoolize --automake; automake --add-missing; autoconf; cd -]])
AC_CONFIG_SUBDIRS(common/mp4v2)
-AC_OUTPUT(libfaad/Makefile common/Makefile frontend/Makefile Makefile)
+AC_CONFIG_FILES([libfaad/Makefile common/Makefile frontend/Makefile Makefile])
+AC_OUTPUT

View File

@ -0,0 +1,8 @@
--- frontend/Makefile.am.orig Thu Jul 25 10:22:25 2002
+++ frontend/Makefile.am Wed Jan 8 21:30:40 2003
@@ -6,4 +6,4 @@
CFLAGS = -O2 -D_FILE_OFFSET_BITS=64
INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)/common/mp4v2
LDFLAGS =
-LDADD = $(top_builddir)/libfaad/libfaad.la $(top_builddir)/common/mp4v2/libmp4v2.la -lm -lsndfile
+LDADD = $(top_builddir)/libfaad/libfaad.la $(top_builddir)/common/mp4v2/libmp4v2.la -lm -lsndfile -lgnugetopt

View File

@ -0,0 +1,11 @@
--- frontend/audio.c.orig Thu Jul 25 08:42:54 2002
+++ frontend/audio.c Wed Jan 8 20:52:34 2003
@@ -52,7 +52,7 @@
break;
}
aufile->sfinfo.channels = channels;
- aufile->sfinfo.samples = 0;
+ aufile->sfinfo.frames = 0;
#ifdef _WIN32
if(infile[0] == '-')
{

1
audio/faad/pkg-comment Normal file
View File

@ -0,0 +1 @@
A LC, MAIN and LTP profile, MPEG2 and MPEG-4 AAC decoder

9
audio/faad/pkg-descr Normal file
View File

@ -0,0 +1,9 @@
This is FAAD 2 - Freeware Advanced Audio Decoder 2.
FAAD 2 is a LC, MAIN and LTP profile, MPEG2 and MPEG-4 AAC decoder,
completely written from scratch.
WWW: http://faac.sourceforge.net/
- Sean McGovern
sean@sfarc.net

8
audio/faad/pkg-plist Normal file
View File

@ -0,0 +1,8 @@
bin/faad
include/faad.h
lib/libfaad.a
lib/libfaad.so
lib/libfaad.so.0
lib/libmp4v2.a
lib/libmp4v2.so
lib/libmp4v2.so.0