- Update to version 0.2.11 [1]
- Remove optional installation of DOCS files, staging takes care of that, make it shorter PR: ports/187447 [1] Submitted by: maintainer
This commit is contained in:
parent
94d84a2d15
commit
06efbf78f0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=348114
@ -2,7 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= dynamips
|
||||
PORTVERSION= 0.2.10
|
||||
PORTVERSION= 0.2.11
|
||||
CATEGORIES= emulators
|
||||
MASTER_SITES= SF/gns-3/Dynamips/${PORTVERSION}
|
||||
PKGNAMESUFFIX= -community
|
||||
@ -39,44 +39,34 @@ PLIST_FILES= bin/${PORTNAME} bin/nvram_export \
|
||||
PORTDOCS= *
|
||||
|
||||
.if ${PORT_OPTIONS:MUNSTABLE}
|
||||
DYNAMIPS_CODE= "unstable"
|
||||
DYNAMIPS_CODE= unstable
|
||||
.else
|
||||
DYNAMIPS_CODE= "stable"
|
||||
DYNAMIPS_CODE= stable
|
||||
.endif
|
||||
|
||||
DYNAMIPS_ARCH= "nojit"
|
||||
|
||||
.if ${ARCH} == "i386"
|
||||
DYNAMIPS_ARCH= "x86"
|
||||
.elif ${ARCH} == "amd64" || ${ARCH} == "x86_64"
|
||||
DYNAMIPS_ARCH= "amd64"
|
||||
.elif ${ARCH} == "powerpc" && ${DYNAMIPS_CODE} == "unstable"
|
||||
DYNAMIPS_ARCH= "ppc32"
|
||||
.if ${ARCH} == powerpc && ${DYNAMIPS_CODE} == unstable
|
||||
DYNAMIPS_ARCH= ppc32
|
||||
.endif
|
||||
|
||||
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000
|
||||
DYNAMIPS_ARCH= "nojit"
|
||||
DYNAMIPS_ARCH= nojit
|
||||
.endif
|
||||
|
||||
#BROKEN_ia64= does not compile: invokes i386 assembler
|
||||
#BROKEN_sparc64= ${BROKEN_ia64}
|
||||
#BROKEN_powerpc= ${BROKEN_ia64}
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}.${DYNAMIPS_CODE} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${DYNAMIPS_CODE}/nvram_export ${STAGEDIR}${PREFIX}/bin
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/nvram_export.${DYNAMIPS_CODE} ${STAGEDIR}${PREFIX}/bin/nvram_export
|
||||
${INSTALL_MAN} ${WRKSRC}/man/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
|
||||
${INSTALL_MAN} ${WRKSRC}/man/nvram_export.1 ${STAGEDIR}${MANPREFIX}/man/man1
|
||||
${INSTALL_MAN} ${WRKSRC}/man/hypervisor_mode.7 ${STAGEDIR}${MANPREFIX}/man/man7
|
||||
|
||||
post-install:
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/README.hypervisor ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/RELEASE-NOTES ${STAGEDIR}${DOCSDIR}
|
||||
.endif
|
||||
.for file in README README.hypervisor RELEASE-NOTES ChangeLog MAINTAINERS
|
||||
${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1,2 +1,2 @@
|
||||
SHA256 (dynamips-0.2.10-source.zip) = d62f739547134aeb0ee5a6b28a52772ae79a93cb6426b712cbddc72cb0b7ba44
|
||||
SIZE (dynamips-0.2.10-source.zip) = 966018
|
||||
SHA256 (dynamips-0.2.11-source.zip) = 4278baecf1f6718433722e6f38179a69ec9b2ef02381b31c5d3ef5b8f8f3e94a
|
||||
SIZE (dynamips-0.2.11-source.zip) = 967525
|
||||
|
24
emulators/dynamips-community/files/patch-Makefile
Normal file
24
emulators/dynamips-community/files/patch-Makefile
Normal file
@ -0,0 +1,24 @@
|
||||
--- Makefile.orig 2014-02-10 17:50:38.000000000 +0400
|
||||
+++ Makefile 2014-03-03 12:12:12.000000000 +0400
|
||||
@@ -4,14 +4,15 @@
|
||||
# - Use "x86" for a build on x86 (32-bits)
|
||||
# - Use "amd64" for a build on x86_64 (64-bits)
|
||||
# - Use "nojit" for unsupported architectures.
|
||||
-ifeq ($(shell arch),x86_64)
|
||||
-export DYNAMIPS_ARCH?=amd64
|
||||
+ifndef DYNAMIPS_ARCH
|
||||
+ifneq ($(findstring $(shell uname -m),x86_64 amd64),)
|
||||
+DYNAMIPS_ARCH=amd64
|
||||
+else ifneq ($(findstring $(shell uname -m),i686 i386),)
|
||||
+DYNAMIPS_ARCH=x86
|
||||
else
|
||||
-ifeq ($(shell arch),i686)
|
||||
-export DYNAMIPS_ARCH?=x86
|
||||
-else
|
||||
-export DYNAMIPS_ARCH?=nojit
|
||||
+DYNAMIPS_ARCH=nojit
|
||||
endif
|
||||
+export DYNAMIPS_ARCH
|
||||
endif
|
||||
|
||||
# For MAC x64 you can compile the "unstable" version, which should work
|
@ -0,0 +1,9 @@
|
||||
--- common/fs_nvram.c.orig 2014-03-03 12:41:30.000000000 +0400
|
||||
+++ common/fs_nvram.c 2014-03-03 12:41:46.000000000 +0400
|
||||
@@ -862,4 +862,4 @@
|
||||
}
|
||||
|
||||
return(0);
|
||||
-}
|
||||
\ No newline at end of file
|
||||
+}
|
20
emulators/dynamips-community/files/patch-stable_Makefile
Normal file
20
emulators/dynamips-community/files/patch-stable_Makefile
Normal file
@ -0,0 +1,20 @@
|
||||
--- stable/Makefile.orig 2014-02-10 17:50:38.000000000 +0400
|
||||
+++ stable/Makefile 2014-03-03 12:35:51.000000000 +0400
|
||||
@@ -2,6 +2,8 @@
|
||||
# Copyright (c) 2005-2006 Christophe Fillot.
|
||||
# Copyright (c) 2013 Daniel Lintott.
|
||||
|
||||
+$(warning stable DYNAMIPS_ARCH="${DYNAMIPS_ARCH}")
|
||||
+
|
||||
# Get include files from the current directory and from the common directory
|
||||
INCLUDE+=-I. -I../common
|
||||
|
||||
@@ -244,7 +246,7 @@
|
||||
|
||||
nvram_export$(BIN_EXT): nvram_export.o fs_nvram.o
|
||||
@echo "Linking $@"
|
||||
- @$(CC) -Wall $(CFLAGS) $(INCLUDE) $(LDFLAGS) -o $@ nvram_export.o fs_nvram.o
|
||||
+ @$(CC) -Wall $(CFLAGS) $(INCLUDE) $(LDFLAGS) -o $@ nvram_export.o fs_nvram.o $(LIBS)
|
||||
|
||||
.PHONY: clean
|
||||
clean:
|
11
emulators/dynamips-community/files/patch-unstable_Makefile
Normal file
11
emulators/dynamips-community/files/patch-unstable_Makefile
Normal file
@ -0,0 +1,11 @@
|
||||
--- unstable/Makefile.orig 2014-03-03 12:37:26.000000000 +0400
|
||||
+++ unstable/Makefile 2014-03-03 12:37:56.000000000 +0400
|
||||
@@ -249,7 +249,7 @@
|
||||
|
||||
nvram_export$(BIN_EXT): nvram_export.o fs_nvram.o
|
||||
@echo "Linking $@"
|
||||
- @$(CC) -Wall $(CFLAGS) $(INCLUDE) $(LDFLAGS) -o $@ nvram_export.o fs_nvram.o
|
||||
+ @$(CC) -Wall $(CFLAGS) $(INCLUDE) $(LDFLAGS) -o $@ nvram_export.o fs_nvram.o $(LIBS)
|
||||
|
||||
.PHONY: clean
|
||||
clean:
|
Loading…
Reference in New Issue
Block a user