Update to version 9.0.302, which should build and work on all versions of

FreeBSD since 1993 without any patches.  Touch the COMMENT while I'm here.

This is result of collaborative work by Frank da Cruz (C-Kermit original
author and current upstream maintainer) and yours truly.
This commit is contained in:
Alexey Dokuchaev 2011-08-21 18:12:08 +00:00
parent 435b5782a6
commit 06e6ff3128
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=280129
4 changed files with 6 additions and 63 deletions

View File

@ -6,14 +6,14 @@
#
PORTNAME= kermit
PORTVERSION= 9.0.301
PORTVERSION= 9.0.302
CATEGORIES= comms
MASTER_SITES= ftp://kermit.columbia.edu/kermit/archives/ \
ftp://ftp.icm.edu.pl/pub/kermit/archives/
DISTNAME= cku${PORTVERSION:E}
MAINTAINER= danfe@FreeBSD.org
COMMENT= Combined network and serial communication package
COMMENT= Portable scriptable network and serial communication program
LICENSE= BSD
@ -22,25 +22,14 @@ NO_WRKSUBDIR= yes
MAKEFILE= makefile
ALL_TARGET= freebsd+ssl
MAKE_ARGS= CC2=${CC} SSLINC=-I${OPENSSLINC} SSLLIB=-L${OPENSSLLIB}
CFLAGS+= -DHERALD=\\\"\\\\\\\" ${HERALD}\\\\\\\"\\\"
PLIST_FILES= bin/kermit
PORTDOCS= *
PORTEXAMPLES= *
MAN1= kermit.1
.include <bsd.port.pre.mk>
# Explicitly pass version of our beloved OS until upstream code is fixed
HERALD!= ${UNAME} -sr
post-patch:
@${REINPLACE_CMD} -e 's,-O -pipe,${CFLAGS},' ${WRKSRC}/${MAKEFILE}
# Catch up with recent <utmp.h> replacement by <utmpx.h>
.if ${OSVERSION} > 900006
@${REINPLACE_CMD} -e 's,ut\.ut_name,ut.ut_user,g' \
-e 's,UNIXWARE,FREEBSD4,' ${WRKSRC}/ckufio.c
.endif
@${REINPLACE_CMD} -e 's,-O2 -pipe,${CFLAGS},' ${WRKSRC}/${MAKEFILE}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/wermit ${PREFIX}/bin/kermit
@ -56,4 +45,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/ckermod.ini ${EXAMPLESDIR}/dot.mykermrc
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
SHA256 (cku301.tar.gz) = 9793eb125f8936b079c6d7e5c3d2ff885cfedc07f9d2dd1e7db928e3029a211a
SIZE (cku301.tar.gz) = 3120826
SHA256 (cku302.tar.gz) = 0d5f2cd12bdab9401b4c836854ebbf241675051875557783c332a6a40dac0711
SIZE (cku302.tar.gz) = 3122219

View File

@ -1,25 +0,0 @@
$FreeBSD$
--- ck_crp.c.orig Tue Jun 25 17:53:02 2002
+++ ck_crp.c Tue Mar 4 15:14:45 2003
@@ -396,7 +396,7 @@
des_new_random_key(Block B)
{
int rc=0;
- rc = des_random_key(B);
+ des_random_key(B);
return(rc);
}
@@ -467,8 +467,8 @@
* These function pointers point to the current routines
* for encrypting and decrypting data.
*/
-static VOID (*encrypt_output) P((unsigned char *, int));
-static int (*decrypt_input) P((int));
+VOID (*encrypt_output) P((unsigned char *, int));
+int (*decrypt_input) P((int));
#ifdef DEBUG
static int encrypt_debug_mode = 1;

View File

@ -1,21 +0,0 @@
--- ckutio.c.orig
+++ ckutio.c
@@ -4879,8 +4879,18 @@
#ifdef USETTYLOCK
haslock = 0; /* Not locked yet. */
*flfnam = '\0'; /* Lockfile name is empty. */
+#ifdef __FreeBSD__
+ char *devname;
+ if ((devname = xxlast(ttdev,'/')) != NULL)
+#if __FreeBSD_version < 800045
+ ckstrncpy(lockname,devname+1,DEVNAMLEN);
+#else
+ ckstrncat(lockname,devname+1,DEVNAMLEN-ckstrncpy(lockname,"pts",4));
+#endif
+#else
if (!strncmp(ttdev,"/dev/",5) && ttdev[5])
ckstrncpy(lockname,ttdev+5,DEVNAMLEN);
+#endif
else
ckstrncpy(lockname,ttdev,DEVNAMLEN);
/*