add gsasl 0.0.8
GNU SASL Library
This commit is contained in:
parent
748e12677b
commit
06d3510c28
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=92625
@ -102,6 +102,7 @@
|
||||
SUBDIR += gpasman
|
||||
SUBDIR += gpgme
|
||||
SUBDIR += gringotts
|
||||
SUBDIR += gsasl
|
||||
SUBDIR += gsfv
|
||||
SUBDIR += gss
|
||||
SUBDIR += gtk-knocker
|
||||
|
38
security/gsasl/Makefile
Normal file
38
security/gsasl/Makefile
Normal file
@ -0,0 +1,38 @@
|
||||
# ex:ts=8
|
||||
# Ports collection makefile for: gsasl
|
||||
# Date created: Oct 18, 2003
|
||||
# Whom: ijliao
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= gsasl
|
||||
PORTVERSION= 0.0.8
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://josefsson.org/${PORTNAME}/releases/ \
|
||||
ftp://alpha.gnu.org/pub/gnu/${PORTNAME}/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= GNU SASL Library
|
||||
|
||||
BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
|
||||
LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv \
|
||||
intl.5:${PORTSDIR}/devel/gettext \
|
||||
ntlm.0:${PORTSDIR}/security/libntlm \
|
||||
gcrypt.6:${PORTSDIR}/security/libgcrypt \
|
||||
idn.12:${PORTSDIR}/devel/libidn
|
||||
|
||||
USE_GNOME= gnomehack gnomeprefix
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= LDFLAGS="-L${LOCALBASE}/lib"
|
||||
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
INFO= gsasl
|
||||
MAN1= gsasl.1
|
||||
|
||||
post-install:
|
||||
@(cd ${WRKSRC}/doc/man ; \
|
||||
${LS} *.3 | ${SED} 's,^,man/man3/,' >> ${TMPPLIST})
|
||||
|
||||
.include <bsd.port.mk>
|
1
security/gsasl/distinfo
Normal file
1
security/gsasl/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (gsasl-0.0.8.tar.gz) = eae923fe86e38e4822f6d9e2459fe7de
|
15
security/gsasl/files/patch-ltmain.sh
Normal file
15
security/gsasl/files/patch-ltmain.sh
Normal file
@ -0,0 +1,15 @@
|
||||
--- ltmain.sh.orig Thu Oct 30 16:27:10 2003
|
||||
+++ ltmain.sh Thu Oct 30 16:27:24 2003
|
||||
@@ -5457,10 +5457,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false ; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
18
security/gsasl/pkg-descr
Normal file
18
security/gsasl/pkg-descr
Normal file
@ -0,0 +1,18 @@
|
||||
GNU SASL is an implementation of the Simple Authentication and Security Layer
|
||||
framework and a few common SASL mechanisms. SASL is used by network servers
|
||||
(e.g., IMAP, SMTP) to request authentication from clients, and in clients to
|
||||
authenticate against servers.
|
||||
|
||||
GNU SASL contains a library (`libgsasl'), a command line utility (`gsasl') to
|
||||
access the library from the shell, and a manual. The library includes support
|
||||
for the SASL framework (with authentication functions and application data
|
||||
privacy and integrity functions) and at least partial support for the CRAM-MD5,
|
||||
EXTERNAL, GSSAPI, ANONYMOUS, PLAIN, SECURID, DIGEST-MD5, LOGIN, NTLM and
|
||||
KERBEROS_V5 mechanisms.
|
||||
|
||||
The library is portable because it does not do network communication by itself,
|
||||
but rather leaves it up to the calling application. The library is flexible
|
||||
with regards to the authorization infrastructure used, as it utilizes callbacks
|
||||
into the application to decide whether an user is authorized or not.
|
||||
|
||||
WWW: http://www.gnu.org/software/gsasl/
|
12
security/gsasl/pkg-plist
Normal file
12
security/gsasl/pkg-plist
Normal file
@ -0,0 +1,12 @@
|
||||
bin/gsasl
|
||||
include/gsasl.h
|
||||
lib/libgsasl.a
|
||||
lib/libgsasl.so
|
||||
lib/libgsasl.so.4
|
||||
libdata/pkgconfig/libgsasl.pc
|
||||
share/locale/sv/LC_MESSAGES/gsasl.mo
|
||||
%%DOCSDIR%%/c4.html
|
||||
%%DOCSDIR%%/gsasl-gsasl.html
|
||||
%%DOCSDIR%%/index.html
|
||||
%%DOCSDIR%%/index.sgml
|
||||
@dirrm %%DOCSDIR%%
|
Loading…
Reference in New Issue
Block a user