devel/elfutils: Fix build after mempcpy(3) and wmempcpy(3) were added
PR: 258092
This commit is contained in:
parent
f2f14190ef
commit
06a7ac65bd
@ -49,6 +49,12 @@ CONFIGURE_ARGS+= --program-prefix=eu-
|
||||
# Disable debuginfod until option support can be added:
|
||||
CONFIGURE_ARGS+= --disable-debuginfod
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1300512 # 2021-07-17
|
||||
CFLAGS+= -DFREEBSD_HAS_MEMPCPY
|
||||
.endif
|
||||
|
||||
pre-configure:
|
||||
@${CP} -a \
|
||||
${LOCALBASE}/share/gnulib/lib/obstack.c \
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- lib/eu-config.h.orig 2020-03-30 12:17:45 UTC
|
||||
+++ lib/eu-config.h
|
||||
@@ -176,6 +176,182 @@ asm (".section predict_data, \"aw\"; .previous\n"
|
||||
@@ -176,6 +176,186 @@ asm (".section predict_data, \"aw\"; .previous\n"
|
||||
#define ELFUTILS_HEADER(name) <lib##name.h>
|
||||
|
||||
|
||||
@ -23,6 +23,9 @@
|
||||
+
|
||||
+#pragma GCC diagnostic push
|
||||
+#pragma GCC diagnostic ignored "-Wshadow"
|
||||
+#ifndef FREEBSD_HAS_MEMPCPY // fix for the build failure, see bug#258092: mempcpy and wmempcpy were added in commits:
|
||||
+// on 14: ee37f64cf875255338f917a9da76c643cf59786c on 2021-07-15
|
||||
+// on 13: dba677d13b26ad5422133b2ab76486b74d63ade4 on 2021-07-22
|
||||
+static inline void *
|
||||
+mempcpy(void * restrict dst, const void * restrict src, size_t len)
|
||||
+{
|
||||
@ -36,6 +39,7 @@
|
||||
+
|
||||
+ return (wmemcpy(dst, src, len) + len);
|
||||
+}
|
||||
+#endif
|
||||
+#pragma GCC diagnostic pop
|
||||
+
|
||||
+static inline void *
|
||||
|
Loading…
Reference in New Issue
Block a user