- Unbreak on 5.3+

This commit is contained in:
Sergey Matveychuk 2004-11-17 09:20:41 +00:00
parent b19d107ab6
commit 06a42a3658
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=121799
2 changed files with 30 additions and 6 deletions

View File

@ -22,7 +22,7 @@ INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
USE_REINPLACE= yes
USE_GMAKE= yes
USE_AUTOCONF_VER= 253
USE_AUTOCONF_VER= 259
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
OPTIONS= SERVICES "Build with all services, not only ORB" on \
@ -61,7 +61,7 @@ CONFIGURE_ARGS+= --disable-coss
MICO_SERVICE= "@comment "
.endif
CONFIGURE_ENV+= CXXFLAGS=${CPPFLAGS}
CONFIGURE_ENV+= CXXFLAGS="${CPPFLAGS} -Wno-unused"
.if defined(WITH_X11)
USE_XLIB= yes
@ -110,10 +110,6 @@ MAN8= ird.8 micod.8 nsd.8
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 502125
BROKEN= Does not build with gcc 3.4
.endif
post-extract:
@${TAR} xzf ${DISTDIR}/doc-html.tar.gz -C ${WRKDIR}

View File

@ -0,0 +1,28 @@
--- include/mico/os-math.h.orig Tue Nov 16 22:31:18 2004
+++ include/mico/os-math.h Tue Nov 16 21:07:40 2004
@@ -291,6 +291,25 @@
#define isnan(x) (fpclassify(x) == FP_NAN)
#endif
#endif
+
+#ifndef asinl
+#define asinl asin
+#endif
+#ifndef ldexpl
+#define ldexpl ldexp
+#endif
+#ifndef frexpl
+#define frexpl frexp
+#endif
+#ifndef fmodl
+#define fmodl fmod
+#endif
+#ifndef ceill
+#define ceill ceil
+#endif
+#ifndef floorl
+#define floorl floor
+#endif
#endif // __FreeBSD__
#include <unistd.h>