o Detect and use memrchr supplied by the distribution

when running system does not have memrchr(3).
 o Pass maintainership to submitter.

Submitted by:	Eric L. Chen <d9364104 mail nchu edu tw>
This commit is contained in:
Xin LI 2008-09-26 02:22:59 +00:00
parent cfd351a4f9
commit 068a8081c5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=220782
2 changed files with 25 additions and 3 deletions

View File

@ -12,10 +12,10 @@ MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DIST_SUBDIR= stardict
MAINTAINER= delphij@FreeBSD.org
MAINTAINER= d9364104@mail.nchu.edu.tw
COMMENT= A cross-platform and international dictionary written in Gtk2
LIB_DEPENDS= sigc-2.0.0:${PORTSDIR}/devel/libsigc++20 \
LIB_DEPENDS= sigc-2.0.0:${PORTSDIR}/devel/libsigc++20 \
enchant.1:${PORTSDIR}/textproc/enchant
GNU_CONFIGURE= yes
@ -31,7 +31,7 @@ USE_GETTEXT= yes
OPTIONS= GNOMEUI "GNOME support" On
CONFLICTS= stardict-2.[0-9]*
CONFLICTS= stardict-2.[0-9]*
.include <bsd.port.pre.mk>
@ -48,6 +48,10 @@ PLIST_SUB= GNOME="@comment not installed: "
MAN1= stardict.1
.if (${OSVERSION} < 700109)
EXTRA_PATCHES+= ${FILESDIR}/src_conf.h
.endif
post-install:
@${CAT} ${PKGMESSAGE}

View File

@ -0,0 +1,18 @@
--- src/conf.h.orig 2008-09-26 09:33:59.000000000 +0800
+++ src/conf.h 2008-09-26 09:34:44.000000000 +0800
@@ -115,7 +115,6 @@
std::auto_ptr<config_file> cf;
cache_t cache;
-#ifdef _WIN32
static void *memrchr(const void *mem, int c, size_t len) {
char *res;
char *cmem = (char *)mem;
@@ -127,7 +126,6 @@
--res;
return res == cmem - 1 ? NULL : res;
}
-#endif
template <typename T>
void set_value(const char *name, const T& val, bool abs = true) {