Update of astro/gpsdrive to latest version (1.33)
PR: 54759 Submitted by: Marco Molteni <molter@tin.it>
This commit is contained in:
parent
35a5b1a216
commit
066a9db902
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=86615
@ -6,8 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= gpsdrive
|
||||
PORTVERSION= 1.31
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.33
|
||||
CATEGORIES= astro
|
||||
MASTER_SITES= http://gpsdrive.kraftvoll.at/ \
|
||||
http://gpsdrive.dotdeguy.de/ \
|
||||
|
@ -1 +1 @@
|
||||
MD5 (gpsdrive-1.31.tar.gz) = d6ae72cb4426068afadce2a5e338502b
|
||||
MD5 (gpsdrive-1.33.tar.gz) = 140ee8a0addf4c71c3a2d80bbe51c1c6
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- configure.orig Sat Dec 7 06:51:08 2002
|
||||
+++ configure Fri Jul 11 15:42:44 2003
|
||||
@@ -12623,8 +12623,6 @@
|
||||
|
||||
|
||||
|
||||
-CFLAGS="-O2 -Wall"
|
||||
-CXXFLAGS="$CFLAGS"
|
||||
|
||||
|
||||
# Check whether --with-pentiumpro or --without-pentiumpro was given.
|
@ -1,7 +1,5 @@
|
||||
$FreeBSD$
|
||||
|
||||
--- ltmain.sh.orig Wed Sep 26 23:26:27 2001
|
||||
+++ ltmain.sh Sat Nov 17 08:35:28 2001
|
||||
--- ltmain.sh.orig Sun Jul 14 20:22:08 2002
|
||||
+++ ltmain.sh Thu Jul 31 17:46:34 2003
|
||||
@@ -1043,7 +1043,7 @@
|
||||
# These systems don't actually have a C library (as such)
|
||||
test "X$arg" = "X-lc" && continue
|
||||
@ -11,7 +9,7 @@ $FreeBSD$
|
||||
# Do not include libc due to us having libc/libc_r.
|
||||
test "X$arg" = "X-lc" && continue
|
||||
;;
|
||||
@@ -2441,7 +2441,7 @@
|
||||
@@ -2445,7 +2445,7 @@
|
||||
*-*-netbsd*)
|
||||
# Don't link with libc until the a.out ld.so is fixed.
|
||||
;;
|
||||
@ -20,7 +18,7 @@ $FreeBSD$
|
||||
# Do not include libc due to us having libc/libc_r.
|
||||
;;
|
||||
*)
|
||||
@@ -4210,10 +4210,12 @@
|
||||
@@ -4225,10 +4225,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- src/Makefile.in.orig Thu Aug 8 23:52:40 2002
|
||||
+++ src/Makefile.in Thu Aug 8 23:54:21 2002
|
||||
@@ -173,7 +173,7 @@
|
||||
|
||||
am_friendsd_OBJECTS = friendsd.$(OBJEXT)
|
||||
friendsd_OBJECTS = $(am_friendsd_OBJECTS)
|
||||
-friendsd_LDADD = $(LDADD)
|
||||
+friendsd_LDADD = $(LDADD) -lintl
|
||||
friendsd_DEPENDENCIES =
|
||||
friendsd_LDFLAGS =
|
||||
@DISABLEGARMIN_TRUE@am_garble_OBJECTS =
|
@ -1,43 +0,0 @@
|
||||
--- src/battery.c.orig Mon Aug 12 14:07:55 2002
|
||||
+++ src/battery.c Mon Aug 12 14:16:49 2002
|
||||
@@ -70,10 +70,11 @@
|
||||
#include <gdk-pixbuf/gdk-pixbuf.h>
|
||||
#include <gtk/gtk.h>
|
||||
|
||||
-#ifdef __FreeBSD__
|
||||
+/* APM is i386-specific. */
|
||||
+#if defined(__FreeBSD__) && defined(__i386__)
|
||||
#include <fcntl.h>
|
||||
#include <machine/apm_bios.h>
|
||||
-#endif /* __FreeBSD__ */
|
||||
+#endif /* __FreeBSD__ && __i386__ */
|
||||
|
||||
#include "../config.h"
|
||||
#include "battery.h"
|
||||
@@ -237,7 +238,7 @@
|
||||
#endif /* Linux */
|
||||
|
||||
|
||||
-#ifdef __FreeBSD__
|
||||
+#if defined(__FreeBSD__) && defined(__i386__)
|
||||
/*
|
||||
* Return TRUE on success, FALSE on error.
|
||||
*/
|
||||
@@ -311,7 +312,7 @@
|
||||
close (fd);
|
||||
return TRUE;
|
||||
}
|
||||
-#endif /* __FreeBSD__ */
|
||||
+#endif /* __FreeBSD__ && __i386__ */
|
||||
|
||||
|
||||
/*
|
||||
@@ -326,7 +327,7 @@
|
||||
}
|
||||
#if defined(__linux__)
|
||||
return battery_get_values_linux (&batlevel, &batloading);
|
||||
-#elif defined(__FreeBSD__)
|
||||
+#elif defined(__FreeBSD__) && defined(__i386__)
|
||||
return battery_get_values_fbsd (&batlevel, &batloading);
|
||||
#else
|
||||
/* add support for your favourite OS here */
|
@ -3,4 +3,3 @@ FreeBSD NOTES:
|
||||
|
||||
Support for Garmin format input is disabled because buggy.
|
||||
Set your GPS device to NMEA mode and start gpsd before gpsdrive.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user