Remove logjam, beside being the last consumer of gtkhtml3 it also
appear to be not working at all and broken on head.
This commit is contained in:
parent
712d7ba9d8
commit
064f3504f7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=549065
1
MOVED
1
MOVED
@ -15622,3 +15622,4 @@ x11-wm/fvwm-crystal||2020-09-19|Has expired: Uses deprecated version of python
|
||||
mail/opensmtpd-extras-queue-python||2020-09-19|Has expired: Uses deprecated version of python
|
||||
mail/opensmtpd-extras-scheduler-python||2020-09-19|Has expired: Uses deprecated version of python
|
||||
lang/python35|lang/python36|2020-09-19|Has expired: Deprecated upstream
|
||||
deskutils/logjam||2020-09-19|Abandonware does not work anymore
|
||||
|
@ -137,7 +137,6 @@
|
||||
SUBDIR += latte-dock
|
||||
SUBDIR += libkdepim
|
||||
SUBDIR += ljclive
|
||||
SUBDIR += logjam
|
||||
SUBDIR += lookbook
|
||||
SUBDIR += lumina-archiver
|
||||
SUBDIR += lumina-calculator
|
||||
|
@ -1,52 +0,0 @@
|
||||
# Created by: alanp@unixpower.org
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= logjam
|
||||
PORTVERSION= 4.6.2
|
||||
PORTREVISION= 6
|
||||
CATEGORIES= deskutils
|
||||
MASTER_SITES= http://andy-shev.github.com/LogJam/download/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= GTK2 interface to livejournals, ie www.livejournal.com
|
||||
|
||||
LIB_DEPENDS= libcurl.so:ftp/curl \
|
||||
libdbus-glib-1.so:devel/dbus-glib
|
||||
|
||||
CFLAGS+= -fcommon
|
||||
|
||||
DEPRECATED= Unmaintained and dead upstream, does not build with -fno-common (llvm 11)
|
||||
EXPIRATION_DATE=2021-04-01
|
||||
|
||||
OPTIONS_DEFINE= GTKSPELL SQLITE GTKHTML RSVG
|
||||
OPTIONS_DEFAULT= GTKSPELL
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
GTKSPELL_DESC= Support spell checking
|
||||
GTKHTML_DESC= Support rendering HTML
|
||||
RSVG_DESC= Support rendering SVG
|
||||
SQLITE_DESC= Use sqlite3 as a backend
|
||||
|
||||
USES= gettext gmake gnome pathfix pkgconfig tar:bzip2
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GNOME= gnomeprefix gtk20 libxml2 intlhack
|
||||
CONFIGURE_ARGS= --program-transform-name="s/$$//"
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LIBS+= -L${LOCALBASE}/lib
|
||||
|
||||
GTKSPELL_LIB_DEPENDS= libgtkspell.so:textproc/gtkspell
|
||||
GTKSPELL_CONFIGURE_WITH= gtkspell
|
||||
|
||||
SQLITE_CONFIGURE_WITH= sqlite3
|
||||
SQLITE_LIB_DEPENDS= libsqlite3.so:databases/sqlite3
|
||||
|
||||
GTKHTML_USE= GNOME=gtkhtml3
|
||||
GTKHTML_CONFIGURE_WITH= gtkhtml
|
||||
|
||||
RSVG_USE= GNOME=librsvg2
|
||||
RSVG_CONFIGURE_WITH= librsvg
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|libgtkhtml-3.0|libgtkhtml-3.18|g' ${WRKSRC}/configure
|
||||
|
||||
.include <bsd.port.mk>
|
@ -1,2 +0,0 @@
|
||||
SHA256 (logjam-4.6.2.tar.bz2) = 6735e98daaa0711f4723865866e89847c9ae2bd20853beebccd8d5056df5ee84
|
||||
SIZE (logjam-4.6.2.tar.bz2) = 789333
|
@ -1,10 +0,0 @@
|
||||
--- src/get_cmd_out.c.orig Sun Jun 5 22:09:21 2005
|
||||
+++ src/get_cmd_out.c Sun Jun 5 22:09:38 2005
|
||||
@@ -11,6 +11,7 @@
|
||||
#include <stdio.h>
|
||||
#include <unistd.h>
|
||||
#include <errno.h>
|
||||
+#include <signal.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/wait.h>
|
||||
#include "util.h"
|
@ -1,10 +0,0 @@
|
||||
--- src/menu.c.orig Mon Oct 24 00:11:08 2005
|
||||
+++ src/menu.c Thu Aug 17 02:01:02 2006
|
||||
@@ -408,7 +408,7 @@
|
||||
0, NULL },
|
||||
{ "/Insert/---", NULL, NULL, 0, "<Separator>" },
|
||||
{ N_("/Insert/_Link..."), "<ctl>L", menu_make_link },
|
||||
-{ N_("/Insert/_Image..."), NULL, menu_insert_image },
|
||||
+{ N_("/Insert/_Image..."), "<ctl><alt>P", menu_insert_image },
|
||||
{ N_("/Insert/_Journal Link..."), "<ctl><alt>L", menu_make_journal_link },
|
||||
{ N_("/Insert/lj-_cut..."), "<ctl><alt>X", menu_ljcut, 0, NULL },
|
@ -1,8 +0,0 @@
|
||||
"LiveJournal.com... because you like to think other people care." LogJam is
|
||||
a GTK2 client for the LiveJournal API. It sits unobtrusively in the corner
|
||||
of your screen, waiting for you to have something worthwhile to tell the
|
||||
world. It can spellcheck with gtkspell and offers preview capabilities
|
||||
using gtkhtml3. It will interface with any site running LiveJournal, not
|
||||
just www.livejournal.com, and can create offline copies of your journal.
|
||||
|
||||
WWW: http://logjam.danga.com/
|
@ -1,13 +0,0 @@
|
||||
bin/logjam
|
||||
man/man1/logjam.1.gz
|
||||
share/applications/logjam.desktop
|
||||
share/pixmaps/logjam_goat.png
|
||||
share/pixmaps/logjam_pencil.png
|
||||
share/locale/de/LC_MESSAGES/logjam.mo
|
||||
share/locale/en_GB/LC_MESSAGES/logjam.mo
|
||||
share/locale/en_US.UTF-8/LC_MESSAGES/logjam.mo
|
||||
share/locale/es/LC_MESSAGES/logjam.mo
|
||||
share/locale/he/LC_MESSAGES/logjam.mo
|
||||
share/locale/ru_RU/LC_MESSAGES/logjam.mo
|
||||
share/locale/uk_UA/LC_MESSAGES/logjam.mo
|
||||
share/locale/ja/LC_MESSAGES/logjam.mo
|
Loading…
Reference in New Issue
Block a user