dns/adns: 1.4 -> 1.5.0~rc0
New features: * Support for queries about IPv6 data in all applicable adns query types (including AAAA, PTR, and adns_r_addr queries). (Thanks very much to Mark Wooding.) * Support for transport over IPv6. (Thanks to Mark Wooding again.) * adns_addr2text and adns_text2addr: Convenient functions for converting between addresses and address literals. Bugfixes: * Fix a crashing bug in adnslogres. (Debian#392102.) * Do all checks of checked PTR owner name before actually sending the query, and reject IPv4 PTR owner names whose labels have leading zero digits or values >255. Build system fixes and improvements: * `make clean' removes the pipes. * Work around bugs in make (Debian #4073, #756123) affecting regress. * Do not include Makefile and src/config.h in distribution tarball. Regression test debugging improvements: * Provide gdbwrap convenience script. * Honour ADNS_TEST_DEBUG env. var. (Mark Wooding.) Submitted by: pi (maintainer)
This commit is contained in:
parent
7d1aef3edc
commit
0632a01008
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=371480
@ -2,14 +2,16 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= adns
|
||||
PORTVERSION= 1.4
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 1.5
|
||||
CATEGORIES= dns
|
||||
MASTER_SITES= http://www.chiark.greenend.org.uk/~ian/adns/ftp/
|
||||
EXTRACT_SUFX= .0~rc0.tar.gz
|
||||
|
||||
MAINTAINER= pi@FreeBSD.org
|
||||
COMMENT= Easy to use asynchronous-capable DNS client library and utilities
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}.0~rc0
|
||||
|
||||
USES= gmake
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LDCONFIG= yes
|
||||
@ -21,11 +23,11 @@ BUILD_DEPENDS+= gm4:${PORTSDIR}/devel/m4
|
||||
CFLAGS+= -Ds6_addr16=__u6_addr.__u6_addr16
|
||||
CFLAGS+= -Ds6_addr32=__u6_addr.__u6_addr32
|
||||
MAKE_FLAGS+= M4=gm4
|
||||
PATCH_SITES+= https://people.debian.org/~lucab/deb/adns/:ipv6patch
|
||||
PATCHFILES+= adns-ipv6.patch:ipv6patch
|
||||
PATCH_DIST_STRIP+= -p1
|
||||
#PATCH_SITES+= https://people.debian.org/~lucab/deb/adns/:ipv6patch
|
||||
#PATCHFILES+= adns-ipv6.patch:ipv6patch
|
||||
#PATCH_DIST_STRIP+= -p1
|
||||
|
||||
DOCS= COPYING GPL-vs-LGPL INSTALL LICENCE.WAIVERS README \
|
||||
DOCS= COPYING GPL-vs-LGPL INSTALL README \
|
||||
README.html TODO changelog
|
||||
|
||||
TOSTRIP= bin/adnsheloex \
|
||||
|
@ -1,4 +1,4 @@
|
||||
SHA256 (adns-1.4.tar.gz) = 717b92a39117a5d8b04ea7c652c630659c6eecb35211129a8cee95e6524ca9fe
|
||||
SIZE (adns-1.4.tar.gz) = 252668
|
||||
SHA256 (adns-1.5.0~rc0.tar.gz) = ae9459c778d21b6cdb8cd98731ff103c264b47df4bd44e38573a697cb0893b4a
|
||||
SIZE (adns-1.5.0~rc0.tar.gz) = 345530
|
||||
SHA256 (adns-ipv6.patch) = 84adcc350ee9a3144e0b48fb12ad8f7e8f028a5316b7948e698acaf57afae2e4
|
||||
SIZE (adns-ipv6.patch) = 88709
|
||||
|
11
dns/adns/files/patch-regress-Makefile.in
Normal file
11
dns/adns/files/patch-regress-Makefile.in
Normal file
@ -0,0 +1,11 @@
|
||||
--- regress/Makefile.in.orig 2014-10-25 13:43:05.000000000 +0200
|
||||
+++ regress/Makefile.in 2014-10-25 13:43:08.000000000 +0200
|
||||
@@ -25,7 +25,7 @@
|
||||
|
||||
PROGS_SYSDEP= @PROGS_HAVE_TSEARCH@
|
||||
|
||||
-CLIENTS= adnstest adnshost adnslogres $(PROGS_SYSDEP)
|
||||
+CLIENTS= adnstest adnslogres $(PROGS_SYSDEP)
|
||||
AUTOCHDRS= harness.h hsyscalls.h hredirect.h
|
||||
AUTOCSRCS= hrecord.c hplayback.c hcommon.c
|
||||
include ../settings.make
|
@ -9,9 +9,7 @@ lib/libadns.so.%%LIBVERSION%%
|
||||
%%PORTDOCS%%%%DOCSDIR%%/COPYING
|
||||
%%PORTDOCS%%%%DOCSDIR%%/GPL-vs-LGPL
|
||||
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
|
||||
%%PORTDOCS%%%%DOCSDIR%%/LICENCE.WAIVERS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/TODO
|
||||
%%PORTDOCS%%%%DOCSDIR%%/changelog
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
|
Loading…
Reference in New Issue
Block a user