- Split into client and server ports: upstream now provides separate
distfiles and also this allows to simplify configure and build glue in the Makefiles considerably - Update to version 3.2.1, reword both COMMENTs accordingly - Actualize MASTER_SITES and WWW line in the port description - Unbreak the build against contemporary versions of OpenSSL - Define LICENSE (GPLv2+) and install provided documentation files
This commit is contained in:
parent
074461fc44
commit
06105161eb
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=563282
1
MOVED
1
MOVED
@ -16028,3 +16028,4 @@ security/py-rekall|security/py-volatility3|2021-01-28|Has expired: Unmaintained
|
||||
security/py-rekall-core||2021-01-28|Has expired: Unmaintained upstream
|
||||
www/kurly||2021-01-28|Has expired: Upstream is gone
|
||||
security/regripper||2021-01-28|Has expired: Upstream repo disappeared
|
||||
ftp/bbftp||2021-01-30|Was split into client and server ports, install as needed
|
||||
|
@ -6,7 +6,8 @@
|
||||
SUBDIR += R-cran-RCurl
|
||||
SUBDIR += R-cran-curl
|
||||
SUBDIR += axel
|
||||
SUBDIR += bbftp
|
||||
SUBDIR += bbftp-client
|
||||
SUBDIR += bbftp-server
|
||||
SUBDIR += bftpd
|
||||
SUBDIR += bsdftpd-ssl
|
||||
SUBDIR += cmdftp
|
||||
|
36
ftp/bbftp-client/Makefile
Normal file
36
ftp/bbftp-client/Makefile
Normal file
@ -0,0 +1,36 @@
|
||||
# Created by: Petr Holub <hopet@ics.muni.cz>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= bbftp-client
|
||||
PORTVERSION= 3.2.1
|
||||
CATEGORIES= ftp
|
||||
MASTER_SITES= http://software.in2p3.fr/bbftp/dist/ \
|
||||
ftp://ftp.in2p3.fr/pub/bbftp/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Secure file transfer suite optimized for large files (client)
|
||||
|
||||
LICENSE= GPLv2+
|
||||
|
||||
USES= gmake ssl
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-ssl=${OPENSSLBASE}
|
||||
WRKSRC_SUBDIR= bbftpc
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e '/with_ssl\/lib\/libcrypto/s,\.a,.so,' \
|
||||
${WRKSRC}/${CONFIGURE_SCRIPT}
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/bbftp ${STAGEDIR}${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/../doc/bbftp.1 \
|
||||
${STAGEDIR}${MANPREFIX}/man/man1
|
||||
|
||||
do-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/../doc/ports ${WRKSRC}/../ChangeLog \
|
||||
${WRKSRC}/../README ${WRKSRC}/../TODO ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
.include <bsd.port.mk>
|
3
ftp/bbftp-client/distinfo
Normal file
3
ftp/bbftp-client/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1505814511
|
||||
SHA256 (bbftp-client-3.2.1.tar.gz) = 4000009804d90926ad3c0e770099874084fb49013e8b0770b82678462304456d
|
||||
SIZE (bbftp-client-3.2.1.tar.gz) = 245320
|
55
ftp/bbftp-client/files/patch-connecttoserver.c
Normal file
55
ftp/bbftp-client/files/patch-connecttoserver.c
Normal file
@ -0,0 +1,55 @@
|
||||
--- connecttoserver.c.orig 2013-02-07 10:42:46 UTC
|
||||
+++ connecttoserver.c
|
||||
@@ -517,6 +517,7 @@ int connectviapassword()
|
||||
#ifdef WITH_SSL
|
||||
RSA *hisrsa ;
|
||||
int lenrsa ;
|
||||
+ BIGNUM *n, *e;
|
||||
#endif
|
||||
/*
|
||||
** Get the socket
|
||||
@@ -629,33 +630,35 @@ int connectviapassword()
|
||||
/*
|
||||
** Getting BIGNUM structures to store the key and exponent
|
||||
*/
|
||||
- if ( (hisrsa->n = BN_new()) == NULL) {
|
||||
+ n = BN_new();
|
||||
+ e = BN_new();
|
||||
+ if (n == NULL || e == NULL) {
|
||||
free(readbuffer) ;
|
||||
close(tmpctrlsock) ;
|
||||
printmessage(stderr,CASE_ERROR,56,timestamp,"Error reading encrypted message : %s (%s)\n","getting BIGNUM",(char *) ERR_error_string(ERR_get_error(),NULL)) ;
|
||||
return -1 ;
|
||||
}
|
||||
- if ( (hisrsa->e = BN_new()) == NULL) {
|
||||
- free(readbuffer) ;
|
||||
- close(tmpctrlsock) ;
|
||||
- printmessage(stderr,CASE_ERROR,56,timestamp,"Error reading encrypted message : %s (%s)\n","getting BIGNUM",(char *) ERR_error_string(ERR_get_error(),NULL)) ;
|
||||
- return -1 ;
|
||||
- }
|
||||
/*
|
||||
** Copy the key and exponent received
|
||||
*/
|
||||
- if ( BN_mpi2bn(pubkey,lenkey,hisrsa->n) == NULL ) {
|
||||
+ if ( BN_mpi2bn(pubkey,lenkey,n) == NULL ) {
|
||||
free(readbuffer) ;
|
||||
close(tmpctrlsock) ;
|
||||
printmessage(stderr,CASE_ERROR,56,timestamp,"Error reading encrypted message : %s (%s)\n","copying pubkey",(char *) ERR_error_string(ERR_get_error(),NULL)) ;
|
||||
return -1 ;
|
||||
}
|
||||
- if ( BN_mpi2bn(pubexponent,lenexpo,hisrsa->e) == NULL ) {
|
||||
+ if ( BN_mpi2bn(pubexponent,lenexpo,e) == NULL ) {
|
||||
free(readbuffer) ;
|
||||
close(tmpctrlsock) ;
|
||||
printmessage(stderr,CASE_ERROR,56,timestamp,"Error reading encrypted message : %s (%s)\n","copying pubexponent",(char *) ERR_error_string(ERR_get_error(),NULL)) ;
|
||||
return -1 ;
|
||||
}
|
||||
+#if OPENSSL_VERSION_NUMBER < 0x10100000L
|
||||
+ hisrsa->n = n;
|
||||
+ hisrsa->e = e;
|
||||
+#else
|
||||
+ RSA_set0_key(hisrsa, n, e, NULL);
|
||||
+#endif
|
||||
lenrsa = RSA_size(hisrsa) ;
|
||||
|
||||
if (strlen(username) > lenrsa - 41 ) {
|
11
ftp/bbftp-client/files/patch-setsignals.c
Normal file
11
ftp/bbftp-client/files/patch-setsignals.c
Normal file
@ -0,0 +1,11 @@
|
||||
--- setsignals.c.orig 2005-03-29 12:48:21 UTC
|
||||
+++ setsignals.c
|
||||
@@ -134,7 +134,7 @@ void blockallsignals()
|
||||
if ( sigaction(SIGTSTP,&sga,0) < 0 ) {
|
||||
printmessage(stderr,CASE_FATAL_ERROR,32,timestamp,"Error setting signal SIGTSTP : %s \n",strerror(errno)) ;
|
||||
}
|
||||
-#ifndef DARWIN
|
||||
+#ifdef SIGPOLL
|
||||
if ( sigaction(SIGPOLL,&sga,0) < 0 ) {
|
||||
printmessage(stderr,CASE_FATAL_ERROR,32,timestamp,"Error setting signal SIGPOLL : %s \n",strerror(errno)) ;
|
||||
}
|
@ -17,4 +17,4 @@ main features are:
|
||||
bbFTP is open-source software, released under the GNU General Public License.
|
||||
It was written by Gilles Farrache at IN2P3 Computing Center in Lyon, France.
|
||||
|
||||
WWW: http://doc.in2p3.fr/bbftp/index.html
|
||||
WWW: http://software.in2p3.fr/bbftp/
|
6
ftp/bbftp-client/pkg-plist
Normal file
6
ftp/bbftp-client/pkg-plist
Normal file
@ -0,0 +1,6 @@
|
||||
bin/bbftp
|
||||
man/man1/bbftp.1.gz
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%%%DOCSDIR%%/TODO
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ports
|
38
ftp/bbftp-server/Makefile
Normal file
38
ftp/bbftp-server/Makefile
Normal file
@ -0,0 +1,38 @@
|
||||
# Created by: Petr Holub <hopet@ics.muni.cz>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= bbftp-server
|
||||
PORTVERSION= 3.2.1
|
||||
CATEGORIES= ftp
|
||||
MASTER_SITES= http://software.in2p3.fr/bbftp/dist/ \
|
||||
ftp://ftp.in2p3.fr/pub/bbftp/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Secure file transfer suite optimized for large files (server)
|
||||
|
||||
LICENSE= GPLv2+
|
||||
|
||||
USES= gmake ssl
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-ssl=${OPENSSLBASE}
|
||||
WRKSRC_SUBDIR= bbftpd
|
||||
USE_RC_SUBR= bbftpd
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e '/^#include/s,malloc,stdlib,' \
|
||||
${WRKSRC}/bbftpd_cd.c ${WRKSRC}/bbftpd_statfs.c
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/bbftpd ${STAGEDIR}${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/../doc/bbftpd.1 \
|
||||
${STAGEDIR}${MANPREFIX}/man/man1
|
||||
|
||||
do-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/../doc/ports ${WRKSRC}/../doc/stats \
|
||||
${WRKSRC}/../ChangeLog ${WRKSRC}/../README \
|
||||
${WRKSRC}/../TODO ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
.include <bsd.port.mk>
|
3
ftp/bbftp-server/distinfo
Normal file
3
ftp/bbftp-server/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1505814511
|
||||
SHA256 (bbftp-server-3.2.1.tar.gz) = 818e2de73fbda68b854e0253d13e95f9aae2abe0efb3b4077667a66fe76a5201
|
||||
SIZE (bbftp-server-3.2.1.tar.gz) = 234731
|
15
ftp/bbftp-server/files/patch-bbftpd.c
Normal file
15
ftp/bbftp-server/files/patch-bbftpd.c
Normal file
@ -0,0 +1,15 @@
|
||||
--- bbftpd.c.orig 2005-05-03 08:43:34 UTC
|
||||
+++ bbftpd.c
|
||||
@@ -842,10 +842,12 @@ main (argc,argv,envp)
|
||||
char buffrand[NBITSINKEY] ;
|
||||
struct timeval tp ;
|
||||
unsigned int seed ;
|
||||
+#if OPENSSL_VERSION_NUMBER < 0x10100000L
|
||||
/*
|
||||
** Load the error message from the crypto lib
|
||||
*/
|
||||
ERR_load_crypto_strings() ;
|
||||
+#endif
|
||||
/*
|
||||
** Initialize the buffrand buffer which is giong to be used to initialize the
|
||||
** random generator
|
16
ftp/bbftp-server/files/patch-bbftpd__crypt.c
Normal file
16
ftp/bbftp-server/files/patch-bbftpd__crypt.c
Normal file
@ -0,0 +1,16 @@
|
||||
--- bbftpd_crypt.c.orig 2004-06-30 17:38:50 UTC
|
||||
+++ bbftpd_crypt.c
|
||||
@@ -84,8 +84,13 @@ void sendcrypt()
|
||||
/*
|
||||
** Now extract the public key in order to send it
|
||||
*/
|
||||
+#if OPENSSL_VERSION_NUMBER < 0x10100000L
|
||||
lenkey = BN_bn2mpi(myrsa->n,pubkey) ;
|
||||
lenexpo = BN_bn2mpi(myrsa->e,pubexponent) ;
|
||||
+#else
|
||||
+ lenkey = BN_bn2mpi(RSA_get0_n(myrsa),pubkey) ;
|
||||
+ lenexpo = BN_bn2mpi(RSA_get0_e(myrsa),pubexponent) ;
|
||||
+#endif
|
||||
mess = (struct message *) buf ;
|
||||
mess->code = MSG_CRYPT ;
|
||||
#ifndef WORDS_BIGENDIAN
|
11
ftp/bbftp-server/files/patch-bbftpd__signals.c
Normal file
11
ftp/bbftp-server/files/patch-bbftpd__signals.c
Normal file
@ -0,0 +1,11 @@
|
||||
--- bbftpd_signals.c.orig 2013-02-07 10:46:27 UTC
|
||||
+++ bbftpd_signals.c
|
||||
@@ -376,7 +376,7 @@ int bbftpd_blockallsignals() {
|
||||
syslog(BBFTPD_ERR,"Error sigaction SIGTSTP : %s",strerror(errno)) ;
|
||||
return(-1) ;
|
||||
}
|
||||
-#ifndef DARWIN
|
||||
+#ifdef SIGPOLL
|
||||
if ( sigaction(SIGPOLL,&sga,0) < 0 ) {
|
||||
syslog(BBFTPD_ERR,"Error sigaction SIGPOLL : %s",strerror(errno)) ;
|
||||
return(-1) ;
|
20
ftp/bbftp-server/pkg-descr
Normal file
20
ftp/bbftp-server/pkg-descr
Normal file
@ -0,0 +1,20 @@
|
||||
bbFTP is a file transfer software. It implements its own transfer protocol,
|
||||
which is optimized for large files (larger than 2GB) and secure as it does not
|
||||
read the password in a file and encrypts the connection information. bbFTP
|
||||
main features are:
|
||||
|
||||
* Encoded username and password at connection
|
||||
* SSH and Certificate authentication modules
|
||||
* Multi-stream transfer
|
||||
* Big windows as defined in RFC1323
|
||||
* On-the-fly data compression
|
||||
* Automatic retry
|
||||
* Customizable time-outs
|
||||
* Transfer simulation
|
||||
* AFS authentication integration
|
||||
* RFIO interface
|
||||
|
||||
bbFTP is open-source software, released under the GNU General Public License.
|
||||
It was written by Gilles Farrache at IN2P3 Computing Center in Lyon, France.
|
||||
|
||||
WWW: http://software.in2p3.fr/bbftp/
|
7
ftp/bbftp-server/pkg-plist
Normal file
7
ftp/bbftp-server/pkg-plist
Normal file
@ -0,0 +1,7 @@
|
||||
bin/bbftpd
|
||||
man/man1/bbftpd.1.gz
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%%%DOCSDIR%%/TODO
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ports
|
||||
%%PORTDOCS%%%%DOCSDIR%%/stats
|
@ -1,46 +0,0 @@
|
||||
# Created by: Petr Holub <hopet@ics.muni.cz>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= bbftp
|
||||
PORTVERSION= 3.0.2
|
||||
CATEGORIES= ftp
|
||||
MASTER_SITES= http://doc.in2p3.fr/bbftp/dist/ \
|
||||
http://ftp.riken.go.jp/pub/net/bbftp/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Multiple stream file transfer protocol optimized for large files
|
||||
|
||||
USES= gmake ssl:build
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
EXTRA_PATCHES= ${FILESDIR}/bbftp.patch
|
||||
|
||||
USE_RC_SUBR= bbftpd
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${SSL_DEFAULT} == base
|
||||
BROKEN_FreeBSD_12= error: incomplete definition of type 'struct rsa_st'
|
||||
BROKEN_FreeBSD_13= error: incomplete definition of type 'struct rsa_st'
|
||||
BROKEN_FreeBSD_14= error: incomplete definition of type 'struct rsa_st'
|
||||
.endif
|
||||
|
||||
do-configure:
|
||||
${CP} -f ${TEMPLATES}/config.guess ${WRKSRC}
|
||||
${CP} -f ${TEMPLATES}/config.sub ${WRKSRC}
|
||||
(cd ${WRKSRC}/bbftpc && ./configure --prefix=${PREFIX} \
|
||||
${CONFIGURE_ARGS} --with-ssl=${OPENSSLBASE})
|
||||
(cd ${WRKSRC}/bbftpd && ./configure --prefix=${PREFIX} \
|
||||
${CONFIGURE_ARGS} --with-ssl=${OPENSSLBASE})
|
||||
|
||||
do-build:
|
||||
(cd ${WRKSRC}/bbftpc && ${SETENV} ${MAKE_ENV} ${MAKE_CMD})
|
||||
(cd ${WRKSRC}/bbftpd && ${SETENV} ${MAKE_ENV} ${MAKE_CMD})
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/bbftpc/bbftp ${STAGEDIR}${PREFIX}/bin
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/bbftpd/bbftpd ${STAGEDIR}${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/bbftp.1 ${STAGEDIR}${PREFIX}/man/man1
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/bbftpd.1 ${STAGEDIR}${PREFIX}/man/man1
|
||||
|
||||
.include <bsd.port.post.mk>
|
@ -1,2 +0,0 @@
|
||||
SHA256 (bbftp-3.0.2.tar.gz) = 539ef20f90778783890f81cf6b4cd434bb6c47c392ec824caf92f6ca1005cc72
|
||||
SIZE (bbftp-3.0.2.tar.gz) = 344495
|
@ -1,145 +0,0 @@
|
||||
diff -ru bbftpc/bbftp_socket.c bbftp/bbftpc/bbftp_socket.c
|
||||
--- bbftpc/bbftp_socket.c Wed May 7 14:59:17 2003
|
||||
+++ bbftpc/bbftp_socket.c Tue Jun 6 23:53:25 2006
|
||||
@@ -28,10 +28,10 @@
|
||||
#include <errno.h>
|
||||
#include <fcntl.h>
|
||||
#include <netinet/in.h>
|
||||
+#include <sys/types.h>
|
||||
#include <netinet/tcp.h>
|
||||
#include <syslog.h>
|
||||
#include <sys/socket.h>
|
||||
-#include <sys/types.h>
|
||||
#include <unistd.h>
|
||||
#include <utime.h>
|
||||
|
||||
diff -ru bbftpc/bbftp_utils.c bbftp/bbftpc/bbftp_utils.c
|
||||
--- bbftpc/bbftp_utils.c Mon Jun 30 14:41:40 2003
|
||||
+++ bbftpc/bbftp_utils.c Tue Jun 6 23:55:14 2006
|
||||
@@ -44,6 +44,7 @@
|
||||
#ifdef HAVE_BYTESWAP_H
|
||||
#include <byteswap.h>
|
||||
#endif
|
||||
+#include <sys/time.h>
|
||||
|
||||
extern int incontrolsock ;
|
||||
extern int outcontrolsock ;
|
||||
diff -ru bbftpc/setsignals.c bbftp/bbftpc/setsignals.c
|
||||
--- bbftpc/setsignals.c Wed Apr 17 10:44:24 2002
|
||||
+++ bbftpc/setsignals.c Tue Jun 6 23:55:59 2006
|
||||
@@ -129,9 +129,6 @@
|
||||
if ( sigaction(SIGTSTP,&sga,0) < 0 ) {
|
||||
printmessage(stderr,CASE_FATAL_ERROR,32,timestamp,"Error setting signal SIGTSTP : %s \n",strerror(errno)) ;
|
||||
}
|
||||
- if ( sigaction(SIGPOLL,&sga,0) < 0 ) {
|
||||
- printmessage(stderr,CASE_FATAL_ERROR,32,timestamp,"Error setting signal SIGPOLL : %s \n",strerror(errno)) ;
|
||||
- }
|
||||
if ( sigaction(SIGPROF,&sga,0) < 0 ) {
|
||||
printmessage(stderr,CASE_FATAL_ERROR,32,timestamp,"Error setting signal SIGPROF : %s \n",strerror(errno)) ;
|
||||
}
|
||||
diff -ru bbftpd/bbftpd.c bbftp/bbftpd/bbftpd.c
|
||||
--- bbftpd/bbftpd.c Thu Jul 24 15:27:55 2003
|
||||
+++ bbftpd/bbftpd.c Tue Jun 6 23:56:46 2006
|
||||
@@ -61,6 +61,7 @@
|
||||
#include <limits.h>
|
||||
#include <netdb.h>
|
||||
#include <netinet/in.h>
|
||||
+#include <sys/types.h>
|
||||
#include <netinet/tcp.h>
|
||||
#include <pwd.h>
|
||||
#include <signal.h>
|
||||
diff -ru bbftpd/bbftpd_daemon.c bbftp/bbftpd/bbftpd_daemon.c
|
||||
--- bbftpd/bbftpd_daemon.c Wed Jun 11 17:17:51 2003
|
||||
+++ bbftpd/bbftpd_daemon.c Tue Jun 6 23:57:11 2006
|
||||
@@ -43,6 +43,7 @@
|
||||
*****************************************************************************/
|
||||
#include <netdb.h>
|
||||
#include <netinet/in.h>
|
||||
+#include <sys/types.h>
|
||||
#include <netinet/tcp.h>
|
||||
#include <stdio.h>
|
||||
#include <syslog.h>
|
||||
diff -ru bbftpd/bbftpd_login.c bbftp/bbftpd/bbftpd_login.c
|
||||
--- bbftpd/bbftpd_login.c Mon Feb 24 10:26:59 2003
|
||||
+++ bbftpd/bbftpd_login.c Tue Jun 6 23:59:34 2006
|
||||
@@ -47,7 +47,6 @@
|
||||
|
||||
*****************************************************************************/
|
||||
|
||||
-#include <crypt.h>
|
||||
#include <errno.h>
|
||||
#include <netinet/in.h>
|
||||
#include <pwd.h>
|
||||
@@ -287,6 +286,7 @@
|
||||
PAM_BAIL;
|
||||
retcode = pam_acct_mgmt(pamh, 0);
|
||||
PAM_BAIL;
|
||||
+#define PAM_ESTABLISH_CRED 1
|
||||
#ifdef PAM_ESTABLISH_CRED
|
||||
retcode = pam_setcred(pamh, PAM_ESTABLISH_CRED);
|
||||
#else
|
||||
diff -ru bbftpd/bbftpd_signals.c bbftp/bbftpd/bbftpd_signals.c
|
||||
--- bbftpd/bbftpd_signals.c Tue Mar 11 13:34:36 2003
|
||||
+++ bbftpd/bbftpd_signals.c Wed Jun 7 00:00:47 2006
|
||||
@@ -268,7 +268,7 @@
|
||||
*/
|
||||
if ( unlinkfile == 1 ) unlink(realfilename) ;
|
||||
clean_child() ;
|
||||
- exit() ;
|
||||
+ exit(0) ;
|
||||
} else {
|
||||
exit(EINTR) ;
|
||||
}
|
||||
@@ -358,10 +358,6 @@
|
||||
}
|
||||
if ( sigaction(SIGTSTP,&sga,0) < 0 ) {
|
||||
syslog(BBFTPD_ERR,"Error sigaction SIGTSTP : %s",strerror(errno)) ;
|
||||
- return(-1) ;
|
||||
- }
|
||||
- if ( sigaction(SIGPOLL,&sga,0) < 0 ) {
|
||||
- syslog(BBFTPD_ERR,"Error sigaction SIGPOLL : %s",strerror(errno)) ;
|
||||
return(-1) ;
|
||||
}
|
||||
if ( sigaction(SIGPROF,&sga,0) < 0 ) {
|
||||
diff -ru bbftpd/bbftpd_socket.c bbftp/bbftpd/bbftpd_socket.c
|
||||
--- bbftpd/bbftpd_socket.c Wed Mar 5 12:23:37 2003
|
||||
+++ bbftpd/bbftpd_socket.c Wed Jun 7 00:01:04 2006
|
||||
@@ -30,10 +30,10 @@
|
||||
#include <errno.h>
|
||||
#include <fcntl.h>
|
||||
#include <netinet/in.h>
|
||||
+#include <sys/types.h>
|
||||
#include <netinet/tcp.h>
|
||||
#include <syslog.h>
|
||||
#include <sys/socket.h>
|
||||
-#include <sys/types.h>
|
||||
#include <unistd.h>
|
||||
#include <utime.h>
|
||||
|
||||
diff -ru bbftpd/createreceivesock.c bbftp/bbftpd/createreceivesock.c
|
||||
--- bbftpd/createreceivesock.c Wed Apr 17 10:45:10 2002
|
||||
+++ bbftpd/createreceivesock.c Wed Jun 7 00:01:20 2006
|
||||
@@ -52,10 +52,10 @@
|
||||
#include <errno.h>
|
||||
#include <fcntl.h>
|
||||
#include <netinet/in.h>
|
||||
+#include <sys/types.h>
|
||||
#include <netinet/tcp.h>
|
||||
#include <syslog.h>
|
||||
#include <sys/socket.h>
|
||||
-#include <sys/types.h>
|
||||
#include <unistd.h>
|
||||
|
||||
#include <common.h>
|
||||
diff -ru bbftpd/signals_routines.c bbftp/bbftpd/signals_routines.c
|
||||
--- bbftpd/signals_routines.c Wed Apr 17 10:45:10 2002
|
||||
+++ bbftpd/signals_routines.c Wed Jun 7 00:01:40 2006
|
||||
@@ -192,7 +192,7 @@
|
||||
*/
|
||||
if ( unlinkfile == 1 ) unlink(currentfilename) ;
|
||||
clean_child() ;
|
||||
- exit() ;
|
||||
+ exit(0) ;
|
||||
} else {
|
||||
exit(EINTR) ;
|
||||
}
|
@ -1,4 +0,0 @@
|
||||
bin/bbftp
|
||||
bin/bbftpd
|
||||
man/man1/bbftp.1.gz
|
||||
man/man1/bbftpd.1.gz
|
Loading…
Reference in New Issue
Block a user