- Fix compatibility with c++11
While here: - Add LICENSE - Strip binaries - Regenerate patches - Sort plist PR: 199998 Submitted by: 6yearold@gmail.com Approved by: maintainer timeout (vsevolod, 7 weeks)
This commit is contained in:
parent
59b52f73ef
commit
060bc1595b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=390672
@ -3,14 +3,22 @@
|
||||
|
||||
PORTNAME= minisat
|
||||
PORTVERSION= 2.2.1
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= math devel
|
||||
MASTER_SITES= http://highsecure.ru/distfiles/
|
||||
|
||||
MAINTAINER= vsevolod@FreeBSD.org
|
||||
COMMENT= Minimalistic, open-source SAT solver
|
||||
|
||||
USES= gmake
|
||||
LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
USES= gmake
|
||||
USE_LDCONFIG= yes
|
||||
MAKE_ENV= prefix=${PREFIX} CFLAGS="-std=c++03"
|
||||
|
||||
post-install:
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME} \
|
||||
${STAGEDIR}${PREFIX}/lib/libminisat.so
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- minisat/core/SolverTypes.h.orig 2014-03-31 11:50:09.479636337 +0100
|
||||
+++ minisat/core/SolverTypes.h 2014-03-31 11:50:32.079953517 +0100
|
||||
@@ -52,7 +52,7 @@
|
||||
--- minisat/core/SolverTypes.h.orig 2012-11-19 13:50:09 UTC
|
||||
+++ minisat/core/SolverTypes.h
|
||||
@@ -52,7 +52,7 @@ struct Lit {
|
||||
int x;
|
||||
|
||||
// Use this as a constructor:
|
||||
@ -9,7 +9,7 @@
|
||||
|
||||
bool operator == (Lit p) const { return x == p.x; }
|
||||
bool operator != (Lit p) const { return x != p.x; }
|
||||
@@ -60,7 +60,7 @@
|
||||
@@ -60,7 +60,7 @@ struct Lit {
|
||||
};
|
||||
|
||||
|
21
math/minisat/files/patch-minisat_utils_Options.h
Normal file
21
math/minisat/files/patch-minisat_utils_Options.h
Normal file
@ -0,0 +1,21 @@
|
||||
--- minisat/utils/Options.h.orig 2012-11-19 13:50:09 UTC
|
||||
+++ minisat/utils/Options.h
|
||||
@@ -282,15 +282,15 @@ class Int64Option : public Option
|
||||
if (range.begin == INT64_MIN)
|
||||
fprintf(stderr, "imin");
|
||||
else
|
||||
- fprintf(stderr, "%4"PRIi64, range.begin);
|
||||
+ fprintf(stderr, "%4" PRIi64, range.begin);
|
||||
|
||||
fprintf(stderr, " .. ");
|
||||
if (range.end == INT64_MAX)
|
||||
fprintf(stderr, "imax");
|
||||
else
|
||||
- fprintf(stderr, "%4"PRIi64, range.end);
|
||||
+ fprintf(stderr, "%4" PRIi64, range.end);
|
||||
|
||||
- fprintf(stderr, "] (default: %"PRIi64")\n", value);
|
||||
+ fprintf(stderr, "] (default: %" PRIi64")\n", value);
|
||||
if (verbose){
|
||||
fprintf(stderr, "\n %s\n", description);
|
||||
fprintf(stderr, "\n");
|
@ -1,24 +1,23 @@
|
||||
|
||||
bin/minisat
|
||||
include/minisat/mtl/XAlloc.h
|
||||
include/minisat/mtl/Heap.h
|
||||
include/minisat/mtl/IntTypes.h
|
||||
include/minisat/mtl/IntMap.h
|
||||
include/minisat/mtl/Sort.h
|
||||
include/minisat/mtl/Rnd.h
|
||||
include/minisat/core/Dimacs.h
|
||||
include/minisat/core/Solver.h
|
||||
include/minisat/core/SolverTypes.h
|
||||
include/minisat/mtl/Alg.h
|
||||
include/minisat/mtl/Vec.h
|
||||
include/minisat/mtl/Alloc.h
|
||||
include/minisat/mtl/Heap.h
|
||||
include/minisat/mtl/IntMap.h
|
||||
include/minisat/mtl/IntTypes.h
|
||||
include/minisat/mtl/Map.h
|
||||
include/minisat/mtl/Queue.h
|
||||
include/minisat/mtl/Rnd.h
|
||||
include/minisat/mtl/Sort.h
|
||||
include/minisat/mtl/Vec.h
|
||||
include/minisat/mtl/XAlloc.h
|
||||
include/minisat/simp/SimpSolver.h
|
||||
include/minisat/utils/Options.h
|
||||
include/minisat/utils/ParseUtils.h
|
||||
include/minisat/utils/System.h
|
||||
include/minisat/core/Solver.h
|
||||
include/minisat/core/Dimacs.h
|
||||
include/minisat/core/SolverTypes.h
|
||||
include/minisat/simp/SimpSolver.h
|
||||
lib/libminisat.so.2.1.0
|
||||
lib/libminisat.so.2
|
||||
lib/libminisat.so
|
||||
lib/libminisat.a
|
||||
lib/libminisat.so
|
||||
lib/libminisat.so.2
|
||||
lib/libminisat.so.2.1.0
|
||||
|
Loading…
Reference in New Issue
Block a user