Update to 1.42.
This commit is contained in:
parent
15d82c528c
commit
05e2de6ae7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=224871
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= transmission
|
||||
PORTVERSION= 1.40
|
||||
PORTVERSION= 1.42
|
||||
PORTREVISION?= 0
|
||||
CATEGORIES?= net-p2p
|
||||
MASTER_SITES= http://download.m0k.org/${PORTNAME}/files/
|
||||
|
@ -1,3 +1,3 @@
|
||||
MD5 (transmission-1.40.tar.bz2) = 490d13c141ba7b4a96582541ea83a461
|
||||
SHA256 (transmission-1.40.tar.bz2) = 944ab9cfcfc9a4bd7efeecf32ea609fa6517970a9708c44eee6d5750c4ff8e0c
|
||||
SIZE (transmission-1.40.tar.bz2) = 4604462
|
||||
MD5 (transmission-1.42.tar.bz2) = c083bdcb01426466e80ee339bccd9351
|
||||
SHA256 (transmission-1.42.tar.bz2) = e7e17f29a166794017c6d94362159337f14008c414d1f8da5f7c2c1c05c7d543
|
||||
SIZE (transmission-1.42.tar.bz2) = 4630409
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- configure.ac.orig 2008-11-08 14:39:19.000000000 -0600
|
||||
+++ configure.ac 2008-11-08 14:43:25.000000000 -0600
|
||||
--- configure.ac.orig 2008-12-26 12:01:10.000000000 -0600
|
||||
+++ configure.ac 2008-12-26 12:05:35.000000000 -0600
|
||||
@@ -23,28 +23,14 @@
|
||||
fi
|
||||
AM_CONDITIONAL(TR_UNSTABLE, test "x$TR_UNSTABLE" = "xyes")
|
||||
@ -31,7 +31,7 @@
|
||||
fi
|
||||
|
||||
AC_HEADER_STDC
|
||||
@@ -56,7 +42,7 @@
|
||||
@@ -63,7 +49,7 @@
|
||||
|
||||
AC_SEARCH_LIBS([socket], [socket net])
|
||||
AC_SEARCH_LIBS([gethostbyname], [nsl bind])
|
||||
@ -40,7 +40,7 @@
|
||||
PKG_CHECK_MODULES(LIBCURL, [libcurl >= $CURL_MINIMUM])
|
||||
AC_PATH_ZLIB
|
||||
|
||||
@@ -89,214 +75,9 @@
|
||||
@@ -96,214 +82,9 @@
|
||||
AC_SUBST(LIBEVENT_CPPFLAGS)
|
||||
|
||||
|
||||
@ -135,18 +135,18 @@
|
||||
-dnl
|
||||
-dnl wxWidgets detection for the wxWidgets client
|
||||
-
|
||||
-AM_OPTIONS_WXCONFIG
|
||||
-AM_PATH_WXCONFIG($WX_MINIMUM,[have_wx=yes],[have_wx=no])
|
||||
-build_wx=no
|
||||
-AC_ARG_ENABLE([wx],
|
||||
- AC_HELP_STRING([--enable-wx],[build wxWidgets client]),
|
||||
- [want_wx=${enableval}],
|
||||
- [want_wx=no])
|
||||
-build_wx=no
|
||||
-if test "x$want_wx" = "xyes" ; then
|
||||
- [want_wx=maybe])
|
||||
-if test "x$want_wx" != "xno"; then
|
||||
- AM_OPTIONS_WXCONFIG
|
||||
- AM_PATH_WXCONFIG($WX_MINIMUM,[have_wx=yes],[have_wx=no])
|
||||
- if test "x$have_wx" = "xyes"; then
|
||||
- build_wx=yes
|
||||
- else
|
||||
- AC_MSG_ERROR("wxWidgets not found!")
|
||||
- build_wx=yes
|
||||
- elif test "x$want_wx" = "xyes"; then
|
||||
- AC_MSG_ERROR("wxWidgets not found!")
|
||||
- fi
|
||||
-fi
|
||||
-AM_CONDITIONAL([BUILD_WX],[test "x$build_wx" = "xyes"])
|
||||
@ -256,7 +256,7 @@
|
||||
if test "x$have_msw" = "xyes"; then
|
||||
AC_DEFINE([HAVE_MSW], 1)
|
||||
fi
|
||||
@@ -307,21 +88,11 @@
|
||||
@@ -314,21 +95,11 @@
|
||||
dnl Generate the output
|
||||
|
||||
AC_CONFIG_FILES([Makefile
|
||||
@ -279,7 +279,7 @@
|
||||
|
||||
ac_configure_args="$ac_configure_args --enable-static --disable-shared -q"
|
||||
AC_OUTPUT
|
||||
@@ -333,13 +104,5 @@
|
||||
@@ -340,13 +111,5 @@
|
||||
Source code location: ${srcdir}
|
||||
Compiler: ${CXX}
|
||||
Build Command-Line client: ${build_cli}
|
||||
@ -293,8 +293,8 @@
|
||||
- Build wxWidgets client: ${build_wx}
|
||||
|
||||
"
|
||||
--- Makefile.am.orig 2008-11-08 14:39:25.000000000 -0600
|
||||
+++ Makefile.am 2008-11-08 14:43:59.000000000 -0600
|
||||
--- Makefile.am.orig 2008-12-26 12:01:15.000000000 -0600
|
||||
+++ Makefile.am 2008-12-26 12:06:10.000000000 -0600
|
||||
@@ -1,108 +1,6 @@
|
||||
ACLOCAL_AMFLAGS = -I m4
|
||||
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- configure.ac.orig 2008-11-08 14:46:39.000000000 -0600
|
||||
+++ configure.ac 2008-11-08 14:49:51.000000000 -0600
|
||||
--- configure.ac.orig 2008-12-26 12:12:34.000000000 -0600
|
||||
+++ configure.ac 2008-12-26 12:15:38.000000000 -0600
|
||||
@@ -23,28 +23,14 @@
|
||||
fi
|
||||
AM_CONDITIONAL(TR_UNSTABLE, test "x$TR_UNSTABLE" = "xyes")
|
||||
@ -31,7 +31,7 @@
|
||||
fi
|
||||
|
||||
AC_HEADER_STDC
|
||||
@@ -56,7 +42,7 @@
|
||||
@@ -63,7 +49,7 @@
|
||||
|
||||
AC_SEARCH_LIBS([socket], [socket net])
|
||||
AC_SEARCH_LIBS([gethostbyname], [nsl bind])
|
||||
@ -40,7 +40,7 @@
|
||||
PKG_CHECK_MODULES(LIBCURL, [libcurl >= $CURL_MINIMUM])
|
||||
AC_PATH_ZLIB
|
||||
|
||||
@@ -89,214 +75,9 @@
|
||||
@@ -96,214 +82,9 @@
|
||||
AC_SUBST(LIBEVENT_CPPFLAGS)
|
||||
|
||||
|
||||
@ -135,18 +135,18 @@
|
||||
-dnl
|
||||
-dnl wxWidgets detection for the wxWidgets client
|
||||
-
|
||||
-AM_OPTIONS_WXCONFIG
|
||||
-AM_PATH_WXCONFIG($WX_MINIMUM,[have_wx=yes],[have_wx=no])
|
||||
-build_wx=no
|
||||
-AC_ARG_ENABLE([wx],
|
||||
- AC_HELP_STRING([--enable-wx],[build wxWidgets client]),
|
||||
- [want_wx=${enableval}],
|
||||
- [want_wx=no])
|
||||
-build_wx=no
|
||||
-if test "x$want_wx" = "xyes" ; then
|
||||
- [want_wx=maybe])
|
||||
-if test "x$want_wx" != "xno"; then
|
||||
- AM_OPTIONS_WXCONFIG
|
||||
- AM_PATH_WXCONFIG($WX_MINIMUM,[have_wx=yes],[have_wx=no])
|
||||
- if test "x$have_wx" = "xyes"; then
|
||||
- build_wx=yes
|
||||
- else
|
||||
- AC_MSG_ERROR("wxWidgets not found!")
|
||||
- build_wx=yes
|
||||
- elif test "x$want_wx" = "xyes"; then
|
||||
- AC_MSG_ERROR("wxWidgets not found!")
|
||||
- fi
|
||||
-fi
|
||||
-AM_CONDITIONAL([BUILD_WX],[test "x$build_wx" = "xyes"])
|
||||
@ -256,7 +256,7 @@
|
||||
if test "x$have_msw" = "xyes"; then
|
||||
AC_DEFINE([HAVE_MSW], 1)
|
||||
fi
|
||||
@@ -307,21 +88,11 @@
|
||||
@@ -314,21 +95,11 @@
|
||||
dnl Generate the output
|
||||
|
||||
AC_CONFIG_FILES([Makefile
|
||||
@ -279,7 +279,7 @@
|
||||
|
||||
ac_configure_args="$ac_configure_args --enable-static --disable-shared -q"
|
||||
AC_OUTPUT
|
||||
@@ -332,14 +103,6 @@
|
||||
@@ -339,14 +110,6 @@
|
||||
|
||||
Source code location: ${srcdir}
|
||||
Compiler: ${CXX}
|
||||
@ -294,8 +294,8 @@
|
||||
- Build wxWidgets client: ${build_wx}
|
||||
|
||||
"
|
||||
--- Makefile.am.orig 2008-11-08 14:46:44.000000000 -0600
|
||||
+++ Makefile.am 2008-11-08 14:50:29.000000000 -0600
|
||||
--- Makefile.am.orig 2008-12-26 12:12:37.000000000 -0600
|
||||
+++ Makefile.am 2008-12-26 12:16:13.000000000 -0600
|
||||
@@ -1,108 +1,6 @@
|
||||
ACLOCAL_AMFLAGS = -I m4
|
||||
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- configure.ac.orig 2008-11-08 14:51:27.000000000 -0600
|
||||
+++ configure.ac 2008-11-08 14:54:58.000000000 -0600
|
||||
--- configure.ac.orig 2008-12-26 12:17:00.000000000 -0600
|
||||
+++ configure.ac 2008-12-26 12:20:53.000000000 -0600
|
||||
@@ -23,28 +23,24 @@
|
||||
fi
|
||||
AM_CONDITIONAL(TR_UNSTABLE, test "x$TR_UNSTABLE" = "xyes")
|
||||
@ -31,7 +31,7 @@
|
||||
fi
|
||||
|
||||
AC_HEADER_STDC
|
||||
@@ -56,7 +52,7 @@
|
||||
@@ -63,7 +59,7 @@
|
||||
|
||||
AC_SEARCH_LIBS([socket], [socket net])
|
||||
AC_SEARCH_LIBS([gethostbyname], [nsl bind])
|
||||
@ -40,7 +40,7 @@
|
||||
PKG_CHECK_MODULES(LIBCURL, [libcurl >= $CURL_MINIMUM])
|
||||
AC_PATH_ZLIB
|
||||
|
||||
@@ -100,20 +96,14 @@
|
||||
@@ -107,20 +103,14 @@
|
||||
gthread-2.0 >= $GLIB_MINIMUM],
|
||||
[have_gtk=yes],
|
||||
[have_gtk=no])
|
||||
@ -65,7 +65,7 @@
|
||||
fi
|
||||
AM_CONDITIONAL([BUILD_GTK],[test "x$build_gtk" = "xyes"])
|
||||
AC_SUBST(GTK_LIBS)
|
||||
@@ -176,127 +166,8 @@
|
||||
@@ -183,127 +173,8 @@
|
||||
AC_SUBST(transmissionlocaledir)
|
||||
|
||||
|
||||
@ -73,18 +73,18 @@
|
||||
-dnl
|
||||
-dnl wxWidgets detection for the wxWidgets client
|
||||
-
|
||||
-AM_OPTIONS_WXCONFIG
|
||||
-AM_PATH_WXCONFIG($WX_MINIMUM,[have_wx=yes],[have_wx=no])
|
||||
-build_wx=no
|
||||
-AC_ARG_ENABLE([wx],
|
||||
- AC_HELP_STRING([--enable-wx],[build wxWidgets client]),
|
||||
- [want_wx=${enableval}],
|
||||
- [want_wx=no])
|
||||
-build_wx=no
|
||||
-if test "x$want_wx" = "xyes" ; then
|
||||
- [want_wx=maybe])
|
||||
-if test "x$want_wx" != "xno"; then
|
||||
- AM_OPTIONS_WXCONFIG
|
||||
- AM_PATH_WXCONFIG($WX_MINIMUM,[have_wx=yes],[have_wx=no])
|
||||
- if test "x$have_wx" = "xyes"; then
|
||||
- build_wx=yes
|
||||
- else
|
||||
- AC_MSG_ERROR("wxWidgets not found!")
|
||||
- build_wx=yes
|
||||
- elif test "x$want_wx" = "xyes"; then
|
||||
- AC_MSG_ERROR("wxWidgets not found!")
|
||||
- fi
|
||||
-fi
|
||||
-AM_CONDITIONAL([BUILD_WX],[test "x$build_wx" = "xyes"])
|
||||
@ -193,7 +193,7 @@
|
||||
if test "x$have_msw" = "xyes"; then
|
||||
AC_DEFINE([HAVE_MSW], 1)
|
||||
fi
|
||||
@@ -307,18 +178,10 @@
|
||||
@@ -314,18 +185,10 @@
|
||||
dnl Generate the output
|
||||
|
||||
AC_CONFIG_FILES([Makefile
|
||||
@ -212,7 +212,7 @@
|
||||
gtk/Makefile
|
||||
gtk/icons/Makefile
|
||||
po/Makefile.in])
|
||||
@@ -332,14 +195,9 @@
|
||||
@@ -339,14 +202,9 @@
|
||||
|
||||
Source code location: ${srcdir}
|
||||
Compiler: ${CXX}
|
||||
@ -227,8 +227,8 @@
|
||||
- Build wxWidgets client: ${build_wx}
|
||||
|
||||
"
|
||||
--- Makefile.am.orig 2008-11-08 14:51:30.000000000 -0600
|
||||
+++ Makefile.am 2008-11-08 14:55:30.000000000 -0600
|
||||
--- Makefile.am.orig 2008-12-26 12:17:02.000000000 -0600
|
||||
+++ Makefile.am 2008-12-26 12:21:26.000000000 -0600
|
||||
@@ -1,108 +1,6 @@
|
||||
ACLOCAL_AMFLAGS = -I m4
|
||||
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- configure.ac.orig 2008-11-08 14:57:14.000000000 -0600
|
||||
+++ configure.ac 2008-11-08 15:00:06.000000000 -0600
|
||||
--- configure.ac.orig 2008-12-26 12:22:16.000000000 -0600
|
||||
+++ configure.ac 2008-12-26 12:24:42.000000000 -0600
|
||||
@@ -13,9 +13,7 @@
|
||||
AC_CONFIG_MACRO_DIR([m4])
|
||||
|
||||
@ -10,7 +10,7 @@
|
||||
|
||||
if test m4_substr(peer_id_prefix,6,1) = "Z"; then
|
||||
AC_DEFINE(TR_UNSTABLE, 1, [Define to 1 if this is an unstable version of Transmission])
|
||||
@@ -23,323 +21,14 @@
|
||||
@@ -23,330 +21,12 @@
|
||||
fi
|
||||
AM_CONDITIONAL(TR_UNSTABLE, test "x$TR_UNSTABLE" = "xyes")
|
||||
|
||||
@ -30,7 +30,7 @@
|
||||
-AC_SUBST(WX_MINIMUM)
|
||||
-AC_SUBST(LIBNOTIFY_MINIMUM)
|
||||
-AC_SUBST(DBUS_GLIB_MINIMUM)
|
||||
|
||||
-
|
||||
-AC_PROG_CC
|
||||
-AC_PROG_CXX
|
||||
-if test "x$GCC" = "xyes" ; then
|
||||
@ -40,7 +40,14 @@
|
||||
-
|
||||
-AC_HEADER_STDC
|
||||
-AC_HEADER_TIME
|
||||
-AC_CHECK_FUNCS([lrintf strlcpy daemon dirname basename daemon strcasecmp localtime_r fallocate posix_fallocate])
|
||||
-
|
||||
-AC_MSG_CHECKING([for fallocate])
|
||||
-AC_TRY_LINK([#include <linux/falloc.h>],
|
||||
- [return fallocate(-1,0,0,0);],
|
||||
- [AC_DEFINE([HAVE_FALLOCATE],[1],[Defined if fallocate() exists])
|
||||
- AC_MSG_RESULT([yes])],
|
||||
- [AC_MSG_RESULT([no])])
|
||||
-AC_CHECK_FUNCS([lrintf strlcpy daemon dirname basename daemon strcasecmp localtime_r posix_fallocate])
|
||||
AC_PROG_INSTALL
|
||||
AC_PROG_MAKE_SET
|
||||
-ACX_PTHREAD
|
||||
@ -171,26 +178,26 @@
|
||||
-dnl
|
||||
-dnl wxWidgets detection for the wxWidgets client
|
||||
-
|
||||
-AM_OPTIONS_WXCONFIG
|
||||
-AM_PATH_WXCONFIG($WX_MINIMUM,[have_wx=yes],[have_wx=no])
|
||||
-build_wx=no
|
||||
-AC_ARG_ENABLE([wx],
|
||||
- AC_HELP_STRING([--enable-wx],[build wxWidgets client]),
|
||||
- [want_wx=${enableval}],
|
||||
- [want_wx=no])
|
||||
-build_wx=no
|
||||
-if test "x$want_wx" = "xyes" ; then
|
||||
- [want_wx=maybe])
|
||||
-if test "x$want_wx" != "xno"; then
|
||||
- AM_OPTIONS_WXCONFIG
|
||||
- AM_PATH_WXCONFIG($WX_MINIMUM,[have_wx=yes],[have_wx=no])
|
||||
- if test "x$have_wx" = "xyes"; then
|
||||
- build_wx=yes
|
||||
- else
|
||||
- AC_MSG_ERROR("wxWidgets not found!")
|
||||
- build_wx=yes
|
||||
- elif test "x$want_wx" = "xyes"; then
|
||||
- AC_MSG_ERROR("wxWidgets not found!")
|
||||
- fi
|
||||
-fi
|
||||
-AM_CONDITIONAL([BUILD_WX],[test "x$build_wx" = "xyes"])
|
||||
-
|
||||
|
||||
|
||||
dnl ----------------------------------------------------------------------------
|
||||
dnl
|
||||
-
|
||||
-
|
||||
-dnl ----------------------------------------------------------------------------
|
||||
-dnl
|
||||
-dnl platform-specific stuff.
|
||||
-
|
||||
-AC_CANONICAL_HOST
|
||||
@ -292,9 +299,9 @@
|
||||
- AC_DEFINE([HAVE_MSW], 1)
|
||||
-fi
|
||||
-AM_CONDITIONAL(WIN32, test "x$have_msw" = "xyes")
|
||||
-
|
||||
-dnl ----------------------------------------------------------------------------
|
||||
-dnl
|
||||
|
||||
dnl ----------------------------------------------------------------------------
|
||||
dnl
|
||||
dnl Generate the output
|
||||
|
||||
-AC_CONFIG_FILES([Makefile
|
||||
@ -335,8 +342,8 @@
|
||||
- Build wxWidgets client: ${build_wx}
|
||||
-
|
||||
-"
|
||||
--- Makefile.am.orig 2008-11-08 14:57:16.000000000 -0600
|
||||
+++ Makefile.am 2008-11-08 15:00:59.000000000 -0600
|
||||
--- Makefile.am.orig 2008-12-26 12:22:19.000000000 -0600
|
||||
+++ Makefile.am 2008-12-26 12:25:23.000000000 -0600
|
||||
@@ -1,49 +1,5 @@
|
||||
ACLOCAL_AMFLAGS = -I m4
|
||||
|
||||
|
@ -38,6 +38,7 @@ share/locale/it/LC_MESSAGES/transmission.mo
|
||||
share/locale/ja/LC_MESSAGES/transmission.mo
|
||||
share/locale/ka/LC_MESSAGES/transmission.mo
|
||||
share/locale/ku/LC_MESSAGES/transmission.mo
|
||||
share/locale/li/LC_MESSAGES/transmission.mo
|
||||
share/locale/lt/LC_MESSAGES/transmission.mo
|
||||
share/locale/lv/LC_MESSAGES/transmission.mo
|
||||
share/locale/mk/LC_MESSAGES/transmission.mo
|
||||
@ -54,6 +55,7 @@ share/locale/ro/LC_MESSAGES/transmission.mo
|
||||
share/locale/ru/LC_MESSAGES/transmission.mo
|
||||
share/locale/sk/LC_MESSAGES/transmission.mo
|
||||
share/locale/sl/LC_MESSAGES/transmission.mo
|
||||
share/locale/sq/LC_MESSAGES/transmission.mo
|
||||
share/locale/sr/LC_MESSAGES/transmission.mo
|
||||
share/locale/sv/LC_MESSAGES/transmission.mo
|
||||
share/locale/te/LC_MESSAGES/transmission.mo
|
||||
|
Loading…
Reference in New Issue
Block a user