SALOME is a free software that provides a generic platform for Pre

and Post-Processing for numerical simulation.
+Supports interoperability between CAD modeling and
 computation software (CAD-CAE link)
+Makes easier the integration of new components on heterogeneous systems
 for numerical computation
+Sets the priority to multi-physics coupling between computation software
+Provides a generic user interface, user-friendly and efficient,
 which helps to reduce the costs and  delays of carrying out the studies
+Reduces training time to the specific time for learning the software solution
 which has been based on this platform
+All functionalities are accessible through the programmatic
 integrated Python console

This package contains MED module.

WWW: http://www.salome-platform.org
- Stas Timokhin
devel@stasyan.com

PR:		ports/143469
Submitted by:	Stas Timokhin <devel at stasyan.com>
This commit is contained in:
Philip M. Gollucci 2010-02-12 22:15:16 +00:00
parent 17d776a706
commit 05c91872bd
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=249728
32 changed files with 2268 additions and 0 deletions

View File

@ -76,6 +76,7 @@
SUBDIR += salome-gui
SUBDIR += salome-kernel
SUBDIR += salome-light
SUBDIR += salome-med
SUBDIR += sceptre
SUBDIR += scotch
SUBDIR += scv

14
cad/salome-med/Makefile Normal file
View File

@ -0,0 +1,14 @@
# New ports collection makefile for: cad/salome-med
# Date created: 20 May 2009
# Whom: Stas Timokhin <devel@stasyan.com>
#
# $FreeBSD$
CATEGORIES= cad science
MASTERDIR= ${.CURDIR}/../salome
PKGNAMESUFFIX= -med
SAL_MODULE_UPPER= MED
.include "${MASTERDIR}/Makefile"

View File

@ -0,0 +1,11 @@
--- src/MEDSPLITTER/MEDSPLITTER_SCOTCHGraph.cxx.orig 2009-12-17 13:53:26.000000000 +0600
+++ src/MEDSPLITTER/MEDSPLITTER_SCOTCHGraph.cxx 2009-12-17 13:53:59.000000000 +0600
@@ -19,7 +19,7 @@
#include <cstdio>
extern "C" {
#define restrict
-#include "bin/scotch.h"
+#include "scotch.h"
}
#include "MEDSPLITTER_Graph.hxx"
#include "MEDSPLITTER_SCOTCHGraph.hxx"

View File

@ -0,0 +1,20 @@
--- src/MEDMEM/MEDMEM_define.hxx.orig 2009-03-18 20:52:30.000000000 +0600
+++ src/MEDMEM/MEDMEM_define.hxx 2009-06-04 14:59:23.000000000 +0700
@@ -24,7 +24,7 @@
#include <stdio.h>
#include <iostream>
-#include <string>
+#include <cstring>
#include <assert.h>
// UTILE AUX DEUX NAMESPACES
@@ -117,7 +117,7 @@
// //#define MED_ALL 0 !!!!! NB: WARNING MED_ALL deja utilise dans l'enum medGeometryElement !!!!!!!!
// #define MED_ALL 0
-#if defined(SUN4SOL2) || defined(PCLINUX) || defined(PCLINUX64_32) || defined(OSF1_32) || defined(IRIX64_32) || defined(RS6000)
+#if defined(SUN4SOL2) || defined(PCLINUX) || defined(PCLINUX64_32) || defined(OSF1_32) || defined(IRIX64_32) || defined(RS6000) || defined(FREEBSD)
/* interface C/FORTRAN */
/* this true only with g77 and gcc : we must change it to use directly NOMF_... and INT32 or INT64 - it will be more simple to understand and to use ! */
// #define NOMF_POST_UNDERSCORE

View File

@ -0,0 +1,10 @@
--- src/MEDWrapper/Base/MED_Common.hxx.orig 2009-06-04 11:40:35.000000000 +0700
+++ src/MEDWrapper/Base/MED_Common.hxx 2009-06-04 11:40:49.000000000 +0700
@@ -32,6 +32,7 @@
#include <string>
#include <set>
#include <map>
+#include <cstring>
extern "C"
{

View File

@ -0,0 +1,32 @@
--- src/MEDWrapper/V2_1/Core/MEDunvCr.cxx.orig 2009-06-04 08:44:21.000000000 +0700
+++ src/MEDWrapper/V2_1/Core/MEDunvCr.cxx 2009-06-04 09:10:00.000000000 +0700
@@ -25,6 +25,10 @@
#include <stdio.h>
#include <time.h>
+#include <unistd.h>
+#include <sys/types.h>
+#include <pwd.h>
+
//#ifdef PPRO_NT
#ifdef WIN32
// Windows Header Files:
@@ -51,6 +55,7 @@
long nSize = UNLEN+1;
#else
struct timeval tp;
+ struct passwd *pwstr;
#endif
med_err ret;
@@ -83,7 +88,9 @@
nSize = (long)strlen(nomu)-1;
if ( sprintf(&nomu[nSize]," %hu",tp.millitm) < 0 ) return -1;
#else
- if (cuserid(nomu) == (void*) NULL) return -1;
+// if (cuserid(nomu) == (void*) NULL) return -1;
+ pwstr=getpwuid(getuid());
+ strncpy(nomu,pwstr->pw_name,MED_TAILLE_LNOM+1);
strcat(nomu," ");
temps=time(&temps);
strcat(nomu,ctime(&temps));

View File

@ -0,0 +1,15 @@
--- src/MEDWrapper/V2_2/MED_V2_2_Wrapper.cxx.orig 2009-06-04 16:07:01.000000000 +0700
+++ src/MEDWrapper/V2_2/MED_V2_2_Wrapper.cxx 2009-06-04 16:07:21.000000000 +0700
@@ -95,7 +95,11 @@
void
GetVersionRelease<eV2_2>(TInt& majeur, TInt& mineur, TInt& release)
{
- MEDversionDonner(&majeur, &mineur, &release);
+ med_int a,b,c;
+ a=majeur;
+ b=mineur;
+ c=release;
+ MEDversionDonner(&a, &b, &c);
}
template<>

View File

@ -0,0 +1,12 @@
--- adm_local/unix/config_files/check_Med2.m4.orig 2009-06-03 16:35:02.000000000 +0700
+++ adm_local/unix/config_files/check_Med2.m4 2009-06-03 16:35:32.000000000 +0700
@@ -141,6 +141,9 @@
uxpv*)
MACHINE=VPP5000
;;
+ freebsd*)
+ MACHINE=FreeBSD
+ ;;
*)
MACHINE=
host_os_novers=$host_os

View File

@ -0,0 +1,60 @@
--- adm_local/unix/config_files/check_metis.m4.orig 2009-05-28 22:09:03.000000000 +0700
+++ adm_local/unix/config_files/check_metis.m4 2009-07-30 15:07:50.000000000 +0700
@@ -43,8 +43,8 @@
LIBS_old=$LIBS
if test "x${METISDIR}" != "x" ; then
- METIS_CPPFLAGS="-DENABLE_METIS -I${METISDIR}/Lib"
- METIS_LIBS="-L${METISDIR} -lmetis"
+ METIS_CPPFLAGS="-DENABLE_METIS -I${METISDIR}/include/metis"
+ METIS_LIBS="-L${METISDIR}/lib -lmetis"
fi
metis_ok=no
@@ -57,13 +57,13 @@
metis_include_dir_ok=yes
if test "x${METISDIR}" != "x" ; then
- AC_CHECK_FILE(${METISDIR}/Lib/metis.h,
+ AC_CHECK_FILE(${METISDIR}/include/metis/metis.h,
metis_include_dir_ok=yes,
metis_include_dir_ok=no)
fi
if test "x${metis_include_dir_ok}" = "xyes" ; then
- AC_TRY_COMPILE([#include <metis.h>],
+ AC_TRY_COMPILE([#include <metis/metis.h>],
[Change2CNumbering(0,0,0)],
metis_headers_ok=yes,
metis_headers_ok=no)
@@ -81,26 +81,26 @@
AC_CHECKING(for METIS binaries)
metis_lib_dir_ok=yes
if test "x${METISDIR}" != "x" ; then
- AC_CHECK_FILE(${METISDIR}/libmetis.a,
+ AC_CHECK_FILE(${METISDIR}/lib/libmetis.a,
metis_lib_dir_ok=yes,
metis_lib_dir_ok=no)
if test "x${metis_lib_dir_ok}" = "xno" ; then
METIS_LIBSUFFIX=""
- AC_CHECK_FILE(${METISDIR}/libmetis.a,
+ AC_CHECK_FILE(${METISDIR}/lib/libmetis.a,
metis_lib_dir_ok=yes,
metis_lib_dir_ok=no)
fi
fi
if test "x${metis_lib_dir_ok}" = "xyes" ; then
LIBS="${LIBS_old} ${METIS_LIBS}"
- AC_TRY_LINK([#include <metis.h>],
+ AC_TRY_LINK([#include <metis/metis.h>],
[Change2CNumbering(0,0,0)],
metis_binaries_ok=yes,
metis_binaries_ok=no)
if test "x${metis_binaries_ok}" = "xno" ; then
METIS_LIBSUFFIX=""
LIBS="${LIBS_old} ${METIS_LIBS} "
- AC_TRY_LINK([#include <metis.h>],
+ AC_TRY_LINK([#include <metis/metis.h>],
[Change2CNumbering(0,0,0)],
metis_binaries_ok=yes,
metis_binaries_ok=no)

View File

@ -0,0 +1,61 @@
--- adm_local/unix/config_files/check_scotch.m4.orig 2009-05-28 22:09:03.000000000 +0700
+++ adm_local/unix/config_files/check_scotch.m4 2009-07-30 14:52:49.000000000 +0700
@@ -44,7 +44,7 @@
if test "x${SCOTCHDIR}" != "x" ; then
SCOTCH_CPPFLAGS="-DENABLE_SCOTCH -I${SCOTCHDIR}"
- SCOTCH_LIBS="-L${SCOTCHDIR}/bin -lscotch -lscotcherr"
+ SCOTCH_LIBS="-L${SCOTCHDIR}/lib -lscotch -lscotcherr"
fi
scotch_ok=no
@@ -57,14 +57,14 @@
scotch_include_dir_ok=yes
if test "x${SCOTCHDIR}" != "x" ; then
- AC_CHECK_FILE(${SCOTCHDIR}/bin/scotch.h,
+ AC_CHECK_FILE(${SCOTCHDIR}/include/scotch.h,
scotch_include_dir_ok=yes,
scotch_include_dir_ok=no)
fi
if test "x${scotch_include_dir_ok}" = "xyes" ; then
AC_TRY_COMPILE([#include <stdio.h>
- #include <bin/scotch.h>],
+ #include <scotch.h>],
[SCOTCH_Graph* graph;
SCOTCH_graphInit(graph)],
scotch_headers_ok=yes,
@@ -83,12 +83,12 @@
AC_CHECKING(for SCOTCH binaries)
scotch_lib_dir_ok=yes
if test "x${SCOTCHDIR}" != "x" ; then
- AC_CHECK_FILE(${SCOTCHDIR}/bin/libscotch.a,
+ AC_CHECK_FILE(${SCOTCHDIR}/lib/libscotch.a,
scotch_lib_dir_ok=yes,
scotch_lib_dir_ok=no)
if test "x${scotch_lib_dir_ok}" = "xno" ; then
SCOTCH_LIBSUFFIX=""
- AC_CHECK_FILE(${SCOTCHDIR}/bin/libscotch.a,
+ AC_CHECK_FILE(${SCOTCHDIR}/lib/libscotch.a,
scotch_lib_dir_ok=yes,
scotch_lib_dir_ok=no)
fi
@@ -96,7 +96,7 @@
if test "x${scotch_lib_dir_ok}" = "xyes" ; then
LIBS="${LIBS_old} ${SCOTCH_LIBS}"
AC_TRY_LINK([#include <stdio.h>
- #include <bin/scotch.h>],
+ #include <scotch.h>],
[SCOTCH_Graph* graph;
SCOTCH_graphInit(graph)],
scotch_binaries_ok=yes,
@@ -105,7 +105,7 @@
SCOTCH_LIBSUFFIX=""
LIBS="${LIBS_old} ${SCOTCH_LIBS} "
AC_TRY_LINK([#include <stdio.h>
- #include <bin/scotch.h>],
+ #include <scotch.h>],
[SCOTCH_Graph* graph;
SCOTCH_graphInit(graph)],
scotch_binaries_ok=yes,

View File

@ -0,0 +1,8 @@
--- configure.ac.orig 2009-06-03 15:58:43.000000000 +0700
+++ configure.ac 2009-06-03 16:05:00.000000000 +0700
@@ -665,4 +665,4 @@
])
dnl To avoid recompiling half of the sources because of SALOMEconfig.h recreating
-touch -d 01Jan2007 ./salome_adm/unix/SALOMEconfig.h
+touch -t 200701010000 ./salome_adm/unix/SALOMEconfig.h

View File

@ -0,0 +1,12 @@
--- src/MEDWrapper/V2_1/Core/med_outils.hxx.orig 2009-06-03 16:46:04.000000000 +0700
+++ src/MEDWrapper/V2_1/Core/med_outils.hxx 2009-06-03 16:49:05.000000000 +0700
@@ -118,7 +118,8 @@
#define MED_TAILLE_PROFILS 9
/*Pour eviter le bug solaris*/
-#include <malloc.h>
+#include <stdlib.h>
+#include <string.h>
/* Interface des routines du composant tools */
#include "med_misc.hxx"

View File

@ -0,0 +1,20 @@
--- src/MULTIPR/MULTIPR_DecimationAccel.cxx.orig 2009-03-18 20:52:30.000000000 +0600
+++ src/MULTIPR/MULTIPR_DecimationAccel.cxx 2009-06-05 14:46:47.000000000 +0700
@@ -51,7 +51,7 @@
//*****************************************************************************
-ostream& operator<<(ostream& pOs, DecimationAccel& pA)
+std::ostream& operator<<(std::ostream& pOs, DecimationAccel& pA)
{
pOs << "DecimationAccel:" << endl;
return pOs;
@@ -305,7 +305,7 @@
}
-ostream& operator<<(ostream& pOs, DecimationAccelGrid& pG)
+std::ostream& operator<<(std::ostream& pOs, DecimationAccelGrid& pG)
{
pOs << "DecimationAccelGrid:" << endl;
pOs << " Num=" << pG.mNum << endl;

View File

@ -0,0 +1,11 @@
--- src/MULTIPR/MULTIPR_Elements.hxx.orig 2009-03-18 20:52:30.000000000 +0600
+++ src/MULTIPR/MULTIPR_Elements.hxx 2009-06-05 14:53:11.000000000 +0700
@@ -45,7 +45,7 @@
#include <set>
#include <vector>
-
+#include <iostream>
namespace multipr
{

View File

@ -0,0 +1,11 @@
--- src/MULTIPR/MULTIPR_Field.cxx.orig 2009-03-18 20:52:30.000000000 +0600
+++ src/MULTIPR/MULTIPR_Field.cxx 2009-06-05 14:47:48.000000000 +0700
@@ -832,7 +832,7 @@
}
}
-ostream& operator<<(ostream& pOs, Field& pF)
+std::ostream& operator<<(std::ostream& pOs, Field& pF)
{
char strEntity[16];
switch (pF.mEntity)

View File

@ -0,0 +1,11 @@
--- src/MULTIPR/MULTIPR_Mesh.cxx.orig 2009-03-18 20:52:30.000000000 +0600
+++ src/MULTIPR/MULTIPR_Mesh.cxx 2009-06-05 14:19:22.000000000 +0700
@@ -1909,7 +1909,7 @@
}
-ostream& operator<<(ostream& pOs, Mesh& pM)
+std::ostream& operator<<(std::ostream& pOs, Mesh& pM)
{
pOs << "Mesh: " << endl;
pOs << " MED file =|" << pM.mMEDfilename << "|" << endl;

View File

@ -0,0 +1,20 @@
--- src/MULTIPR/MULTIPR_MeshDis.cxx.orig 2009-03-18 20:52:30.000000000 +0600
+++ src/MULTIPR/MULTIPR_MeshDis.cxx 2009-06-05 14:19:02.000000000 +0700
@@ -179,7 +179,7 @@
}
-ostream& operator<<(ostream& pOs, MeshDisPart& pM)
+std::ostream& operator<<(std::ostream& pOs, MeshDisPart& pM)
{
switch (pM.mToDoOnNextWrite)
{
@@ -1475,7 +1475,7 @@
}
}
-ostream& operator<<(ostream& pOs, MeshDis& pM)
+std::ostream& operator<<(std::ostream& pOs, MeshDis& pM)
{
pOs << "Mesh Dis.:" << endl;
pOs << " Sequential filename (source) =|" << pM.mSequentialMEDFilename << "|" << endl;

View File

@ -0,0 +1,20 @@
--- src/MULTIPR/MULTIPR_Nodes.cxx.orig 2009-05-28 22:08:56.000000000 +0700
+++ src/MULTIPR/MULTIPR_Nodes.cxx 2009-07-13 13:29:35.000000000 +0700
@@ -36,6 +36,8 @@
#include "MULTIPR_Exceptions.hxx"
#include <iostream>
+#include <cstring>
+#include <memory>
#include <limits>
using namespace std;
@@ -429,7 +431,7 @@
}
-ostream& operator<<(ostream& pOs, Nodes& pN)
+std::ostream& operator<<(std::ostream& pOs, Nodes& pN)
{
char strCoordSystem[16];
switch (pN.mCoordSystem)

View File

@ -0,0 +1,11 @@
--- src/MULTIPR/MULTIPR_Obj.cxx.orig 2009-03-18 20:52:30.000000000 +0600
+++ src/MULTIPR/MULTIPR_Obj.cxx 2009-06-05 14:48:11.000000000 +0700
@@ -742,7 +742,7 @@
}
}
-ostream& operator<<(ostream& pOs, Obj& pO)
+std::ostream& operator<<(std::ostream& pOs, Obj& pO)
{
pOs << "Obj:" << endl;
pOs << " Name:" << pO.mMEDfilename << endl;

View File

@ -0,0 +1,10 @@
--- src/MULTIPR/MULTIPR_PointOfField.hxx.orig 2009-03-18 20:52:30.000000000 +0600
+++ src/MULTIPR/MULTIPR_PointOfField.hxx 2009-06-05 14:55:16.000000000 +0700
@@ -30,6 +30,7 @@
#ifndef MULTIPR_POINTOFFIELD_HXX
#define MULTIPR_POINTOFFIELD_HXX
+#include <limits>
//*****************************************************************************
// Includes section

View File

@ -0,0 +1,21 @@
--- src/MULTIPR/MULTIPR_Profil.cxx.orig 2009-03-18 20:52:30.000000000 +0600
+++ src/MULTIPR/MULTIPR_Profil.cxx 2009-06-05 14:20:37.000000000 +0700
@@ -41,6 +41,9 @@
using namespace std;
+
+
+
namespace multipr
{
@@ -344,7 +347,7 @@
}
-ostream& operator<<(ostream& pOs, Profil& pP)
+std::ostream& operator<<(std::ostream& pOs, Profil& pP)
{
pOs << "Profil:" << endl;
pOs << " Name=|" << pP.mName << "|" << endl;

View File

@ -0,0 +1,10 @@
--- src/MULTIPR/MULTIPR_Profil.hxx.orig 2009-05-28 22:08:56.000000000 +0700
+++ src/MULTIPR/MULTIPR_Profil.hxx 2009-07-13 13:32:15.000000000 +0700
@@ -44,6 +44,7 @@
#include <vector>
#include <set>
+#include <cstring>
#include <iostream>
namespace multipr

View File

@ -0,0 +1,10 @@
--- src/ParaMEDMEM/ElementLocator.hxx.orig 2009-10-19 15:35:19.000000000 +0700
+++ src/ParaMEDMEM/ElementLocator.hxx 2009-10-19 15:36:30.000000000 +0700
@@ -24,6 +24,7 @@
#include <mpi.h>
#include <vector>
#include <set>
+#include <string>
namespace ParaMEDMEM
{

View File

@ -0,0 +1,10 @@
--- src/ParaMEDMEM/MPIAccessDEC.hxx.orig 2009-10-19 15:39:50.000000000 +0700
+++ src/ParaMEDMEM/MPIAccessDEC.hxx 2009-10-19 15:42:15.000000000 +0700
@@ -25,6 +25,7 @@
#include <map>
#include <iostream>
+#include <cstring>
namespace ParaMEDMEM
{

View File

@ -0,0 +1,13 @@
--- src/ParaMEDMEM/MxN_Mapping.hxx.orig 2009-10-19 15:18:21.000000000 +0700
+++ src/ParaMEDMEM/MxN_Mapping.hxx 2009-10-19 15:18:27.000000000 +0700
@@ -39,8 +39,8 @@
void addElementFromSource(int distant_proc, int distant_elem);
void prepareSendRecv();
void sendRecv(MEDCouplingFieldDouble& field);
- void sendRecv(double* field, MEDCouplingFieldDouble& field) const ;
- void reverseSendRecv(double* field, MEDCouplingFieldDouble& field) const ;
+ void sendRecv(double* fieldd, MEDCouplingFieldDouble& field) const ;
+ void reverseSendRecv(double* fieldd, MEDCouplingFieldDouble& field) const ;
//
const std::vector<std::pair<int,int> >& getSendingIds() const { return _sending_ids; }//tmp

View File

@ -0,0 +1,20 @@
--- adm_local/unix/config_files/Makefile.am.orig 2009-12-01 20:59:14.000000000 +0600
+++ adm_local/unix/config_files/Makefile.am 2010-01-05 20:29:04.000000000 +0600
@@ -23,17 +23,12 @@
dist_admlocalm4_DATA = \
ac_check_sizeof_fortran.m4 \
- check_GUI.m4 \
check_Med.m4 \
check_Med2.m4 \
check_bft.m4 \
check_fvm.m4 \
check_libxml.m4 \
- check_metis.m4 \
- check_opengl.m4 \
- check_qt.m4 \
check_scotch.m4 \
- check_vtk.m4 \
med_check_sizeof_medint.m4 \
renumber.m4 \
splitter.m4 \

View File

@ -0,0 +1,11 @@
--- bin/Makefile.am.orig 2010-01-06 21:46:00.000000000 +0600
+++ bin/Makefile.am 2010-01-06 21:46:08.000000000 +0600
@@ -22,7 +22,7 @@
include $(top_srcdir)/adm_local/unix/make_common_starter.am
# non-distributed files
-nodist_salomescript_DATA = VERSION
+nodist_salomescript_DATA =
# distributed files
dist_salomescript_SCRIPTS =

View File

@ -0,0 +1,20 @@
--- adm_local/unix/config_files/check_Med.m4.orig 2009-08-14 20:34:25.000000000 +0700
+++ adm_local/unix/config_files/check_Med.m4 2009-08-14 20:34:47.000000000 +0700
@@ -39,7 +39,7 @@
[ --with-med=DIR root directory path of MED installation ],
MED_DIR="$withval",MED_DIR="")
-if test "x${MED_DIR}" == "x" ; then
+if test "x${MED_DIR}" = "x" ; then
AC_MSG_RESULT(for \${MED_ROOT_DIR}: ${MED_ROOT_DIR})
# no --with-med-dir option used
if test "x${MED_ROOT_DIR}" != "x" ; then
@@ -57,7 +57,7 @@
AC_MSG_RESULT(Using Med module distribution in ${MED_DIR})
Med_ok=yes
- if test "x$MED_ROOT_DIR" == "x" ; then
+ if test "x$MED_ROOT_DIR" = "x" ; then
MED_ROOT_DIR=${MED_DIR}
fi

View File

@ -0,0 +1,38 @@
--- adm_local/unix/config_files/check_qt.m4.orig 2009-10-19 14:53:19.000000000 +0700
+++ adm_local/unix/config_files/check_qt.m4 2009-10-19 14:53:50.000000000 +0700
@@ -153,9 +153,9 @@
#
if test "x$qt_ok" = "xyes"
then
- if test -f ${QTDIR}/bin/moc
+ if test -f ${QTDIR}/bin/moc-qt4
then
- MOC=${QTDIR}/bin/moc
+ MOC=${QTDIR}/bin/moc-qt4
else
AC_PATH_PROG(MOC, moc)
fi
@@ -189,9 +189,9 @@
#
if test "x$qt_ok" = "xyes"
then
- if test -f ${QTDIR}/bin/uic
+ if test -f ${QTDIR}/bin/uic-qt4
then
- UIC=${QTDIR}/bin/uic
+ UIC=${QTDIR}/bin/uic-qt4
else
AC_PATH_PROG(UIC, uic)
fi
@@ -246,9 +246,9 @@
#
if test "x$qt_ok" = "xyes"
then
- if test -f ${QTDIR}/bin/lrelease
+ if test -f ${QTDIR}/bin/lrelease-qt4
then
- LRELEASE=${QTDIR}/bin/lrelease
+ LRELEASE=${QTDIR}/bin/lrelease-qt4
else
AC_PATH_PROG(LRELEASE, lrelease)
fi

View File

@ -0,0 +1,11 @@
--- src/MEDMEMBinTest/test_grid.cxx.orig 2009-06-04 12:55:43.000000000 +0700
+++ src/MEDMEMBinTest/test_grid.cxx 2009-06-04 12:55:55.000000000 +0700
@@ -21,6 +21,8 @@
//
#include "MEDMEM_Grid.hxx"
+#include <memory>
+
using namespace MEDMEM;
using namespace MED_EN;

19
cad/salome-med/pkg-descr Normal file
View File

@ -0,0 +1,19 @@
SALOME is a free software that provides a generic platform for Pre
and Post-Processing for numerical simulation.
+Supports interoperability between CAD modeling and
computation software (CAD-CAE link)
+Makes easier the integration of new components on heterogeneous systems
for numerical computation
+Sets the priority to multi-physics coupling between computation software
+Provides a generic user interface, user-friendly and efficient,
which helps to reduce the costs and delays of carrying out the studies
+Reduces training time to the specific time for learning the software solution
which has been based on this platform
+All functionalities are accessible through the programmatic
integrated Python console
This package contains MED module.
WWW: http://www.salome-platform.org
- Stas Timokhin
devel@stasyan.com

1715
cad/salome-med/pkg-plist Normal file

File diff suppressed because it is too large Load Diff