Add p5-WebService-NoPaste 0.03, a pastebin web application to upload

snippets of text.

PR:		90919
Submitted by:	Gea-Suan Lin <gslin@gslin.org>
This commit is contained in:
Emanuel Haupt 2005-12-28 20:59:43 +00:00
parent 1a6a2a42ee
commit 0518883a01
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=152297
6 changed files with 99 additions and 0 deletions

View File

@ -689,6 +689,7 @@
SUBDIR += p5-WWW-SourceForge
SUBDIR += p5-WWW-Wikipedia
SUBDIR += p5-WebService-Bloglines
SUBDIR += p5-WebService-NoPaste
SUBDIR += p5-WebService-Technorati
SUBDIR += p5-ldap-abook
SUBDIR += p5-libapreq

View File

@ -0,0 +1,47 @@
# New ports collection makefile for: p5-WebService-NoPaste
# Date created: 2005-12-26
# Whom: Gea-Suan Lin <gslin@netnews.NCTU.edu.tw>
#
# $FreeBSD$
#
PORTNAME= WebService-NoPaste
PORTVERSION= 0.03
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= WebService
PKGNAMEPREFIX= p5-
MAINTAINER= gslin@gslin.org
COMMENT= A pastebin web application to upload snippets of text
BUILD_DEPENDS= ${SITE_PERL}/IO/All.pm:${PORTSDIR}/devel/p5-IO-All \
${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/Spiffy.pm:${PORTSDIR}/devel/p5-Spiffy
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
MAN3= WebService::NoPaste.3
OPTIONS= X11 "Enable X11 Clipboard support" off
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500601
IGNORE= requires perl 5.6.x or later. Install lang/perl5 then try again
.endif
.if defined(WITH_X11)
BUILD_DEPENDS+= ${SITE_PERL}/Clipboard.pm:${PORTSDIR}/x11/p5-Clipboard
.else
EXTRA_PATCHES+= ${FILESDIR}/extrapatch-lib-WebService-NoPaste.pm
.endif
post-patch:
@${PERL} -pi -e "s|/usr/bin/perl|${PERL}|;" ${WRKSRC}/nopaste
.if !defined(WITH_X11)
@${RM} ${WRKSRC}/lib/WebService/NoPaste.pm.orig
.endif
.include <bsd.port.post.mk>

View File

@ -0,0 +1,3 @@
MD5 (WebService-NoPaste-0.03.tar.gz) = 1113fd9f7a9de9ec5b8310b7aed1f8b6
SHA256 (WebService-NoPaste-0.03.tar.gz) = 413a1eba3694cff66904941ba216ef25dddc259e4f17e8cfd75ddb4aaba2973d
SIZE (WebService-NoPaste-0.03.tar.gz) = 9773

View File

@ -0,0 +1,37 @@
--- lib/WebService/NoPaste.pm.orig Tue May 3 20:10:26 2005
+++ lib/WebService/NoPaste.pm Mon Dec 26 18:45:18 2005
@@ -3,7 +3,6 @@
use LWP::UserAgent;
use HTTP::Request::Common 'POST';
use IO::All;
-use Clipboard;
our $VERSION = '0.03';
sub new {
@@ -37,9 +36,9 @@
io('-')->all
}
-sub read_from_clipboard { Clipboard->paste }
+sub read_from_clipboard { }
-sub save_to_clipboard { Clipboard->copy($_[0]); }
+sub save_to_clipboard { }
my $PLEASE_EMAIL = "WebService::NoPaste has only been tested with 'pastebot' brand paste servers, and even then only to a limited extent. If you got this error unexpectedly, please let me know - rking\@panopic.com.";
sub response_die {
@@ -57,14 +56,6 @@
# Manually paste input, manually copy the result url:
$ nopaste
-
- # Turbo mode: use clipboard as input, send, and then put the result
- # URL back into the clipboard:
- $ nopaste cp
-
- # Just take the input from the clipboard, but otherwise leave the
- # clipboard alone:
- $ nopaste c
# Instantly upload your passwd file for the whole world to see, but
# at least you'll have the result URL conveniently in your

View File

@ -0,0 +1,5 @@
A pastebin web application to upload snippets of text to a webserver. Pastebins
are often used in IRC channels to show large amuonts of text.
Author: Ryan King <rking@panoptic.com>
WWW: http://search.cpan.org/dist/WebService-NoPaste/

View File

@ -0,0 +1,6 @@
bin/nopaste
%%SITE_PERL%%/WebService/NoPaste.pm
@unexec rmdir %D/%%SITE_PERL%%/WebService 2>/dev/null || true
%%SITE_PERL%%/%%PERL_ARCH%%/auto/WebService/NoPaste/.packlist
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/WebService/NoPaste
@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/WebService 2>/dev/null || true