o update to 0.9.2
o use ports libraries instead of internal versions: liba52 and ffmpeg o support for both vorbis and ogg o WITH_CSS: plugin for css processing o add WWW tag to DESCR Reviewed by: MAINTAINER, freebsd-multimedia
This commit is contained in:
parent
b3f9ad8523
commit
04e3b1a90f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=49225
@ -6,20 +6,22 @@
|
||||
#
|
||||
|
||||
PORTNAME= xine
|
||||
PORTVERSION= 0.9.1
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.9.2
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://xine.sourceforge.net/files/ \
|
||||
${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
PKGNAMEPREFIX= lib
|
||||
DISTNAME= ${PORTNAME}-lib-${PORTVERSION}
|
||||
DISTFILES= ${PORTNAME}-lib-${PORTVERSION}${EXTRACT_SUFX}
|
||||
|
||||
MAINTAINER= nobutaka@nobutaka.com
|
||||
|
||||
LIB_DEPENDS= aa.1:${PORTSDIR}/graphics/aalib
|
||||
BUILD_DEPENDS= ${LOCALBASE}/lib/libavcodec.a:${PORTSDIR}/graphics/ffmpeg
|
||||
LIB_DEPENDS= a52.0:${PORTSDIR}/audio/liba52 \
|
||||
aa.1:${PORTSDIR}/graphics/aalib
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-lib-${PORTVERSION}
|
||||
USE_AUTOMAKE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_X_PREFIX= yes
|
||||
USE_IMLIB= yes
|
||||
@ -29,6 +31,7 @@ INSTALLS_SHLIB= yes
|
||||
|
||||
MAN1= xine-config.1
|
||||
MAN3= ao_driver_t.3 ao_functions_t.3 autoplay_group.3 \
|
||||
audio_cap.3 audio_group.3 audio_prop.3 \
|
||||
browse_group.3 build_info.3 cfg_data_t.3 config_group.3 \
|
||||
config_values_s.3 config_values_t.3 demux_strategy.3 \
|
||||
event_group.3 loadplugins_group.3 mrl_t.3 mrl_types.3 \
|
||||
@ -52,4 +55,45 @@ PLIST_SUB+= HAVE_ARTS=""
|
||||
PLIST_SUB+= HAVE_ARTS="@comment "
|
||||
.endif
|
||||
|
||||
.if exists(${LOCALBASE}/include/vorbis/codec.h)
|
||||
LIB_DEPENDS+= vorbis.0:${PORTSDIR}/audio/libvorbis
|
||||
|
||||
PLIST_SUB+= HAVE_VORBIS=""
|
||||
.else
|
||||
PLIST_SUB+= HAVE_VORBIS="@comment "
|
||||
.endif
|
||||
|
||||
.if exists(${LOCALBASE}/include/ogg/ogg.h)
|
||||
LIB_DEPENDS+= ogg.2:${PORTSDIR}/audio/libogg
|
||||
|
||||
PLIST_SUB+= HAVE_OGG=""
|
||||
.else
|
||||
PLIST_SUB+= HAVE_OGG="@comment "
|
||||
.endif
|
||||
|
||||
.if defined(WITH_CSS)
|
||||
# http://members.home.nl/mphm.janssen/linuxvideo/linuxvideo.html
|
||||
MASTER_SITES+= http://members.home.nl/mphm.janssen/files/
|
||||
DISTFILES+= ${PLUGIN_CSS}${EXTRACT_SUFX}
|
||||
|
||||
LIB_DEPENDS+= dvdcss.0:${PORTSDIR}/graphics/libdvdcss
|
||||
|
||||
PLUGIN_CSS= dvd-plugin-${PLUGIN_CSS_VERSION}
|
||||
PLUGIN_CSS_VERSION= 0.4
|
||||
.endif
|
||||
|
||||
pre-everything::
|
||||
.if !defined(WITH_CSS)
|
||||
@${ECHO_MSG} "====>"
|
||||
@${ECHO_MSG} "====> To enable css support, define WITH_CSS"
|
||||
@${ECHO_MSG} "====>"
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
.if defined(WITH_CSS)
|
||||
@${PERL} -pi.orig -e 's/(xineplug_inp_dvd_la_LDFLAGS = -avoid-version -module)/\1 -ldvdcss/' \
|
||||
${WRKSRC}/src/input/Makefile.am
|
||||
@${CP} -f ${WRKDIR}/${PLUGIN_CSS}/*.[ch] ${WRKSRC}/src/input
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1 +1,2 @@
|
||||
MD5 (xine-lib-0.9.1.tar.gz) = 927a7bad3246db23a6d9fce08307d200
|
||||
MD5 (xine-lib-0.9.2.tar.gz) = 5806ced82d5ccd95a94020e73152473c
|
||||
MD5 (dvd-plugin-0.4.tar.gz) = 3b3020690cf16ada39bcc5385cbfd338
|
||||
|
18
graphics/libxine/files/patch-src:liba52:Makefile.am
Normal file
18
graphics/libxine/files/patch-src:liba52:Makefile.am
Normal file
@ -0,0 +1,18 @@
|
||||
--- src/liba52/Makefile.am.orig Fri Oct 19 16:55:18 2001
|
||||
+++ src/liba52/Makefile.am Fri Oct 19 16:57:31 2001
|
||||
@@ -8,13 +8,9 @@
|
||||
|
||||
lib_LTLIBRARIES = xineplug_decode_a52.la
|
||||
|
||||
-xineplug_decode_a52_la_SOURCES = bitstream.c bit_allocate.c \
|
||||
- parse.c downmix.c imdct.c imdct_mlib.c \
|
||||
- xine_decoder.c
|
||||
+xineplug_decode_a52_la_SOURCES = xine_decoder.c
|
||||
+xineplug_decode_a52_la_LIBADD = -la52
|
||||
xineplug_decode_a52_la_LDFLAGS = -avoid-version -module
|
||||
-
|
||||
-noinst_HEADERS = a52.h a52_internal.h \
|
||||
- bitstream.h tables.h
|
||||
|
||||
##
|
||||
## Install header files (default=$includedir/xine)
|
13
graphics/libxine/files/patch-src:liba52:xine_decoder.c
Normal file
13
graphics/libxine/files/patch-src:liba52:xine_decoder.c
Normal file
@ -0,0 +1,13 @@
|
||||
--- src/liba52/xine_decoder.c.orig Fri Oct 19 17:55:03 2001
|
||||
+++ src/liba52/xine_decoder.c Fri Oct 19 17:55:31 2001
|
||||
@@ -31,8 +31,8 @@
|
||||
#include <fcntl.h>
|
||||
|
||||
#include "audio_out.h"
|
||||
-#include "a52.h"
|
||||
-#include "a52_internal.h"
|
||||
+#include <a52dec/a52.h>
|
||||
+#include <a52dec/a52_internal.h>
|
||||
#include "buffer.h"
|
||||
#include "xine_internal.h"
|
||||
#include "cpu_accel.h"
|
25
graphics/libxine/files/patch-src:libffmpeg:Makefile.am
Normal file
25
graphics/libxine/files/patch-src:libffmpeg:Makefile.am
Normal file
@ -0,0 +1,25 @@
|
||||
--- src/libffmpeg/Makefile.am.orig Fri Oct 19 21:19:47 2001
|
||||
+++ src/libffmpeg/Makefile.am Fri Oct 19 21:23:02 2001
|
||||
@@ -2,7 +2,6 @@
|
||||
## Process this file with automake to produce Makefile.in
|
||||
##
|
||||
|
||||
-SUBDIRS = libavcodec
|
||||
|
||||
CFLAGS = @GLOBAL_CFLAGS@
|
||||
|
||||
@@ -13,12 +12,9 @@
|
||||
lib_LTLIBRARIES = xineplug_decode_ff.la
|
||||
|
||||
xineplug_decode_ff_la_SOURCES = xine_decoder.c
|
||||
+xineplug_decode_ff_la_LIBADD = -lavcodec
|
||||
+xineplug_decode_ff_la_LDFLAGS = -avoid-version -module
|
||||
|
||||
-xineplug_decode_ff_la_LDFLAGS = \
|
||||
- $(top_builddir)/src/libffmpeg/libavcodec/libavcodec.la \
|
||||
- -avoid-version -module
|
||||
-
|
||||
-noinst_HEADERS = config.h
|
||||
|
||||
debug:
|
||||
@list='$(SUBDIRS)'; for subdir in $$list; do \
|
13
graphics/libxine/files/patch-src:libffmpeg:xine_decoder.c
Normal file
13
graphics/libxine/files/patch-src:libffmpeg:xine_decoder.c
Normal file
@ -0,0 +1,13 @@
|
||||
--- src/libffmpeg/xine_decoder.c.orig Fri Oct 19 21:17:15 2001
|
||||
+++ src/libffmpeg/xine_decoder.c Fri Oct 19 21:17:39 2001
|
||||
@@ -38,8 +38,8 @@
|
||||
#include "buffer.h"
|
||||
#include "metronom.h"
|
||||
|
||||
-#include "libavcodec/avcodec.h"
|
||||
-#include "libavcodec/dsputil.h"
|
||||
+#include <libavcodec/avcodec.h>
|
||||
+#include <libavcodec/dsputil.h>
|
||||
|
||||
/* now this is ripped of wine's vfw.h */
|
||||
typedef struct {
|
12
graphics/libxine/files/patch-src:xine-engine:Makefile.am
Normal file
12
graphics/libxine/files/patch-src:xine-engine:Makefile.am
Normal file
@ -0,0 +1,12 @@
|
||||
--- src/xine-engine/Makefile.am.orig Sun Oct 21 09:06:25 2001
|
||||
+++ src/xine-engine/Makefile.am Sun Oct 21 09:07:43 2001
|
||||
@@ -18,8 +18,7 @@
|
||||
-lm
|
||||
|
||||
libxine_la_LDFLAGS = \
|
||||
- -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
|
||||
- -release $(LT_RELEASE)
|
||||
+ -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
|
||||
|
||||
include_HEADERS = buffer.h metronom.h configfile.h \
|
||||
monitor.h cpu_accel.h attributes.h utils.h \
|
@ -1,11 +0,0 @@
|
||||
--- src/xine-engine/Makefile.in.orig Thu Sep 20 03:13:58 2001
|
||||
+++ src/xine-engine/Makefile.in Thu Sep 20 03:14:49 2001
|
||||
@@ -142,7 +142,7 @@
|
||||
libxine_la_LIBADD = cpu_accel.lo $(THREAD_LIBS) $(DYNAMIC_LD_LIBS) -lm
|
||||
|
||||
|
||||
-libxine_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) -release $(LT_RELEASE)
|
||||
+libxine_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
|
||||
|
||||
|
||||
include_HEADERS = buffer.h metronom.h configfile.h monitor.h cpu_accel.h attributes.h utils.h audio_out.h resample.h video_out.h xine_internal.h spu_decoder.h events.h
|
@ -4,3 +4,5 @@ mpeg elementary streams (audio/video only, e.g. mp3 files) and
|
||||
AVI files (using win32 codec dlls).
|
||||
|
||||
These are the libraries for the xine.
|
||||
|
||||
WWW: http://xine.sourceforge.net/
|
||||
|
@ -29,6 +29,8 @@ lib/xine/plugins/xineplug_ao_out_oss.la
|
||||
lib/xine/plugins/xineplug_ao_out_oss.so
|
||||
lib/xine/plugins/xineplug_decode_a52.la
|
||||
lib/xine/plugins/xineplug_decode_a52.so
|
||||
lib/xine/plugins/xineplug_decode_divx4.la
|
||||
lib/xine/plugins/xineplug_decode_divx4.so
|
||||
lib/xine/plugins/xineplug_decode_dts.la
|
||||
lib/xine/plugins/xineplug_decode_dts.so
|
||||
lib/xine/plugins/xineplug_decode_vfill.la
|
||||
@ -43,8 +45,12 @@ lib/xine/plugins/xineplug_decode_mpeg2.la
|
||||
lib/xine/plugins/xineplug_decode_mpeg2.so
|
||||
lib/xine/plugins/xineplug_decode_spu.la
|
||||
lib/xine/plugins/xineplug_decode_spu.so
|
||||
%%HAVE_VORBIS%%lib/xine/plugins/xineplug_decode_vorbis.la
|
||||
%%HAVE_VORBIS%%lib/xine/plugins/xineplug_decode_vorbis.so
|
||||
lib/xine/plugins/xineplug_decode_w32dll.la
|
||||
lib/xine/plugins/xineplug_decode_w32dll.so
|
||||
lib/xine/plugins/xineplug_dmx_asf.la
|
||||
lib/xine/plugins/xineplug_dmx_asf.so
|
||||
lib/xine/plugins/xineplug_dmx_avi.la
|
||||
lib/xine/plugins/xineplug_dmx_avi.so
|
||||
lib/xine/plugins/xineplug_dmx_mpeg.la
|
||||
@ -59,6 +65,8 @@ lib/xine/plugins/xineplug_dmx_mpeg_pes.la
|
||||
lib/xine/plugins/xineplug_dmx_mpeg_pes.so
|
||||
lib/xine/plugins/xineplug_dmx_mpeg_ts.la
|
||||
lib/xine/plugins/xineplug_dmx_mpeg_ts.so
|
||||
%%HAVE_OGG%%lib/xine/plugins/xineplug_dmx_ogg.la
|
||||
%%HAVE_OGG%%lib/xine/plugins/xineplug_dmx_ogg.so
|
||||
lib/xine/plugins/xineplug_dmx_qt.la
|
||||
lib/xine/plugins/xineplug_dmx_qt.so
|
||||
lib/xine/plugins/xineplug_inp_dvd.la
|
||||
@ -81,14 +89,15 @@ lib/xine/plugins/xineplug_vo_out_xshm.la
|
||||
lib/xine/plugins/xineplug_vo_out_xshm.so
|
||||
%%HAVE_LIBXV%%lib/xine/plugins/xineplug_vo_out_xv.la
|
||||
%%HAVE_LIBXV%%lib/xine/plugins/xineplug_vo_out_xv.so
|
||||
share/doc/xine/README.dxr3
|
||||
share/doc/xine/README.xinerc
|
||||
share/doc/xine/xine-lib-API/html/annotated.html
|
||||
share/doc/xine/xine-lib-API/html/doxygen.css
|
||||
share/doc/xine/xine-lib-API/html/doxygen.gif
|
||||
share/doc/xine/xine-lib-API/html/files.html
|
||||
share/doc/xine/xine-lib-API/html/functions.html
|
||||
share/doc/xine/xine-lib-API/html/globals.html
|
||||
share/doc/xine/xine-lib-API/html/group__audio__cap.html
|
||||
share/doc/xine/xine-lib-API/html/group__audio__group.html
|
||||
share/doc/xine/xine-lib-API/html/group__audio__prop.html
|
||||
share/doc/xine/xine-lib-API/html/group__autoplay__group.html
|
||||
share/doc/xine/xine-lib-API/html/group__browse__group.html
|
||||
share/doc/xine/xine-lib-API/html/group__build__info.html
|
||||
|
@ -6,20 +6,22 @@
|
||||
#
|
||||
|
||||
PORTNAME= xine
|
||||
PORTVERSION= 0.9.1
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.9.2
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://xine.sourceforge.net/files/ \
|
||||
${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
PKGNAMEPREFIX= lib
|
||||
DISTNAME= ${PORTNAME}-lib-${PORTVERSION}
|
||||
DISTFILES= ${PORTNAME}-lib-${PORTVERSION}${EXTRACT_SUFX}
|
||||
|
||||
MAINTAINER= nobutaka@nobutaka.com
|
||||
|
||||
LIB_DEPENDS= aa.1:${PORTSDIR}/graphics/aalib
|
||||
BUILD_DEPENDS= ${LOCALBASE}/lib/libavcodec.a:${PORTSDIR}/graphics/ffmpeg
|
||||
LIB_DEPENDS= a52.0:${PORTSDIR}/audio/liba52 \
|
||||
aa.1:${PORTSDIR}/graphics/aalib
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-lib-${PORTVERSION}
|
||||
USE_AUTOMAKE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_X_PREFIX= yes
|
||||
USE_IMLIB= yes
|
||||
@ -29,6 +31,7 @@ INSTALLS_SHLIB= yes
|
||||
|
||||
MAN1= xine-config.1
|
||||
MAN3= ao_driver_t.3 ao_functions_t.3 autoplay_group.3 \
|
||||
audio_cap.3 audio_group.3 audio_prop.3 \
|
||||
browse_group.3 build_info.3 cfg_data_t.3 config_group.3 \
|
||||
config_values_s.3 config_values_t.3 demux_strategy.3 \
|
||||
event_group.3 loadplugins_group.3 mrl_t.3 mrl_types.3 \
|
||||
@ -52,4 +55,45 @@ PLIST_SUB+= HAVE_ARTS=""
|
||||
PLIST_SUB+= HAVE_ARTS="@comment "
|
||||
.endif
|
||||
|
||||
.if exists(${LOCALBASE}/include/vorbis/codec.h)
|
||||
LIB_DEPENDS+= vorbis.0:${PORTSDIR}/audio/libvorbis
|
||||
|
||||
PLIST_SUB+= HAVE_VORBIS=""
|
||||
.else
|
||||
PLIST_SUB+= HAVE_VORBIS="@comment "
|
||||
.endif
|
||||
|
||||
.if exists(${LOCALBASE}/include/ogg/ogg.h)
|
||||
LIB_DEPENDS+= ogg.2:${PORTSDIR}/audio/libogg
|
||||
|
||||
PLIST_SUB+= HAVE_OGG=""
|
||||
.else
|
||||
PLIST_SUB+= HAVE_OGG="@comment "
|
||||
.endif
|
||||
|
||||
.if defined(WITH_CSS)
|
||||
# http://members.home.nl/mphm.janssen/linuxvideo/linuxvideo.html
|
||||
MASTER_SITES+= http://members.home.nl/mphm.janssen/files/
|
||||
DISTFILES+= ${PLUGIN_CSS}${EXTRACT_SUFX}
|
||||
|
||||
LIB_DEPENDS+= dvdcss.0:${PORTSDIR}/graphics/libdvdcss
|
||||
|
||||
PLUGIN_CSS= dvd-plugin-${PLUGIN_CSS_VERSION}
|
||||
PLUGIN_CSS_VERSION= 0.4
|
||||
.endif
|
||||
|
||||
pre-everything::
|
||||
.if !defined(WITH_CSS)
|
||||
@${ECHO_MSG} "====>"
|
||||
@${ECHO_MSG} "====> To enable css support, define WITH_CSS"
|
||||
@${ECHO_MSG} "====>"
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
.if defined(WITH_CSS)
|
||||
@${PERL} -pi.orig -e 's/(xineplug_inp_dvd_la_LDFLAGS = -avoid-version -module)/\1 -ldvdcss/' \
|
||||
${WRKSRC}/src/input/Makefile.am
|
||||
@${CP} -f ${WRKDIR}/${PLUGIN_CSS}/*.[ch] ${WRKSRC}/src/input
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1 +1,2 @@
|
||||
MD5 (xine-lib-0.9.1.tar.gz) = 927a7bad3246db23a6d9fce08307d200
|
||||
MD5 (xine-lib-0.9.2.tar.gz) = 5806ced82d5ccd95a94020e73152473c
|
||||
MD5 (dvd-plugin-0.4.tar.gz) = 3b3020690cf16ada39bcc5385cbfd338
|
||||
|
18
multimedia/libxine/files/patch-src:liba52:Makefile.am
Normal file
18
multimedia/libxine/files/patch-src:liba52:Makefile.am
Normal file
@ -0,0 +1,18 @@
|
||||
--- src/liba52/Makefile.am.orig Fri Oct 19 16:55:18 2001
|
||||
+++ src/liba52/Makefile.am Fri Oct 19 16:57:31 2001
|
||||
@@ -8,13 +8,9 @@
|
||||
|
||||
lib_LTLIBRARIES = xineplug_decode_a52.la
|
||||
|
||||
-xineplug_decode_a52_la_SOURCES = bitstream.c bit_allocate.c \
|
||||
- parse.c downmix.c imdct.c imdct_mlib.c \
|
||||
- xine_decoder.c
|
||||
+xineplug_decode_a52_la_SOURCES = xine_decoder.c
|
||||
+xineplug_decode_a52_la_LIBADD = -la52
|
||||
xineplug_decode_a52_la_LDFLAGS = -avoid-version -module
|
||||
-
|
||||
-noinst_HEADERS = a52.h a52_internal.h \
|
||||
- bitstream.h tables.h
|
||||
|
||||
##
|
||||
## Install header files (default=$includedir/xine)
|
13
multimedia/libxine/files/patch-src:liba52:xine_decoder.c
Normal file
13
multimedia/libxine/files/patch-src:liba52:xine_decoder.c
Normal file
@ -0,0 +1,13 @@
|
||||
--- src/liba52/xine_decoder.c.orig Fri Oct 19 17:55:03 2001
|
||||
+++ src/liba52/xine_decoder.c Fri Oct 19 17:55:31 2001
|
||||
@@ -31,8 +31,8 @@
|
||||
#include <fcntl.h>
|
||||
|
||||
#include "audio_out.h"
|
||||
-#include "a52.h"
|
||||
-#include "a52_internal.h"
|
||||
+#include <a52dec/a52.h>
|
||||
+#include <a52dec/a52_internal.h>
|
||||
#include "buffer.h"
|
||||
#include "xine_internal.h"
|
||||
#include "cpu_accel.h"
|
25
multimedia/libxine/files/patch-src:libffmpeg:Makefile.am
Normal file
25
multimedia/libxine/files/patch-src:libffmpeg:Makefile.am
Normal file
@ -0,0 +1,25 @@
|
||||
--- src/libffmpeg/Makefile.am.orig Fri Oct 19 21:19:47 2001
|
||||
+++ src/libffmpeg/Makefile.am Fri Oct 19 21:23:02 2001
|
||||
@@ -2,7 +2,6 @@
|
||||
## Process this file with automake to produce Makefile.in
|
||||
##
|
||||
|
||||
-SUBDIRS = libavcodec
|
||||
|
||||
CFLAGS = @GLOBAL_CFLAGS@
|
||||
|
||||
@@ -13,12 +12,9 @@
|
||||
lib_LTLIBRARIES = xineplug_decode_ff.la
|
||||
|
||||
xineplug_decode_ff_la_SOURCES = xine_decoder.c
|
||||
+xineplug_decode_ff_la_LIBADD = -lavcodec
|
||||
+xineplug_decode_ff_la_LDFLAGS = -avoid-version -module
|
||||
|
||||
-xineplug_decode_ff_la_LDFLAGS = \
|
||||
- $(top_builddir)/src/libffmpeg/libavcodec/libavcodec.la \
|
||||
- -avoid-version -module
|
||||
-
|
||||
-noinst_HEADERS = config.h
|
||||
|
||||
debug:
|
||||
@list='$(SUBDIRS)'; for subdir in $$list; do \
|
13
multimedia/libxine/files/patch-src:libffmpeg:xine_decoder.c
Normal file
13
multimedia/libxine/files/patch-src:libffmpeg:xine_decoder.c
Normal file
@ -0,0 +1,13 @@
|
||||
--- src/libffmpeg/xine_decoder.c.orig Fri Oct 19 21:17:15 2001
|
||||
+++ src/libffmpeg/xine_decoder.c Fri Oct 19 21:17:39 2001
|
||||
@@ -38,8 +38,8 @@
|
||||
#include "buffer.h"
|
||||
#include "metronom.h"
|
||||
|
||||
-#include "libavcodec/avcodec.h"
|
||||
-#include "libavcodec/dsputil.h"
|
||||
+#include <libavcodec/avcodec.h>
|
||||
+#include <libavcodec/dsputil.h>
|
||||
|
||||
/* now this is ripped of wine's vfw.h */
|
||||
typedef struct {
|
12
multimedia/libxine/files/patch-src:xine-engine:Makefile.am
Normal file
12
multimedia/libxine/files/patch-src:xine-engine:Makefile.am
Normal file
@ -0,0 +1,12 @@
|
||||
--- src/xine-engine/Makefile.am.orig Sun Oct 21 09:06:25 2001
|
||||
+++ src/xine-engine/Makefile.am Sun Oct 21 09:07:43 2001
|
||||
@@ -18,8 +18,7 @@
|
||||
-lm
|
||||
|
||||
libxine_la_LDFLAGS = \
|
||||
- -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
|
||||
- -release $(LT_RELEASE)
|
||||
+ -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
|
||||
|
||||
include_HEADERS = buffer.h metronom.h configfile.h \
|
||||
monitor.h cpu_accel.h attributes.h utils.h \
|
@ -1,11 +0,0 @@
|
||||
--- src/xine-engine/Makefile.in.orig Thu Sep 20 03:13:58 2001
|
||||
+++ src/xine-engine/Makefile.in Thu Sep 20 03:14:49 2001
|
||||
@@ -142,7 +142,7 @@
|
||||
libxine_la_LIBADD = cpu_accel.lo $(THREAD_LIBS) $(DYNAMIC_LD_LIBS) -lm
|
||||
|
||||
|
||||
-libxine_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) -release $(LT_RELEASE)
|
||||
+libxine_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
|
||||
|
||||
|
||||
include_HEADERS = buffer.h metronom.h configfile.h monitor.h cpu_accel.h attributes.h utils.h audio_out.h resample.h video_out.h xine_internal.h spu_decoder.h events.h
|
@ -4,3 +4,5 @@ mpeg elementary streams (audio/video only, e.g. mp3 files) and
|
||||
AVI files (using win32 codec dlls).
|
||||
|
||||
These are the libraries for the xine.
|
||||
|
||||
WWW: http://xine.sourceforge.net/
|
||||
|
@ -29,6 +29,8 @@ lib/xine/plugins/xineplug_ao_out_oss.la
|
||||
lib/xine/plugins/xineplug_ao_out_oss.so
|
||||
lib/xine/plugins/xineplug_decode_a52.la
|
||||
lib/xine/plugins/xineplug_decode_a52.so
|
||||
lib/xine/plugins/xineplug_decode_divx4.la
|
||||
lib/xine/plugins/xineplug_decode_divx4.so
|
||||
lib/xine/plugins/xineplug_decode_dts.la
|
||||
lib/xine/plugins/xineplug_decode_dts.so
|
||||
lib/xine/plugins/xineplug_decode_vfill.la
|
||||
@ -43,8 +45,12 @@ lib/xine/plugins/xineplug_decode_mpeg2.la
|
||||
lib/xine/plugins/xineplug_decode_mpeg2.so
|
||||
lib/xine/plugins/xineplug_decode_spu.la
|
||||
lib/xine/plugins/xineplug_decode_spu.so
|
||||
%%HAVE_VORBIS%%lib/xine/plugins/xineplug_decode_vorbis.la
|
||||
%%HAVE_VORBIS%%lib/xine/plugins/xineplug_decode_vorbis.so
|
||||
lib/xine/plugins/xineplug_decode_w32dll.la
|
||||
lib/xine/plugins/xineplug_decode_w32dll.so
|
||||
lib/xine/plugins/xineplug_dmx_asf.la
|
||||
lib/xine/plugins/xineplug_dmx_asf.so
|
||||
lib/xine/plugins/xineplug_dmx_avi.la
|
||||
lib/xine/plugins/xineplug_dmx_avi.so
|
||||
lib/xine/plugins/xineplug_dmx_mpeg.la
|
||||
@ -59,6 +65,8 @@ lib/xine/plugins/xineplug_dmx_mpeg_pes.la
|
||||
lib/xine/plugins/xineplug_dmx_mpeg_pes.so
|
||||
lib/xine/plugins/xineplug_dmx_mpeg_ts.la
|
||||
lib/xine/plugins/xineplug_dmx_mpeg_ts.so
|
||||
%%HAVE_OGG%%lib/xine/plugins/xineplug_dmx_ogg.la
|
||||
%%HAVE_OGG%%lib/xine/plugins/xineplug_dmx_ogg.so
|
||||
lib/xine/plugins/xineplug_dmx_qt.la
|
||||
lib/xine/plugins/xineplug_dmx_qt.so
|
||||
lib/xine/plugins/xineplug_inp_dvd.la
|
||||
@ -81,14 +89,15 @@ lib/xine/plugins/xineplug_vo_out_xshm.la
|
||||
lib/xine/plugins/xineplug_vo_out_xshm.so
|
||||
%%HAVE_LIBXV%%lib/xine/plugins/xineplug_vo_out_xv.la
|
||||
%%HAVE_LIBXV%%lib/xine/plugins/xineplug_vo_out_xv.so
|
||||
share/doc/xine/README.dxr3
|
||||
share/doc/xine/README.xinerc
|
||||
share/doc/xine/xine-lib-API/html/annotated.html
|
||||
share/doc/xine/xine-lib-API/html/doxygen.css
|
||||
share/doc/xine/xine-lib-API/html/doxygen.gif
|
||||
share/doc/xine/xine-lib-API/html/files.html
|
||||
share/doc/xine/xine-lib-API/html/functions.html
|
||||
share/doc/xine/xine-lib-API/html/globals.html
|
||||
share/doc/xine/xine-lib-API/html/group__audio__cap.html
|
||||
share/doc/xine/xine-lib-API/html/group__audio__group.html
|
||||
share/doc/xine/xine-lib-API/html/group__audio__prop.html
|
||||
share/doc/xine/xine-lib-API/html/group__autoplay__group.html
|
||||
share/doc/xine/xine-lib-API/html/group__browse__group.html
|
||||
share/doc/xine/xine-lib-API/html/group__build__info.html
|
||||
|
Loading…
Reference in New Issue
Block a user