MFH: r466447 r466567

Fixed outdated dependency for net/rubygem-gitaly.

Reviewed by:	tz (mentor)
Approved by:	tz (mentor)
Differential Revision:	https://reviews.freebsd.org/D14944

Update to version 0.82.0 which is required for gitlab 10.5.x.

Reviewed by:	mat, tz (mentor)
Approved by:	tz (mentor)
Differential Revision:	https://reviews.freebsd.org/D14867

Approved by:	ports-secteam (eadler)
This commit is contained in:
Matthias Fechner 2018-04-18 17:14:11 +00:00
parent 2b56886dc0
commit 04cb69df0d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/branches/2018Q2/; revision=467719
7 changed files with 177 additions and 27 deletions

View File

@ -1,11 +1,8 @@
# $FreeBSD$
PORTNAME= gitaly
DISTVERSIONPREFIX= v
DISTVERSION= 0.21.2
PORTREVISION= 1
DISTVERSION= 0.82.0
CATEGORIES= devel
MASTER_SITES= https://gitlab.com/gitlab-org/${PORTNAME}/repository/archive.tar.gz?ref=${DISTVERSIONPREFIX}${PORTVERSION}&dummy=/
MAINTAINER= idefix@fechner.net
COMMENT= Smart reverse proxy for GitLab
@ -13,24 +10,48 @@ COMMENT= Smart reverse proxy for GitLab
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= go>=1.8:lang/go
# define dependencies that are required for build and run under MY_DEPENDS
MY_DEPENDS= git>=2.14.3:devel/git \
rubygem-github-linguist47>=4.7.0:textproc/rubygem-github-linguist47 \
rubygem-bundler>0:sysutils/rubygem-bundler \
rubygem-gitlab-markup>=1.6.2:textproc/rubygem-gitlab-markup \
rubygem-gitaly-proto083>=0.83.0:net/rubygem-gitaly-proto083 \
rubygem-activesupport50>=5.0.2:devel/rubygem-activesupport50 \
rubygem-rdoc>=4.2:devel/rubygem-rdoc \
rubygem-gollum-lib-gitlab>=4.2.0:www/rubygem-gollum-lib-gitlab \
rubygem-gollum-rugged_adapter>=0.4.4:www/rubygem-gollum-rugged_adapter \
rubygem-grpc>=1.8.0:net/rubygem-grpc \
rubygem-google-protobuf351>=3.5.1:devel/rubygem-google-protobuf351
BUILD_DEPENDS= go>=1.8:lang/go \
gem:devel/ruby-gems \
rubygem-bundler>0:sysutils/rubygem-bundler \
${MY_DEPENDS}
RUN_DEPENDS= ${MY_DEPENDS} \
gitlab-shell>=6.0.3:devel/gitlab-shell
USES= gmake
USE_RUBY= yes
post-extract:
${MV} ${WRKDIR}/${DISTNAME}-* ${WRKDIR}/${DISTNAME}
USE_GITLAB= yes
GL_ACCOUNT= gitlab-org
# Find this here: https://gitlab.com/gitlab-org/gitaly/tags
GL_COMMIT= 8f7e18974599c47f542e083d56faf45af106788b
post-patch:
${MV} ${WRKDIR}/${DISTNAME}/config.toml.example ${WRKDIR}/${DISTNAME}/config.toml.sample
${MV} ${WRKSRC}/config.toml.example ${WRKSRC}/config.toml.sample
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}
${MKDIR} ${STAGEDIR}${DATADIR}/bin
$(RM) -f ${WRKSRC}/ruby/Gemfile.orig
(cd ${WRKSRC}/_build/bin/ && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/bin && \
cd ${WRKSRC} && ${COPYTREE_SHARE} config.toml.sample ${STAGEDIR}${DATADIR})
cd ${WRKSRC} && ${COPYTREE_SHARE} config.toml.sample ${STAGEDIR}${DATADIR}) && \
cd ${WRKSRC}/ruby && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/ruby
post-install:
${STRIP_CMD} ${STAGEDIR}${DATADIR}/bin/gitaly
${STRIP_CMD} ${STAGEDIR}${DATADIR}/bin/gitaly-ssh
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1505982310
SHA256 (gitaly-v0.21.2.tar.gz) = badbf17917341993f4ce670ef111a2f0e5e40fb737c9bf5fab72c9538e0b07d6
SIZE (gitaly-v0.21.2.tar.gz) = 2027704
TIMESTAMP = 1522736881
SHA256 (gitlab-org-gitaly-8f7e18974599c47f542e083d56faf45af106788b_GL0.tar.gz) = 22f2b66067ebdb87907b6cb1698ee471dbbe1beecaa3208a9877033c110a9ebb
SIZE (gitlab-org-gitaly-8f7e18974599c47f542e083d56faf45af106788b_GL0.tar.gz) = 3572308

View File

@ -0,0 +1,20 @@
--- Makefile.orig 2018-02-08 14:44:53 UTC
+++ Makefile
@@ -11,7 +11,7 @@ INSTALL_DEST_DIR := $(DESTDIR)$(PREFIX)/
COVERAGE_DIR := $(TARGET_DIR)/cover
ASSEMBLY_ROOT := $(TARGET_DIR)/assembly
export GITALY_TEST_RUBY_DIR := $(BUILD_DIR)/ruby
-BUNDLE_FLAGS ?= --deployment
+BUNDLE_FLAGS ?= --local
BUILDTIME = $(shell date -u +%Y%m%d.%H%M%S)
VERSION_PREFIXED = $(shell git describe)
@@ -56,7 +56,7 @@ build: .ruby-bundle $(TARGET_SETUP)
cp $(foreach cmd,$(COMMANDS),$(BIN_BUILD_DIR)/$(cmd)) $(BUILD_DIR)/
.ruby-bundle: ruby/Gemfile.lock ruby/Gemfile
- cd ruby && bundle install $(BUNDLE_FLAGS)
+ cd ruby && rm Gemfile.lock && bundle install $(BUNDLE_FLAGS)
touch $@
# TODO: confirm what references this target? Omnibus? Source installs?

View File

@ -1,21 +1,23 @@
--- config.toml.example.orig 2017-10-28 10:50:48.245547000 +0200
+++ config.toml.example 2017-10-28 10:56:00.467310000 +0200
@@ -1,6 +1,6 @@
--- config.toml.example.orig 2018-02-08 14:44:53 UTC
+++ config.toml.example
@@ -1,9 +1,9 @@
# Example Gitaly configuration file
-socket_path = "/home/git/gitlab/tmp/sockets/private/gitaly.socket"
+socket_path = "/usr/local/www/gitlab/tmp/sockets/private/gitaly.socket"
# The directory where Gitaly's executables are stored
-bin_dir = "/home/git/gitaly"
+bin_dir = "/usr/local/share/gitaly/bin/"
# # Optional: listen on a TCP socket. This is insecure (no authentication)
# listen_addr = "localhost:9999"
@@ -10,14 +10,20 @@
# prometheus_listen_addr = "localhost:9236"
@@ -14,12 +14,12 @@ bin_dir = "/home/git/gitaly"
#
-# # Git executable settings
# # Git executable settings
-# [git]
-# bin_path = "/usr/bin/git"
+# Git executable settings
+[git]
+bin_path = "/usr/local/bin/git"
@ -24,12 +26,23 @@
-path = "/home/git/repositories"
+path = "/usr/home/git/repositories"
+[gitaly-ruby]
+dir = "/usr/local/bin/ruby"
+
+[gitlab-shell]
+dir = "/usr/local/share/gitlab-shell/bin/gitlab-shell"
+
# # You can optionally configure more storages for this Gitaly instance to serve up
#
# [[storage]]
@@ -40,7 +40,7 @@ path = "/home/git/repositories"
[gitaly-ruby]
# The directory where gitaly-ruby is installed
-dir = "/home/git/gitaly/ruby"
+dir = "/usr/local/share/gitaly/ruby"
# # Gitaly-ruby resident set size (RSS) that triggers a memory restart (bytes)
# max_rss = 300000000
@@ -53,7 +53,7 @@ dir = "/home/git/gitaly/ruby"
[gitlab-shell]
# The directory where gitlab-shell is installed
-dir = "/home/git/gitlab-shell"
+dir = "/usr/local/share/gitlab-shell/bin"
# # You can adjust the concurrency of each RPC endpoint
# [[concurrency]]

View File

@ -0,0 +1,10 @@
--- ruby/Gemfile.orig 2018-02-25 18:31:26 UTC
+++ ruby/Gemfile
@@ -12,7 +12,3 @@ gem 'grpc', '~> 1.8.0'
# Locked until https://github.com/google/protobuf/issues/4210 is closed
gem 'google-protobuf', '= 3.5.1'
-group :development, :test do
- gem 'gitlab-styles', '~> 2.0.0', require: false
- gem 'rspec', require: false
-end

View File

@ -1,2 +1,88 @@
%%DATADIR%%/ruby/Gemfile
%%DATADIR%%/ruby/Gemfile.lock
%%DATADIR%%/ruby/README.md
@(,,555) %%DATADIR%%/ruby/bin/gitaly-ruby
@(,,555) %%DATADIR%%/ruby/bin/ruby-cd
%%DATADIR%%/ruby/lib/gitaly_server.rb
%%DATADIR%%/ruby/lib/gitaly_server/blob_service.rb
%%DATADIR%%/ruby/lib/gitaly_server/client.rb
%%DATADIR%%/ruby/lib/gitaly_server/commit_service.rb
%%DATADIR%%/ruby/lib/gitaly_server/conflicts_service.rb
%%DATADIR%%/ruby/lib/gitaly_server/diff_service.rb
%%DATADIR%%/ruby/lib/gitaly_server/operations_service.rb
%%DATADIR%%/ruby/lib/gitaly_server/ref_service.rb
%%DATADIR%%/ruby/lib/gitaly_server/remote_service.rb
%%DATADIR%%/ruby/lib/gitaly_server/repository_service.rb
%%DATADIR%%/ruby/lib/gitaly_server/utils.rb
%%DATADIR%%/ruby/lib/gitaly_server/wiki_service.rb
%%DATADIR%%/ruby/lib/gitlab/config.rb
%%DATADIR%%/ruby/lib/gitlab/git.rb
%%DATADIR%%/ruby/lib/gitlab/git/gitaly_remote_repository.rb
%%DATADIR%%/ruby/lib/gitlab/git_logger.rb
%%DATADIR%%/ruby/lib/gitlab/gitaly_client.rb
%%DATADIR%%/ruby/lib/gitlab/gollum.rb
%%DATADIR%%/ruby/lib/gitlab/rails_logger.rb
%%DATADIR%%/ruby/spec/gitaly/ref_service_spec.rb
%%DATADIR%%/ruby/spec/gitaly/repository_service_spec.rb
%%DATADIR%%/ruby/spec/integration_helper.rb
%%DATADIR%%/ruby/spec/lib/gitaly_server/utils_spec.rb
%%DATADIR%%/ruby/spec/lib/gitlab/config_spec.rb
%%DATADIR%%/ruby/spec/spec_helper.rb
%%DATADIR%%/ruby/spec/test_repo_helper.rb
%%DATADIR%%/ruby/vendor/gitlab_git/ORIGIN
%%DATADIR%%/ruby/vendor/gitlab_git/REVISION
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/encoding_helper.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/attributes_at_ref_parser.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/attributes_parser.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/blame.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/blob.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/blob_snippet.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/branch.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/commit.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/commit_stats.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/compare.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/conflict/file.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/conflict/parser.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/conflict/resolution.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/conflict/resolver.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/diff.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/diff_collection.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/env.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/gitlab_projects.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/gitmodules_parser.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/hook.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/hooks_service.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/index.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/info_attributes.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/lfs_changes.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/lfs_pointer_file.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/operation_service.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/path_helper.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/popen.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/ref.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/remote_mirror.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/remote_repository.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/repository.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/repository_mirroring.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/rev_list.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/storage.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/storage/checker.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/storage/circuit_breaker.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/storage/circuit_breaker_settings.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/storage/failure_info.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/storage/forked_storage_check.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/storage/health.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/storage/null_circuit_breaker.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/tag.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/tree.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/user.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/util.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/wiki.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/wiki_file.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/wiki_page.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/wiki_page_version.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/utils/strong_memoize.rb
@(,,555) %%DATADIR%%/bin/gitaly
@(,,555) %%DATADIR%%/bin/gitaly-ssh
@sample %%DATADIR%%/config.toml.sample

View File

@ -15,7 +15,7 @@ BUILD_DEPENDS= rubygem-bundler>=1.12:sysutils/rubygem-bundler \
rubygem-rake>=10.0:devel/rubygem-rake
RUN_DEPENDS= rubygem-google-protobuf>=3.4.0.2:devel/rubygem-google-protobuf \
rubygem-grpc>=1.0:net/rubygem-grpc \
gitaly>=0.11.2:devel/gitaly
gitaly>=0.82.0:devel/gitaly
NO_ARCH= yes
USES= gem