Update to 20200117
This commit is contained in:
parent
d29ec0ff2b
commit
04887febb7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=524038
@ -2,11 +2,10 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= pytsk
|
||||
PORTVERSION= 20190507
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 20200117
|
||||
CATEGORIES= sysutils security devel python
|
||||
MASTER_SITES= CHEESESHOP \
|
||||
https://github.com/py4n6/pytsk/releases/download/${PORTVERSION}/
|
||||
MASTER_SITES= CHEESESHOP
|
||||
# https://github.com/py4n6/pytsk/releases/download/${PORTVERSION}/
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
DISTNAME= ${PORTNAME}3-${PORTVERSION}
|
||||
|
||||
@ -19,7 +18,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
LIB_DEPENDS= libtalloc.so:devel/talloc \
|
||||
libtsk.so:sysutils/sleuthkit
|
||||
|
||||
USES= python
|
||||
USES= python:3.5+
|
||||
USE_PYTHON= distutils autoplist
|
||||
|
||||
post-extract:
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1557324063
|
||||
SHA256 (pytsk3-20190507.tar.gz) = f560b2269e1942884959ac60fcb9a55452f98693abc437fd806c403f64497ea5
|
||||
SIZE (pytsk3-20190507.tar.gz) = 3153833
|
||||
TIMESTAMP = 1579428967
|
||||
SHA256 (pytsk3-20200117.tar.gz) = 56177164a358e98baa258296aa2e9a509304dc8dab053abac347435a0978d962
|
||||
SIZE (pytsk3-20200117.tar.gz) = 3060827
|
||||
|
@ -1,8 +1,8 @@
|
||||
# Unbundle sleuthkit and talloc
|
||||
|
||||
--- setup.py.orig 2019-03-04 18:14:03 UTC
|
||||
--- setup.py.orig 2020-01-17 19:49:31 UTC
|
||||
+++ setup.py
|
||||
@@ -232,9 +232,9 @@ class BuildExtCommand(build_ext):
|
||||
@@ -245,9 +245,9 @@ class BuildExtCommand(build_ext):
|
||||
def run(self):
|
||||
compiler = new_compiler(compiler=self.compiler)
|
||||
# pylint: disable=attribute-defined-outside-init
|
||||
@ -14,7 +14,7 @@
|
||||
|
||||
if not os.access("pytsk3.c", os.R_OK):
|
||||
# Generate the Python binding code (pytsk3.c).
|
||||
@@ -404,7 +404,7 @@ class ProjectBuilder(object):
|
||||
@@ -409,7 +409,7 @@ class ProjectBuilder(object):
|
||||
self._argv = argv
|
||||
|
||||
# The path to the sleuthkit/tsk directory.
|
||||
@ -23,7 +23,7 @@
|
||||
|
||||
# Paths under the sleuthkit/tsk directory which contain files we need
|
||||
# to compile.
|
||||
@@ -414,13 +414,13 @@ class ProjectBuilder(object):
|
||||
@@ -418,13 +418,13 @@ class ProjectBuilder(object):
|
||||
# The args for the extension builder.
|
||||
self.extension_args = {
|
||||
"define_macros": [],
|
||||
|
Loading…
Reference in New Issue
Block a user