It's some extra image loader plugins for Imlib 2.

PR:		ports/31119
Submitted by:	Jeremy Norris <ishmael27@home.com>
This commit is contained in:
Vanilla I. Shu 2001-11-04 10:18:50 +00:00
parent b570bb34da
commit 047dea54fe
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=49561
9 changed files with 158 additions and 0 deletions

View File

@ -108,6 +108,7 @@
SUBDIR += imanager
SUBDIR += imlib
SUBDIR += imlib2
SUBDIR += imlib2_loaders
SUBDIR += ipe
SUBDIR += isreal
SUBDIR += iview

View File

@ -0,0 +1,25 @@
# New ports collection makefile for: imlib2_loaders
# Date created: 7 Oct 2001
# Whom: Jeremy Norris <ishmael27@home.com>
#
# $FreeBSD$
#
PORTNAME= imlib2_loaders
PORTVERSION= 1.0.4
CATEGORIES= graphics
MASTER_SITES= http://www.ny.us.rasterman.com/files/ \
${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= enlightenment
MAINTAINER= ishmael27@home.com
LIB_DEPENDS= Imlib2.1:${PORTSDIR}/graphics/imlib2 \
edb.1:${PORTSDIR}/databases/edb
USE_X_PREFIX= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (imlib2_loaders-1.0.4.tar.gz) = 592035865bd4026f4e3c12a26ace1d59

View File

@ -0,0 +1,11 @@
--- Makefile.in.orig Fri Sep 21 13:40:16 2001
+++ Makefile.in Sun Oct 7 18:54:58 2001
@@ -81,7 +81,7 @@
# A list of all the files in the current directory which can be regenerated
MAINTAINERCLEANFILES = Makefile.in imlib2_loaders.spec
-SUBDIRS = src libltdl
+SUBDIRS = src
CFLAGS_EXTRA = -I$(includedir) -I$(top_srcdir) -I$(top_srcdir)/src

View File

@ -0,0 +1,96 @@
--- configure.orig Fri Sep 21 13:39:55 2001
+++ configure Sun Oct 7 18:56:43 2001
@@ -888,16 +888,6 @@
fi
- case "$enable_ltdl_convenience" in
- no) { echo "configure: error: this package needs a convenience libltdl" 1>&2; exit 1; } ;;
- "") enable_ltdl_convenience=yes
- ac_configure_args="$ac_configure_args --enable-ltdl-convenience" ;;
- esac
- LIBLTDL='${top_builddir}/''libltdl'/libltdlc.la
- INCLTDL='-I${top_srcdir}/''libltdl'
-
-subdirs="libltdl"
-
# Extract the first word of "gcc", so it can be a program name with args.
set dummy gcc; ac_word=$2
@@ -3429,76 +3419,6 @@
esac
done
- for ac_config_dir in libltdl; do
-
- # Do not complain, so a configure script can configure whichever
- # parts of a large source tree are present.
- if test ! -d $srcdir/$ac_config_dir; then
- continue
- fi
-
- echo configuring in $ac_config_dir
-
- case "$srcdir" in
- .) ;;
- *)
- if test -d ./$ac_config_dir || mkdir ./$ac_config_dir; then :;
- else
- { echo "configure: error: can not create `pwd`/$ac_config_dir" 1>&2; exit 1; }
- fi
- ;;
- esac
-
- ac_popdir=`pwd`
- cd $ac_config_dir
-
- # A "../" for each directory in /$ac_config_dir.
- ac_dots=`echo $ac_config_dir|sed -e 's%^\./%%' -e 's%[^/]$%&/%' -e 's%[^/]*/%../%g'`
-
- case "$srcdir" in
- .) # No --srcdir option. We are building in place.
- ac_sub_srcdir=$srcdir ;;
- /*) # Absolute path.
- ac_sub_srcdir=$srcdir/$ac_config_dir ;;
- *) # Relative path.
- ac_sub_srcdir=$ac_dots$srcdir/$ac_config_dir ;;
- esac
-
- # Check for guested configure; otherwise get Cygnus style configure.
- if test -f $ac_sub_srcdir/configure; then
- ac_sub_configure=$ac_sub_srcdir/configure
- elif test -f $ac_sub_srcdir/configure.in; then
- ac_sub_configure=$ac_configure
- else
- echo "configure: warning: no configuration information is in $ac_config_dir" 1>&2
- ac_sub_configure=
- fi
-
- # The recursion is here.
- if test -n "$ac_sub_configure"; then
-
- # Make the cache file name correct relative to the subdirectory.
- case "$cache_file" in
- /*) ac_sub_cache_file=$cache_file ;;
- *) # Relative path.
- ac_sub_cache_file="$ac_dots$cache_file" ;;
- esac
- case "$ac_given_INSTALL" in
- [/$]*) INSTALL="$ac_given_INSTALL" ;;
- *) INSTALL="$ac_dots$ac_given_INSTALL" ;;
- esac
-
- echo "running ${CONFIG_SHELL-/bin/sh} $ac_sub_configure $ac_sub_configure_args --cache-file=$ac_sub_cache_file --srcdir=$ac_sub_srcdir"
- # The eval makes quoting arguments work.
- if eval ${CONFIG_SHELL-/bin/sh} $ac_sub_configure $ac_sub_configure_args --cache-file=$ac_sub_cache_file --srcdir=$ac_sub_srcdir
- then :
- else
- { echo "configure: error: $ac_sub_configure failed for $ac_config_dir" 1>&2; exit 1; }
- fi
- fi
-
- cd $ac_popdir
- done
fi

View File

@ -0,0 +1,19 @@
--- src/Makefile.in.orig Fri Sep 21 13:40:16 2001
+++ src/Makefile.in Sun Oct 7 18:55:39 2001
@@ -268,13 +268,12 @@
|| cp -p $$d/$$file $(distdir)/$$file || :; \
fi; \
done
-loader_db.lo loader_db.o : loader_db.c ../config.h common.h image.h \
- ../libltdl/ltdl.h
+loader_db.lo loader_db.o : loader_db.c ../config.h common.h image.h
loader_xcf.lo loader_xcf.o : loader_xcf.c ../config.h common.h image.h \
- ../libltdl/ltdl.h color_values.h
+ color_values.h
loader_xcf_pixelfuncs.lo loader_xcf_pixelfuncs.o : \
loader_xcf_pixelfuncs.c ../config.h common.h image.h \
- ../libltdl/ltdl.h color_values.h
+ color_values.h
info-am:
info: info-am

View File

@ -0,0 +1 @@
Extra image loader plugins for Imlib 2

View File

@ -0,0 +1,2 @@
This package contains image loader plugins for Imlib 2 that are not dis-
tributed together with the Imlib 2 package itself.

View File

@ -0,0 +1,2 @@
lib/loaders/image/db.so
lib/loaders/image/xcf.so