dns/knot2: Update to 2.6.5

Additional port changes:
* Changed to DISTVERSION
* Replaced the second MASTER_SITES
* Added dependency to LIB_DEPENDS
* Removed USES=autoreconf
* Added USES=ncurses
* Removed extra patches

PR:		225957
Submitted by:	Leo Vandewoestijne <freebsd@dns-lab.com> (mantainer)
Approved by:	tcberner (mentor, implicit)
This commit is contained in:
Yuri Victorovich 2018-02-24 08:14:56 +00:00
parent bade7f6a6e
commit 039abeda42
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=462774
6 changed files with 11 additions and 57 deletions

View File

@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= knot
PORTVERSION= 2.6.4
DISTVERSION= 2.6.5
CATEGORIES= dns ipv6
MASTER_SITES= https://secure.nic.cz/files/knot-dns/ \
http://dns-lab.com/downloads/knot-dns/
https://dns.company/downloads/knot-dns/
PKGNAMESUFFIX= 2
MAINTAINER= freebsd@dns-lab.com
@ -14,23 +14,22 @@ COMMENT= High performance authoritative-only DNS server
LICENSE= GPLv3
LIB_DEPENDS= libgnutls.so:security/gnutls \
libidn2.so:dns/libidn2 \
liblmdb.so:databases/lmdb \
libnettle.so:security/nettle \
liburcu.so:sysutils/liburcu
CONFLICTS= knot-1.* knot1-[0-6].*
USES= autoreconf alias compiler:c11 libedit libtool localbase pkgconfig python shebangfix tar:xz
SHEBANG_FILES= src/utils/pykeymgr/pykeymgr.in
USE_LDCONFIG= yes
USES= alias compiler:c11 libedit libtool localbase ncurses pkgconfig python shebangfix tar:xz
GNU_CONFIGURE= yes
SHEBANG_FILES= src/utils/pykeymgr/pykeymgr.in
CONFIGURE_ARGS= --with-rundir=/var/run/knot \
--with-storage=/var/db/knot \
--with-pkgconfigdir=${PREFIX}/libdata/pkgconfig \
--enable-recvmmsg=no
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
USE_RC_SUBR= ${PORTNAME}
SUB_FILES= pkg-message
@ -60,13 +59,6 @@ FASTPARSER_CONFIGURE_ENABLE= fastparser
IDN_CONFIGURE_WITH= libidn
IDN_LIB_DEPENDS= libidn.so:dns/libidn
# starting at 2.6.5 this block will already be absolete
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-configure.ac
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-src_Makefile.am
.endif
post-patch:
@${REINPLACE_CMD} 's|$$(INSTALL) -d $$(DESTDIR)/\@run_dir\@|#$$(INSTALL) -d $$(DESTDIR)/\@run_dir\@|' \
${WRKSRC}/src/Makefile.in
@ -80,5 +72,4 @@ post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}/
#.include <bsd.port.mk>
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1517244504
SHA256 (knot-2.6.4.tar.xz) = 1d0d37b5047ecd554d927519d5565c29c1ba9b501c100eb5f3a5af184d75386a
SIZE (knot-2.6.4.tar.xz) = 1116928
TIMESTAMP = 1518797968
SHA256 (knot-2.6.5.tar.xz) = 33cd676706e2baeb37cf3879ccbc91a1e1cd1ee5d7a082adff4d1e753ce49d46
SIZE (knot-2.6.5.tar.xz) = 1118084

View File

@ -1,24 +0,0 @@
--- configure.ac.orig 2018-01-29 16:11:32 UTC
+++ configure.ac
@@ -501,19 +501,11 @@ AC_LINK_IFELSE([AC_LANG_PROGRAM([[#inclu
AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <sched.h>]], [[cpuset_t* set = cpuset_create(); cpuset_destroy(set);]])],
[AC_DEFINE(HAVE_CPUSET_NETBSD, 1, [Define if cpuset_t and cpuset(3) exists.])])
-AC_COMPILE_IFELSE(
+AC_LINK_IFELSE(
[AC_LANG_PROGRAM([[#include <stdint.h>]],
[[uint64_t val = 0; __atomic_add_fetch(&val, 1, __ATOMIC_RELAXED);]])],
- [AC_DEFINE(HAVE_ATOMIC, 1, [Define to 1 if you have '__atomic' functions.])
- AC_LINK_IFELSE(
- [AC_LANG_PROGRAM([[#include <stdint.h>]],
- [[uint64_t val = 0; __atomic_add_fetch(&val, 1, __ATOMIC_RELAXED);]])],
- [atomic_LIBS=""],
- [atomic_LIBS="-latomic"]
- )],
- [atomic_LIBS=""]
+ [AC_DEFINE(HAVE_ATOMIC, 1, [Define to 1 if you have '__atomic' functions.])]
)
-AC_SUBST([atomic_LIBS])
# Prepare CFLAG_VISIBILITY to be used where needed
gl_VISIBILITY()

View File

@ -1,11 +0,0 @@
--- src/Makefile.am.orig 2018-01-29 16:11:17 UTC
+++ src/Makefile.am
@@ -399,7 +399,7 @@ libknotd_la_CPPFLAGS = $(AM_CPPFLAGS) $(
$(liburcu_CFLAGS) -DKNOTD_MOD_STATIC
libknotd_la_LDFLAGS = $(AM_LDFLAGS) -export-symbols-regex '^knotd_'
libknotd_la_LIBADD = libknot.la zscanner/libzscanner.la $(systemd_LIBS) \
- $(liburcu_LIBS) $(atomic_LIBS)
+ $(liburcu_LIBS)
###################
# Knot DNS Daemon #

View File

@ -11,4 +11,4 @@ AXFR and IXFR, DDNS and DNSSEC. Its key features:
- EDNS0 and DNSSEC extensions, including NSEC3
- NSID
WWW: http://www.knot-dns.cz/
WWW: https://www.knot-dns.cz/

View File

@ -102,5 +102,3 @@ sbin/keymgr
sbin/knotc
sbin/knotd
sbin/pykeymgr
@dir(knot,knot,) /var/db/knot
@dir(knot,knot,) /var/run/knot