lang/gcc6-aux: Adopt and unbreak with isl 20+ (+)

Take maintainership and keep ada in the tree.
This commit is contained in:
Dima Panov 2022-11-28 14:07:17 +03:00
parent 3c5671ce73
commit 03972bd1c8
3 changed files with 13 additions and 6 deletions

View File

@ -7,17 +7,13 @@ MASTER_SITES= http://downloads.dragonlace.net/src/:boot \
LOCAL/marino:boot LOCAL/ericbsd:boot GCC/${MS_SUBDIR}
DISTFILES= ${IDENTIFICATION}.tar.xz
MAINTAINER= ports@FreeBSD.org
MAINTAINER= fluffy@FreeBSD.org
COMMENT= Version of GCC ${GCC_BRANCH} with full Ada support
WWW= http://www.dragonlace.net/
LICENSE= GPLv3 GPLv3RLE
LICENSE_COMB= multi
# PR 248674
DEPRECATED= Based on way end-of-life version of GCC, has issues, and is unmaintained
EXPIRATION_DATE=2022-12-31
.include "${.CURDIR}/Makefile.common"
LANGS= c c++ ada

View File

@ -8,7 +8,7 @@ GCC_POINT= 4.1
GCC_VERSION= ${GCC_BRANCH}.${GCC_POINT}
SNAPSHOT= 20180516
BUILD_RELEASE= no
MAIN_PR= 2
MAIN_PR= 3
UTIL_PR= 0
ARMV7_PR= 0
ARM64_PR= 0

View File

@ -0,0 +1,11 @@
--- gcc/graphite.h.orig 2020-08-15 14:22:45.859708000 -0400
+++ gcc/graphite.h 2020-08-15 14:25:15.832648000 -0400
@@ -36,6 +36,8 @@
#include <isl/ilp.h>
#include <isl/schedule.h>
#include <isl/ast_build.h>
+#include <isl/id.h>
+#include <isl/space.h>
#ifdef HAVE_ISL_OPTIONS_SET_SCHEDULE_SERIALIZE_SCCS
/* isl 0.15 or later. */