lang/gcc11: Fix conflict on libgccjit.h and libgccjit++.h again

This is the second attempt to solve the conflict, see commits
- dc67e7d300 (first attempt);
- 9f0cd13014 (revert of the first
  attempt).

GCC 11, GCC 12 and GCC 13 install libgccjit.h and libgccjit++.h in the
same directory.

Fix conflict for GCC 11, which is GCC_DEFAULT, by installing those files
in a directory specific to GCC 11.

PR:		257060
Reviewed by:	yasu, jrm
Differential Revision:	https://reviews.freebsd.org/D37266
This commit is contained in:
Lorenzo Salvadore 2022-11-05 08:55:32 +01:00
parent 94c4159840
commit 0338e04504
No known key found for this signature in database
GPG Key ID: B58F7C3CF6DB8A38
4 changed files with 34 additions and 3 deletions

View File

@ -1,6 +1,6 @@
PORTNAME= gcc
PORTVERSION= 11.3.0
PORTREVISION= 4
PORTREVISION= 5
CATEGORIES= lang
MASTER_SITES= GCC
PKGNAMESUFFIX= ${SUFFIX}

View File

@ -0,0 +1,19 @@
--- gcc/Makefile.in.orig 2022-11-02 20:13:34 UTC
+++ gcc/Makefile.in
@@ -630,6 +630,8 @@ libsubdir = $(libdir)/gcc/$(real_target_noncanonical)/
# Directory in which the compiler finds libraries etc.
libsubdir = $(libdir)/gcc/$(real_target_noncanonical)/$(version)$(accel_dir_suffix)
+# Directory in which the compiler finds headers.
+libsubincludedir = $(libdir)/gcc/$(target_alias)/$(version)/include
# Directory in which the compiler finds executables
libexecsubdir = $(libexecdir)/gcc/$(real_target_noncanonical)/$(version)$(accel_dir_suffix)
# Directory in which all plugin resources are installed
@@ -3609,6 +3611,7 @@ installdirs:
# $(libdir)/gcc/include isn't currently searched by cpp.
installdirs:
$(mkinstalldirs) $(DESTDIR)$(libsubdir)
+ $(mkinstalldirs) $(DESTDIR)$(libsubincludedir)
$(mkinstalldirs) $(DESTDIR)$(libexecsubdir)
$(mkinstalldirs) $(DESTDIR)$(bindir)
$(mkinstalldirs) $(DESTDIR)$(includedir)

View File

@ -0,0 +1,14 @@
--- gcc/jit/Make-lang.in.orig 2022-11-02 17:25:43 UTC
+++ gcc/jit/Make-lang.in
@@ -355,9 +355,9 @@ jit.install-headers: installdirs
# Install hooks:
jit.install-headers: installdirs
$(INSTALL_DATA) $(srcdir)/jit/libgccjit.h \
- $(DESTDIR)$(includedir)/libgccjit.h
+ $(DESTDIR)$(libsubincludedir)/libgccjit.h
$(INSTALL_DATA) $(srcdir)/jit/libgccjit++.h \
- $(DESTDIR)$(includedir)/libgccjit++.h
+ $(DESTDIR)$(libsubincludedir)/libgccjit++.h
ifneq (,$(findstring mingw,$(target)))
jit.install-common: installdirs jit.install-headers

View File

@ -20,8 +20,6 @@ bin/gcov-tool%%SUFFIX%%
bin/gdc%%SUFFIX%%
bin/gfortran%%SUFFIX%%
bin/lto-dump%%SUFFIX%%
include/libgccjit++.h
include/libgccjit.h
man/man1/cpp%%SUFFIX%%.1.gz
man/man1/g++%%SUFFIX%%.1.gz
man/man1/gcc%%SUFFIX%%.1.gz