New port: audio/infamous-plugins-lv2: LV2 plugins for various sound effects
PR: 221553 Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D12955
This commit is contained in:
parent
d5091f63be
commit
032acb3a58
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=453486
@ -330,6 +330,7 @@
|
||||
SUBDIR += id3v2
|
||||
SUBDIR += idjc
|
||||
SUBDIR += ifp-line
|
||||
SUBDIR += infamous-plugins-lv2
|
||||
SUBDIR += ir-lv2
|
||||
SUBDIR += jack
|
||||
SUBDIR += jack-keyboard
|
||||
|
32
audio/infamous-plugins-lv2/Makefile
Normal file
32
audio/infamous-plugins-lv2/Makefile
Normal file
@ -0,0 +1,32 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= infamous-plugins
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 0.2.02-80
|
||||
DISTVERSIONSUFFIX= -ga68e73d
|
||||
CATEGORIES= audio
|
||||
PKGNAMESUFFIX= -lv2
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
COMMENT= LV2 plugins for various sound effects
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
BUILD_DEPENDS= lv2>0:audio/lv2 \
|
||||
${LOCALBASE}/lib/libfftw3.so:math/fftw3
|
||||
LIB_DEPENDS= libfftw3f.so:math/fftw3-float \
|
||||
libntk.so:x11-toolkits/ntk \
|
||||
libzita-resampler.so:audio/zita-resampler
|
||||
|
||||
USES= cmake:outsource localbase pkgconfig
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= ssj71
|
||||
GH_PROJECT= infamousPlugins
|
||||
USE_GNOME= cairo
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's| -g"|"|' \
|
||||
${WRKSRC}/src/*/CMakeLists.txt
|
||||
|
||||
.include <bsd.port.mk>
|
3
audio/infamous-plugins-lv2/distinfo
Normal file
3
audio/infamous-plugins-lv2/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1509826147
|
||||
SHA256 (ssj71-infamousPlugins-v0.2.02-80-ga68e73d_GH0.tar.gz) = 7c13a3b131b0daa45dc5070427dad3d59a3609ea27c9638c68523691ef2a5c5c
|
||||
SIZE (ssj71-infamousPlugins-v0.2.02-80-ga68e73d_GH0.tar.gz) = 421491
|
11
audio/infamous-plugins-lv2/files/patch-src_rule.c
Normal file
11
audio/infamous-plugins-lv2/files/patch-src_rule.c
Normal file
@ -0,0 +1,11 @@
|
||||
--- src/rule.c.orig 2017-08-06 09:17:53 UTC
|
||||
+++ src/rule.c
|
||||
@@ -43,7 +43,7 @@ void useage()
|
||||
return;
|
||||
}
|
||||
|
||||
-int main(int argc, int8_t **argv)
|
||||
+int main(int argc, const char **argv)
|
||||
{
|
||||
uint8_t rule=0xD0;//0x7c;
|
||||
uint8_t t;
|
16
audio/infamous-plugins-lv2/pkg-descr
Normal file
16
audio/infamous-plugins-lv2/pkg-descr
Normal file
@ -0,0 +1,16 @@
|
||||
Infamous Plugins is a collection of open-source LV2 plugins. It fills some
|
||||
holes, supplying non-existing plugins for linux audio.
|
||||
|
||||
* Cellular Automaton Synth
|
||||
* Envelope Follower
|
||||
* Hip2B
|
||||
* Cheap Distortion
|
||||
* Stuck
|
||||
* Power Cut
|
||||
* Power Up
|
||||
* EWham
|
||||
* Duffer
|
||||
* Lush Life
|
||||
* Bent Delat
|
||||
|
||||
WWW: http://ssj71.github.io/infamousPlugins
|
43
audio/infamous-plugins-lv2/pkg-plist
Normal file
43
audio/infamous-plugins-lv2/pkg-plist
Normal file
@ -0,0 +1,43 @@
|
||||
bin/infamous-rule
|
||||
lib/lv2/bentdelay.lv2/bentdelay.so
|
||||
lib/lv2/bentdelay.lv2/bentdelay.ttl
|
||||
lib/lv2/bentdelay.lv2/manifest.ttl
|
||||
lib/lv2/casynth.lv2/casynth.so
|
||||
lib/lv2/casynth.lv2/casynth.ttl
|
||||
lib/lv2/casynth.lv2/casynth_presets.ttl
|
||||
lib/lv2/casynth.lv2/casynth_ui.so
|
||||
lib/lv2/casynth.lv2/manifest.ttl
|
||||
lib/lv2/cheapdist.lv2/cheapdist.so
|
||||
lib/lv2/cheapdist.lv2/cheapdist.ttl
|
||||
lib/lv2/cheapdist.lv2/cheapdist_ui.so
|
||||
lib/lv2/cheapdist.lv2/manifest.ttl
|
||||
lib/lv2/envfollower.lv2/envfollower.so
|
||||
lib/lv2/envfollower.lv2/envfollower.ttl
|
||||
lib/lv2/envfollower.lv2/envfollowerCV_ui.so
|
||||
lib/lv2/envfollower.lv2/envfollower_ui.so
|
||||
lib/lv2/envfollower.lv2/manifest.ttl
|
||||
lib/lv2/ewham.lv2/ewham.so
|
||||
lib/lv2/ewham.lv2/ewham.ttl
|
||||
lib/lv2/ewham.lv2/manifest.ttl
|
||||
lib/lv2/hip2b.lv2/hip2b.so
|
||||
lib/lv2/hip2b.lv2/hip2b.ttl
|
||||
lib/lv2/hip2b.lv2/hip2b_presets.ttl
|
||||
lib/lv2/hip2b.lv2/hip2b_ui.so
|
||||
lib/lv2/hip2b.lv2/manifest.ttl
|
||||
lib/lv2/lushlife.lv2/lushlife.so
|
||||
lib/lv2/lushlife.lv2/lushlife.ttl
|
||||
lib/lv2/lushlife.lv2/lushlife_presets.ttl
|
||||
lib/lv2/lushlife.lv2/lushlife_ui.so
|
||||
lib/lv2/lushlife.lv2/manifest.ttl
|
||||
lib/lv2/powercut.lv2/manifest.ttl
|
||||
lib/lv2/powercut.lv2/powercut.so
|
||||
lib/lv2/powercut.lv2/powercut.ttl
|
||||
lib/lv2/powercut.lv2/powercut_ui.so
|
||||
lib/lv2/powerup.lv2/manifest.ttl
|
||||
lib/lv2/powerup.lv2/powerup.so
|
||||
lib/lv2/powerup.lv2/powerup.ttl
|
||||
lib/lv2/powerup.lv2/powerup_ui.so
|
||||
lib/lv2/stuck.lv2/manifest.ttl
|
||||
lib/lv2/stuck.lv2/stuck.so
|
||||
lib/lv2/stuck.lv2/stuck.ttl
|
||||
lib/lv2/stuck.lv2/stuck_ui.so
|
Loading…
Reference in New Issue
Block a user