Update to dumpasn1-20030329, unbreak on 4.x [1] and drop maintainership.
PR: 50957 [1] Submitted by: Oliver Eikemeier <eikemeier@fillmore-labs.com>
This commit is contained in:
parent
102c8761f1
commit
0317e1f8dd
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=84335
@ -6,22 +6,18 @@
|
||||
#
|
||||
|
||||
PORTNAME= dumpasn1
|
||||
PORTVERSION= 20030222
|
||||
PORTVERSION= 20030329
|
||||
CATEGORIES= converters security
|
||||
MASTER_SITES= http://www.cs.auckland.ac.nz/~pgut001/
|
||||
DISTFILES= dumpasn1.c dumpasn1.cfg
|
||||
DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
|
||||
EXTRACT_ONLY=
|
||||
|
||||
MAINTAINER= kris@FreeBSD.org
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Dumps the contents of an ASN.1 encoded file, e.g. an SSL certificate
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 500000
|
||||
BROKEN= "Needs wprintf(), which isn't available on FreeBSD <5"
|
||||
.endif
|
||||
|
||||
do-extract:
|
||||
@${MKDIR} ${WRKSRC}
|
||||
@${CP} ${DISTDIR}/${DIST_SUBDIR}/dumpasn1.c ${WRKSRC}
|
||||
|
@ -1,2 +1,2 @@
|
||||
MD5 (dumpasn1-20030222/dumpasn1.c) = fb4aab1f9c5153cb50bdac031086da50
|
||||
MD5 (dumpasn1-20030222/dumpasn1.cfg) = e0469908e15de921909a844b0f6fa5f5
|
||||
MD5 (dumpasn1-20030329/dumpasn1.c) = 720c630b4f4f17d4bf85b240eceeb8da
|
||||
MD5 (dumpasn1-20030329/dumpasn1.cfg) = f1c0a5c1108b7aad85afe3c5111ff906
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- dumpasn1.c.orig Sat Dec 14 15:13:32 2002
|
||||
+++ dumpasn1.c Sat Dec 14 15:15:24 2002
|
||||
@@ -292,11 +292,13 @@
|
||||
@@ -297,11 +297,13 @@
|
||||
beginning with a '$' uses the appropriate environment variable. In
|
||||
addition under Unix we also walk down $PATH looking for it */
|
||||
|
||||
@ -14,3 +14,21 @@
|
||||
|
||||
#if defined( __TANDEM_NSK__ )
|
||||
|
||||
@@ -1215,14 +1217,14 @@
|
||||
{
|
||||
lineLength++;
|
||||
i++; /* We've read two characters for a wchar_t */
|
||||
-#if defined( __WIN32__ ) || ( defined( __UNIX__ ) && !defined( __MACH__ ) )
|
||||
+#if defined( __WIN32__ ) || ( !( defined( __FreeBSD__ ) && __FreeBSD__ < 5 ) && defined( __UNIX__ ) && !defined( __MACH__ ) )
|
||||
wprintf( L"%c", wCh );
|
||||
#else
|
||||
/* This could use some improvement */
|
||||
- #ifndef __MACH__
|
||||
+ #if !defined( __MACH__ ) && !defined( __FreeBSD__ )
|
||||
for( p = outBuf; *p != '\0'; p++ )
|
||||
*p = asciiToEbcdic( *p );
|
||||
- #endif /* OS X */
|
||||
+ #endif /* OS X || FreeBSD */
|
||||
fprintf( output, "%s", outBuf );
|
||||
#endif /* OS-specific charset handling */
|
||||
fPos += 2;
|
||||
|
Loading…
Reference in New Issue
Block a user