x11/xmenu: create port

XMenu is a menu utility for X. XMenu receives a menu specification in stdin,
shows a menu for the user to select one of the options, and outputs the option
selected to stdout. XMenu can be controlled both via mouse and via keyboard.

WWW: https://github.com/phillbush/xmenu

PR:		248279
Submitted by:	Lewis Cook <vulcan@wired.sh>
This commit is contained in:
Steve Wills 2020-09-04 00:25:11 +00:00
parent 96c7941402
commit 02e3d47b3c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=547491
5 changed files with 65 additions and 0 deletions

View File

@ -453,6 +453,7 @@
SUBDIR += xman
SUBDIR += xmangekyou
SUBDIR += xmascot
SUBDIR += xmenu
SUBDIR += xmessage
SUBDIR += xmh
SUBDIR += xmodmap

41
x11/xmenu/Makefile Normal file
View File

@ -0,0 +1,41 @@
# $FreeBSD$
PORTNAME= xmenu
DISTVERSIONPREFIX= v
DISTVERSION= 4.3.1
CATEGORIES= x11
MAINTAINER= vulcan@wired.sh
COMMENT= X11 menu utility
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/README.md
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libImlib2.so:graphics/imlib2
USES= compiler:c11 xorg
USE_GITHUB= yes
GH_ACCOUNT= phillbush
USE_XORG= x11 xft xinerama
MAKE_ARGS= FREETYPEINC="${LOCALBASE}/include/freetype2" \
MANPREFIX="${PREFIX}/man" \
PREFIX="${PREFIX}"
PLIST_FILES= bin/${PORTNAME} \
man/man1/${PORTNAME}.1.gz
PORTDOCS= README.md
PORTEXAMPLES= icons/* xmenu.sh
OPTIONS_DEFINE= DOCS EXAMPLES
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTEXAMPLES}" ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>

3
x11/xmenu/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1598877606
SHA256 (phillbush-xmenu-v4.3.1_GH0.tar.gz) = c0e1e15ed3cd88ea9f4ed1a04664a7b8c743b012749578cfd2606980a7ee972c
SIZE (phillbush-xmenu-v4.3.1_GH0.tar.gz) = 137703

View File

@ -0,0 +1,15 @@
--- Makefile.orig 2020-07-23 20:39:33 UTC
+++ Makefile
@@ -17,8 +17,10 @@ clean:
-rm ${OBJS} ${PROG}
install: all
- install -D -m 755 ${PROG} ${DESTDIR}${PREFIX}/bin/${PROG}
- install -D -m 644 ${PROG}.1 ${DESTDIR}${MANPREFIX}/man1/${PROG}.1
+ mkdir -p ${DESTDIR}${MANPREFIX}/man1
+ mkdir -p ${DESTDIR}${PREFIX}/bin
+ ${BSD_INSTALL_PROGRAM} ${PROG} ${DESTDIR}${PREFIX}/bin
+ ${BSD_INSTALL_MAN} ${PROG}.1 ${DESTDIR}${MANPREFIX}/man1
uninstall:
rm -f ${DESTDIR}${PREFIX}/bin/${PROG}

5
x11/xmenu/pkg-descr Normal file
View File

@ -0,0 +1,5 @@
XMenu is a menu utility for X. XMenu receives a menu specification in stdin,
shows a menu for the user to select one of the options, and outputs the option
selected to stdout. XMenu can be controlled both via mouse and via keyboard.
WWW: https://github.com/phillbush/xmenu