security/openssh-portable: libfido fix went in 505373243

This commit is contained in:
Bryan Drewery 2021-10-15 10:40:19 -07:00
parent 564decbe0b
commit 02dbfbc676
2 changed files with 0 additions and 18 deletions

View File

@ -89,8 +89,6 @@ BSM_CONFIGURE_ON= --with-audit=bsm
FIDO_U2F_LIB_DEPENDS= libfido2.so:security/libfido2
FIDO_U2F_CONFIGURE_ON= --with-security-key-builtin
FIDO_U2F_CONFIGURE_OFF= --disable-security-key
# Until https://reviews.freebsd.org/D27289 is committed
FIDO_U2F_EXTRA_PATCHES= ${FILESDIR}/extra-patch-libfido2-configure.ac
BLACKLISTD_EXTRA_PATCHES= ${FILESDIR}/extra-patch-blacklistd

View File

@ -1,16 +0,0 @@
Workaround libfido2 package having a libfido2.pc that requires libcrypto
even with base OpenSSL which does not provide the proper pc file.
--- configure.ac.orig 2020-11-19 14:21:03.890890000 -0800
+++ configure.ac 2020-11-19 14:21:57.061193000 -0800
@@ -3256,8 +3256,8 @@ if test "x$enable_sk" = "xyes" -a "x$enable_sk_interna
fi
fi
if test "x$use_pkgconfig_for_libfido2" = "xyes"; then
- LIBFIDO2=`$PKGCONFIG --libs libfido2`
- CPPFLAGS="$CPPFLAGS `$PKGCONFIG --cflags libfido2`"
+ LIBFIDO2="-lfido2 -lcrypto"
+ #CPPFLAGS="$CPPFLAGS `$PKGCONFIG --cflags libfido2`"
else
LIBFIDO2="-lfido2 -lcbor"
fi