Remove unreachable code due to OSVERSION checks

This commit is contained in:
Edwin Groothuis 2007-04-16 11:48:02 +00:00
parent 1121299f31
commit 02c202524b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=190113
2 changed files with 1 additions and 45 deletions

View File

@ -22,12 +22,6 @@ PLIST_SUB= ARCH=${ARCH}
# Do not strip binaries
STRIP=
.include <bsd.port.pre.mk>
.if ${OSVERSION} <= 500036
EXTRA_PATCHES= ${FILESDIR}/extra-patch-ucontext
.endif
do-install:
${MKDIR} ${DATADIR}
${MKDIR} ${DATADIR}/bin
@ -43,4 +37,4 @@ do-install:
${INSTALL_SCRIPT} ${WRKDIR}/libmicro-bench ${PREFIX}/bin/libmicro-bench
${INSTALL_SCRIPT} ${WRKSRC}/multiview ${PREFIX}/bin/multiview
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,38 +0,0 @@
--- setcontext.c.orig Sat Aug 6 16:18:46 2005
+++ setcontext.c Sat Aug 6 16:19:29 2005
@@ -57,7 +57,7 @@
benchmark(void *tsd, result_t *res)
{
volatile int i;
-
+#if 0
ucontext_t uc;
i = 0;
@@ -68,6 +68,7 @@
(void) setcontext(&uc);
res->re_count += lm_optB;
+#endif
return (0);
}
--- getcontext.c.orig Sat Aug 6 16:18:39 2005
+++ getcontext.c Sat Aug 6 16:19:06 2005
@@ -59,7 +59,7 @@
benchmark(void *tsd, result_t *res)
{
int i;
-
+#if 0
for (i = 0; i < lm_optB; i += 10) {
ucontext_t uc;
(void) getcontext(&uc);
@@ -74,6 +74,6 @@
(void) getcontext(&uc);
}
res->re_count = i;
-
+#endif
return (0);
}