Update to 0.18.3.

PR:		ports/58714
Submitted by:	mezz (maintainer)
This commit is contained in:
Adam Weinberger 2003-11-07 06:39:37 +00:00
parent 82162ecf7e
commit 02a2bd0542
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=93286
4 changed files with 19 additions and 57 deletions

View File

@ -6,17 +6,20 @@
#
PORTNAME= neverputt
PORTVERSION= 0.18.2
PORTVERSION= 0.18.3
CATEGORIES= games
MASTER_SITES= http://icculus.org/neverball/
MAINTAINER= mezz7@cox.net
COMMENT= 3D miniature golf for 1-4 players
BUILD_DEPENDS= ${FREETYPE_CONFIG}:${PORTSDIR}/print/freetype2
LIB_DEPENDS= SDL_ttf.3:${PORTSDIR}/graphics/sdl_ttf \
SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
SDL_image.10:${PORTSDIR}/graphics/sdl_image
FREETYPE_CONFIG?= ${LOCALBASE}/bin/freetype-config
USE_BZIP2= yes
USE_SDL= yes
USE_GMAKE= yes
@ -28,6 +31,8 @@ DIRS= bgm map mtrl png snd sol ttf
post-patch:
@${REINPLACE_CMD} -e 's|./data|${DATADIR}/data|g' \
${WRKSRC}/config.h
@${REINPLACE_CMD} -e 's|%%FREETYPE_CONFIG%%|${FREETYPE_CONFIG}|g' \
${WRKSRC}/Makefile
do-install:
.for ii in ${DIRS}

View File

@ -1 +1 @@
MD5 (neverputt-0.18.2.tar.bz2) = 0b166cd83772e7d6be4fde80e1979800
MD5 (neverputt-0.18.3.tar.bz2) = c90426bc8936b6796703b74c7d3f1056

View File

@ -1,14 +1,17 @@
--- Makefile.orig Mon Oct 27 21:35:19 2003
+++ Makefile Mon Oct 27 21:37:26 2003
@@ -3,15 +3,15 @@
--- Makefile.orig Thu Oct 30 02:08:58 2003
+++ Makefile Thu Oct 30 02:09:05 2003
@@ -3,19 +3,18 @@
# Maybe you need one of these. Maybe you don't.
-#X11_PATH= -L/usr/X11/lib
-#X11_PATH= -L/usr/X11R6/lib
+X11_PATHL= -L${X11BASE}/lib
+X11_PATH= -L${X11BASE}/lib
+X11_PATHI= -I${X11BASE}/include
OGL_LIBS= -lGLU -lGL -lm
#OGL_LIBS= -lm # Think Different
#------------------------------------------------------------------------------
-CFLAGS= -Wall -g -ansi $(shell sdl-config --cflags)
@ -16,12 +19,13 @@
-X11_LIBS= $(X11_PATH) -lGLU -lGL -lm
-SDL_LIBS= $(shell sdl-config --libs)
+X11_LIBS= $(X11_PATHL) -lGLU -lGL -lm
-FT2_LIBS= $(shell freetype-config --libs)
+SDL_LIBS= $(shell ${SDL_CONFIG} --libs)
+FT2_LIBS= $(shell %%FREETYPE_CONFIG%% --libs)
MAPC_TARG= mapc
GAME_TARG= neverputt
@@ -39,8 +39,8 @@
@@ -42,8 +41,8 @@
glext.o \
main.o
@ -30,5 +34,5 @@
+MAPC_DEPS= $(GAME_SRCS:.c)
+GAME_DEPS= $(GAME_OBJS:.o)
MAPC_LIBS= $(SDL_LIBS) -lSDL_image $(X11_LIBS)
GAME_LIBS= $(SDL_LIBS) -lSDL_image -lSDL_ttf -lSDL_mixer -lfreetype $(X11_LIBS)
MAPC_LIBS= $(X11_PATH) $(SDL_LIBS) -lSDL_image $(OGL_LIBS)
GAME_LIBS= $(X11_PATH) $(SDL_LIBS) -lSDL_image -lSDL_ttf -lSDL_mixer $(FT2_LIBS) $(OGL_LIBS)

View File

@ -1,47 +0,0 @@
--- config.c.orig Mon Oct 27 02:06:05 2003
+++ config.c Mon Oct 27 02:08:21 2003
@@ -46,7 +46,7 @@
static int audio_rate = CONFIG_DEF_AUDIO_RATE;
static int audio_buff = CONFIG_DEF_AUDIO_BUFF;
static int mouse_sense = CONFIG_DEF_MOUSE_SENSE;
-static int nice = CONFIG_DEF_NICE;
+static int nice1 = CONFIG_DEF_NICE;
static int fps = CONFIG_DEF_FPS;
static int sound_vol = CONFIG_DEF_SOUND_VOL;
static int music_vol = CONFIG_DEF_MUSIC_VOL;
@@ -152,7 +152,7 @@
if (strcmp(key, "audio_rate") == 0) audio_rate = val;
if (strcmp(key, "audio_buff") == 0) audio_buff = val;
if (strcmp(key, "mouse_sense") == 0) mouse_sense = val;
- if (strcmp(key, "nice") == 0) nice = val;
+ if (strcmp(key, "nice") == 0) nice1 = val;
if (strcmp(key, "fps") == 0) fps = val;
if (strcmp(key, "sound_vol") == 0) sound_vol = val;
if (strcmp(key, "music_vol") == 0) music_vol = val;
@@ -178,7 +178,7 @@
fprintf(fp, "audio_rate %d\n", audio_rate);
fprintf(fp, "audio_buff %d\n", audio_buff);
fprintf(fp, "mouse_sense %d\n", mouse_sense);
- fprintf(fp, "nice %d\n", nice);
+ fprintf(fp, "nice %d\n", nice1);
fprintf(fp, "fps %d\n", fps);
fprintf(fp, "sound_vol %d\n", sound_vol);
fprintf(fp, "music_vol %d\n", music_vol);
@@ -198,7 +198,7 @@
int config_rate(void) { return audio_rate; }
int config_buff(void) { return audio_buff; }
int config_sens(void) { return mouse_sense; }
-int config_nice(void) { return nice; }
+int config_nice(void) { return nice1; }
int config_fps (void) { return fps; }
int config_sound(void) { return sound_vol; }
int config_music(void) { return music_vol; }
@@ -305,7 +305,7 @@
void config_tog_nice(void)
{
- nice = nice ? 0 : 1;
+ nice1 = nice1 ? 0 : 1;
}
void config_tog_fps(void)