Update to 1.2.1.

PR:		34573
Submitted by:	Joe Clarke <marcus@marcuscom.com>
This commit is contained in:
Maxim Sobolev 2002-02-07 14:13:56 +00:00
parent b9d24b4ab8
commit 027909387b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=54312
4 changed files with 90 additions and 6 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= glimmer
PORTVERSION= 1.2.0
PORTVERSION= 1.2.1
CATEGORIES= editors gnome python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -26,6 +26,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-regex
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -D_REGEX_H_ -D_REGEX_H" \
LIBS="-L${LOCALBASE}/lib -lgnuregex"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
.if exists(/usr/lib/libcrypto.a)
PYTHON_LIBS= -lssl -lcrypto
.endif
@ -35,7 +36,7 @@ pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|-lpython|${PYTHON_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
@find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'

View File

@ -1 +1 @@
MD5 (glimmer-1.2.0.tar.gz) = 167abcd108032218cafa6dbaa8e1cb77
MD5 (glimmer-1.2.1.tar.gz) = ca0a856b58f91b1bdef7f0828b31490a

View File

@ -1,9 +1,78 @@
$FreeBSD$
--- configure.orig Fri Nov 16 16:02:10 2001
+++ configure Fri Nov 16 16:02:49 2001
@@ -8320,7 +8320,7 @@
--- configure.orig Thu Feb 7 15:54:38 2002
+++ configure Thu Feb 7 16:09:08 2002
@@ -8001,7 +8001,7 @@
#line 8001 "configure"
#include "confdefs.h"
#include <stdlib.h>
-#include <iconv.h>
+#include <giconv.h>
int
main ()
{
@@ -8032,12 +8032,12 @@
rm -f conftest.$ac_objext conftest$ac_exeext conftest.$ac_ext
if test "$am_cv_func_iconv" != yes; then
am_save_LIBS="$LIBS"
- LIBS="$LIBS -liconv"
+ LIBS="$LIBS -lgiconv"
cat >conftest.$ac_ext <<_ACEOF
#line 8037 "configure"
#include "confdefs.h"
#include <stdlib.h>
-#include <iconv.h>
+#include <giconv.h>
int
main ()
{
@@ -8090,7 +8090,7 @@
#include "confdefs.h"
#include <stdlib.h>
-#include <iconv.h>
+#include <giconv.h>
extern
#ifdef __cplusplus
"C"
@@ -8144,7 +8144,7 @@
fi
LIBICONV=
if test "$am_cv_lib_iconv" = yes; then
- LIBICONV="-liconv"
+ LIBICONV="-lgiconv"
fi
echo "$as_me:8150: checking for nl_langinfo and CODESET" >&5
@@ -8605,7 +8605,7 @@
echo "${ECHO_T}no" >&6
fi
- CATOBJEXT=.gmo
+ CATOBJEXT=.mo
fi
fi
@@ -8729,7 +8729,7 @@
BUILD_INCLUDED_LIBINTL=yes
USE_INCLUDED_LIBINTL=yes
- CATOBJEXT=.gmo
+ CATOBJEXT=.mo
INTLLIBS="\$(top_builddir)/intl/libintl.a $LIBICONV"
LIBS=`echo " $LIBS " | sed -e 's/ -lintl / /' -e 's/^ //' -e 's/ $//'`
fi
@@ -8819,7 +8819,7 @@
fi
for lang in $ALL_LINGUAS; do
- GMOFILES="$GMOFILES $lang.gmo"
+ GMOFILES="$GMOFILES $lang.mo"
POFILES="$POFILES $lang.po"
done
@@ -10202,7 +10202,7 @@
fi
echo System regex.......$use_system_regex

View File

@ -0,0 +1,14 @@
$FreeBSD$
--- po/Makefile.in.in 2002/02/07 13:50:02 1.1
+++ po/Makefile.in.in 2002/02/07 13:51:15
@@ -52,7 +52,7 @@
POTFILES = \
CATALOGS = @CATALOGS@
-CATOBJEXT = @CATOBJEXT@
+CATOBJEXT = .mo
INSTOBJEXT = @INSTOBJEXT@
.SUFFIXES: